Package Details: torch7-trepl-git r158.06128f9-1

Git Clone URL: https://aur.archlinux.org/torch7-trepl-git.git (read-only)
Package Base: torch7-trepl-git
Description: A REPL for Torch
Upstream URL: https://github.com/torch/trepl
Licenses: BSD
Conflicts: torch7-trepl
Provides: torch7-trepl
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 14
Popularity: 0.823183
First Submitted: 2015-11-17 20:46
Last Updated: 2016-08-28 14:55

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

petronny commented on 2016-08-28 11:40

missing makedepends: git

aperez commented on 2015-11-18 20:12

@brk0_0: Good catch! I have updated “torch7-paths-git” to not depend on “torch7-git” (it can be used independently of Torch after all!), and made “torch7-git” depend on “torch7-paths-git” as you have suggested. Thanks!

brk0_0 commented on 2015-11-17 23:31

The problem was solved installing 'troch7-paths-git'. Maybe marking it as a dependence (of torch7-git, I believe) is needed.

brk0_0 commented on 2015-11-17 23:20

After downloading this, I try to run 'th' and it raises the following error:

luajit: /usr/share/lua/5.1/trepl/init.lua:692: attempt to call field 'setheaptracking' (a nil value)
stack traceback:
/usr/share/lua/5.1/trepl/init.lua:692: in main chunk
[C]: in function 'require'
/usr/bin/th:104: in main chunk
[C]: at 0x004046e0