Package Details: torchlight-hib 1.15+h20130521-1

Git Clone URL: https://aur.archlinux.org/torchlight-hib.git (read-only)
Package Base: torchlight-hib
Description: A hack and slash action role-playing game (Humble Bundle version)
Upstream URL: http://www.torchlightgame.com/
Keywords: 3D action ARPG dungeon game hack-and-slash humble role-playing RPG top-down
Licenses: custom:commercial
Submitter: smls
Maintainer: smls
Last Packager: smls
Votes: 29
Popularity: 0.013822
First Submitted: 2012-09-19 00:12
Last Updated: 2015-07-10 15:58

Latest Comments

smls commented on 2014-08-06 10:39

That being said, when I have problems passing a CAPTCHA, what usually helps is to temporarily deactivate browser plugins like NoScript or AdBlock, or failing that try a different browser (e.g. Chromium instead of Firefox).

smls commented on 2014-08-06 10:36

Huh? Not sure what CAPTCHA you're talking about.

To install this package, you need to own the Humble Bundle version of the game. (It was part of Humble Indie Bundle 6, which was sold in September 2012).

Then either download the game archive manually from your Humble Bundle library or install hib-dlagent, and set up your DLAGENT in /etc/makepkg.conf accordingly (see https://bbs.archlinux.org/viewtopic.php?pid=1328240#p1328240).

akirashirase commented on 2014-08-05 04:31

I'm having a prob with the captcha image
I'm pretty sure I enter the correct words
and I tried it separated and not separated
but it still prompts me another image and
the installation got stuck on there. help anyone :O

tsester commented on 2013-07-06 06:00

@EstebanMac:

- install hib-dlagent from AUR
- set 'hib::/usr/bin/hib-dlagent -u your email -p your_pass' in DLAGENTS in /etc/makepkg.conf :D

Anonymous comment on 2013-07-06 01:58

I have a problem, It shows me this error mesage:

Could not find hib://Torchlight-2013-05-21.sh. Manually download it to "/home/esteban/AUR PKGBUILD/torchlight-hib", or set up a hib:// DLAGENT in /etc/makepkg.conf.

but I don't know how to add a hib dlagent

Anonymous comment on 2013-06-05 00:45

Is anyone experiencing Segmentation fault with the latest version?
I downgraded to the old version and it worked for me.

danbruegge commented on 2013-05-31 19:02

@smls, don't know why, but i tried again with LOCAL_PACKAGE_SOURCES and it worked. So, sorry for making trouble. :D

Nice to hear that you will improve the process. :) Thanks for your work.

smls commented on 2013-05-30 18:28

@haenx
What's the exact error message? Are you sure Torchlight-2013-05-21.sh exists in that directory, is readable, and has the right checksum? And what AUR helper are you using?

In any case you don't have to use LOCAL_PACKAGE_SOURCES mechanism if you don't want to, you can always use the traditional method of manually copying or symlinking the game archive to the temporary folder that contains the PKGBUILD and then run makepkg (or you AUR helper) again.

(Also I'm planning to move my HIB packages to a simpler solution based on makepkg's dlagent mechanism in the future, but I still need to work out some things.)

danbruegge commented on 2013-05-30 17:11

Me, again...
Where is my problem, i can't install the package...

`export LOCAL_PACKAGE_SOURCES=/home/haenx/Downloads/hib-games` don't work. Why it must be so hard?..

smls commented on 2013-05-29 18:27

Yeah, it's finally fixed. Package updated.

fettouhi commented on 2013-05-29 15:16

New version was released yesterday. The no face bug should now be fixed.

CPUnltd commented on 2012-12-12 09:55

Verifying archive integrity...Error in MD5 checksums: 5ddb167dc81aa32b4deff1fa64358b70 is different from 9deaeb561decd3cdbcd9a5f4da3853bc

danbruegge commented on 2012-11-14 11:34

and again learned new stuff. thanks! :)

smls commented on 2012-11-14 11:15

@haenx:
The $_gamepkg variable only holds the file name of the installer, it's not supposed to contain the full path. In fact you shouldn't have to edit the PKGBUILD at all.

You provide the installer by either copying/symlinking it into the PKGBUILD directory (which depends on the AUR helper you use), or by setting...
export LOCAL_PACKAGE_SOURCES=/home/haenx/Downloads
...in the terminal from which you run makepkg or your AUR helper.

danbruegge commented on 2012-11-14 11:13

But it is definitively the right path.

danbruegge commented on 2012-11-14 11:07

@smls: That the given path is wrong.

smls commented on 2012-11-14 11:04

@haenx: What error message do you get?

danbruegge commented on 2012-11-13 20:09

I'am unable to install the game. The given path in _gamepkg seems to be wrong..

Here is my path: _gamepkg="/home/haenx/Downloads/hib-games/Torchlight-${_hibver}.sh"

smls commented on 2012-11-12 01:31

@mbostwick
Ah you're right, I can confirm that behavior. I find it weird though, as I would have thought that with the --no-register switch it shouldn't care about package managers at all.
Anyhow, I added '--packager pacman' for now, thanks for the report.

mbostwick commented on 2012-11-11 20:15

Error: Multiple package managers were found: rpm, pacman, dpkg
Please use the --packager option to specify which one should be used.
If you don't specify the packager(and the user has the other pkgs systems installed, which may happen for example to support alien_package_converter)

smls commented on 2012-10-19 12:15

@Theodan: To what end? The installer's built-in package generation and installation feature does not make sense here. All the installer needs to do for our purposes, is to extract the game into $srcdir. Makepkg (or your AUR helper) will handle the packaging after executing the PKGBUILD.

smls commented on 2012-10-19 12:14

@Theodan: To what end? The installer's built-in package generation and installation feature does not make sense for the PKGBUILD. All the installer needs to do for our purposes, is to extract the game into $srcdir. Makepkg (or your AUR helper) will handle the packaging after executing the PKGBUILD.

Thaodan commented on 2012-10-19 11:40

please add '--packager pacman' as option for Torchlight-*.sh

JesusMcCloud commented on 2012-10-07 13:57

@hilton, smls
mesa-full pulls latest mesa from git that's why it fixes the crash

smls commented on 2012-10-06 20:38

@JesusMcCloud: I'm aware of that crash, and following the upstream discussion. The problem is due to an overly strict error condition that was introduced in a recent version of mesa, causing it to fail when loading S3 compressed textures with mipmaps of certain sizes - like the trail37.dds texture file in this case (which is bundled inside /opt/Torchlight/pak.zip).
Known workarounds are to either manually resize & resave that texture file with Gimp, or replace it with a copy of one of the other (non-problematic) textures from the game.
A patch to fix this has already been committed to mesa (upstream commit df4a88ac4398ec4c152eb57a7129c07bb623edd7, see https://bugs.freedesktop.org/show_bug.cgi?id=55445), but I don't know when it will make it into a release.

Not sure why mesa-full fixes it for you, maybe it either pulls an outdated revision of mesa from before the bug was introduced, or a devel snapshot which already includes the fix?

smls commented on 2012-10-06 20:37

@JesusMcCloud: I'm aware of that crash, following the upstream discussion. The problem is due to an overly strict error condition that was introduced in a recent version of mesa, causing it to fail when loading S3 compressed textures with mipmaps of certain sizes - like the trail37.dds texture file in this case (which is bundled inside /opt/Torchlight/pak.zip).
Known workarounds are to either manually resize & resave that texture file with Gimp, or replace it with a copy of one of the other (non-problematic) textures from the game.
A patch to fix this has already been committed to mesa (upstream commit df4a88ac4398ec4c152eb57a7129c07bb623edd7, see https://bugs.freedesktop.org/show_bug.cgi?id=55445), but I don't know when it will make it into a release.

Not sure why mesa-full fixes it for you, maybe it either pulls an outdated revision of mesa from before the bug was introduced, or a devel snapshot which already includes the fix?

hilton commented on 2012-10-06 17:03

@JesusMcCloud
With this mesa-full-git package providing libgl we would need to uninstall our proprietary drivers, like nvidia-utils that provides libgl.

Where in that thread you concluded that mesa-full is the solution for the problem? Note that the official mesa package is actually `fuller` than this mesa-full package, considering the build flags they use. If you really need the entire mesa stack, you can install the split packages from the official repo http://www.archlinux.org/packages/extra/x86_64/mesa/ to test.

Sadly I didn't get to 19th floor yet, so I can't help debugging that.

JesusMcCloud commented on 2012-10-06 10:09

I actually need mesa-full in order to run it crash-free (see http://forums.runicgames.com/viewtopic.php?f=24&t=34893 )
maybe this should be a dependency instead of mesa

smls commented on 2012-10-02 18:48

Updated to 2012-09-26 (wonder why it's called that, seeing as it was released today...)

Denommus commented on 2012-10-02 13:38

New version 2012-09-30

Denommus commented on 2012-10-02 13:35

New version 2012-09-30

tsester commented on 2012-10-02 11:18

new version 2012-09-26

tsester commented on 2012-09-25 17:42

woohoo

smls commented on 2012-09-25 13:58

Updated to 2012-09-24.

kelytha commented on 2012-09-25 08:26

Build 2012-09-25 is out.

smls commented on 2012-09-24 21:26

@darkraid1: Can you confirm that this is still required with the updated 2012-09-20 Humble Bundle version?

Anonymous comment on 2012-09-24 19:03

There have been a lot of users which experienced crashes, because they didn't have libtxc_dxtn installed.
I'd like you to add libtxc_dxtn as a dependency.

Watch this thread: http://forums.runicgames.com/viewtopic.php?p=328995#p328995

smls commented on 2012-09-20 18:46

updated.

neuromancer85 commented on 2012-09-20 17:57

My updated PKGBUILD for the impatients... :D
http://pastebin.com/NNK3MGJj

hickop commented on 2012-09-20 09:48

2012-09-20 available which fix crashs

smls commented on 2012-09-20 09:04

Yeah, you're right.

neuromancer85 commented on 2012-09-20 08:14

Why "pkgrel" is 0? Shouldn't it be >= 1?

smls commented on 2012-09-20 07:37

@minus: fixed.

minus commented on 2012-09-19 11:00

It seems there's something a bit wrong, the following directory is installed too:
/opt/Torchlight/{/tmp/yaourt-tmp-thomas/aur-torchlight-hib/pkg}/opt/Torchlight/

minus commented on 2012-09-19 10:57

It seems there's something a bit wrong, the following directory is installed too:
/opt/Torchlight/{/tmp/yaourt-tmp-thomas/aur-torchlight-hib/pkg}/opt/Torchlight/

gtmanfred commented on 2012-09-19 01:51

and DLAGENTS