Package Details: tragtor 0.9.2-1

Git Clone URL: https://aur.archlinux.org/tragtor.git (read-only)
Package Base: tragtor
Description: A graphical user interface for ffmpeg
Upstream URL: http://mein-neues-blog.de/tragtor-gui-for-FFmpeg/
Licenses: GPL
Submitter: adi64
Maintainer: adi64
Last Packager: adi64
Votes: 65
Popularity: 0.775763
First Submitted: 2009-10-16 17:51
Last Updated: 2015-07-28 09:18

Latest Comments

adi64 commented on 2015-07-25 08:38

Thanks for the notice! Unfortunately I am only able to update the package next week. Sorry for the delay!

ItachiSan commented on 2015-07-22 14:53

A new version is upstream, I pointed out some small bugs to the dev (errors in profiles deletion/edit and in name title)
The version number is 0.9.2

adi64 commented on 2014-06-27 14:17

thanks for the hint, Regulus, I fixed that in 80-2 :)

adi64 commented on 2014-06-27 14:17

thanks for the hint, Regulus, I fixed that in 88-2 :)

Regulus commented on 2014-06-27 14:06

/usr/bin/traGtor doesn't have execute premissions

Chocobozzz commented on 2014-05-13 07:15

traGtor version 0.8.79 released (with french support) http://mein-neues-blog.de/2014/05/13/tragtor-0-8-79-french-language-new/

Regulus commented on 2014-05-09 20:01

tragtor versione 0.8.78 released

Regulus commented on 2013-12-23 11:30

Version 0.8.76

Regulus commented on 2013-09-28 11:03

Version 0.8.73:
* avconv changed codecs output again - fixed
* bug with "name as input" function

dongfengweixiao commented on 2013-07-30 12:46

traGtor 0.8.71: Now with Chinese translation!

adi64 commented on 2013-05-29 12:53

As libav provides 'ffmpeg', I changed the dependency back to ffmpeg so you are free as to what you wish to use :)

bersil commented on 2013-05-19 20:18

Hi ADI64:
From my browser still looked the PKGBUILD with the data (mentioned in my previous comment) without updating :(
maybe it was a cache problem, now it's ok.
I just installed the package without problems.
regards

adi64 commented on 2013-05-19 18:00

Hi bersil,
ah okay. I added a comment at the depends array which should make things a little clearer. The whole ffmpeg <-> libav thing seems weird to me.

I already set the PKGBUILD to 0.8.67-1 yesterday - or did I miss something? :)

bersil commented on 2013-05-19 10:49

Please change the PKGBUILD:
pkgver=0.8.67
pkgrel=1
md5sums=('41b7ae94793549ed7bfa38efae0cf62b')

Thanks ;)

bersil commented on 2013-05-18 17:57

Oh yeah, I got that. happens that installing TraGtor with libav Smplayer and some other applications no longer works, so I prefer to use ffmpeg.
Thanks for updating the package.

bersil commented on 2013-05-18 17:56

Oh yeah, I got that. happens that installing libav TraGtor with me no longer works Smplayer and some other applications, so I prefer to use ffmpeg.
Thanks for updating the package.

adi64 commented on 2013-05-18 15:24

Hi bersil,
yes, using ffmpeg works too, but Markus (the dev) switched to libav :)

bersil commented on 2013-05-18 09:12

Hi ADI64:
there is a new version available (http://repository.mein-neues-blog.de:9000/archive/tragtor-0.8.67_all.tar.gz) with updated translations and small corrections in the GUI.

Another thing: I installed this package replacing "libav" with "ffmpeg" in the line of the dependencies and installed and working properly. just if it helps someone.

adi64 commented on 2013-05-05 18:35

Version 0.8.66 fixed the issue.

adi64 commented on 2013-05-04 12:57

I updated the PKGBUILD to use avconv instead of ffmpeg, but I still get errors :-/
I'll wait to get an answer from the dev.

Mr.Smith1974 commented on 2013-04-28 08:49

`--> tragtor
which: no avconv in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/bin/core_perl)
/usr/share/themes/Black-Diamond/gtk-2.0/gtkrc:92: Murrine configuration option "gradients" is no longer supported and will be ignored.
Traceback (most recent call last):
File "/usr/share/tragtor/tragtor.py", line 4332, in <module>
tragtorWindow = tragtorGUI()
File "/usr/share/tragtor/tragtor.py", line 585, in __init__
self.reset()
File "/usr/share/tragtor/tragtor.py", line 2468, in reset
self.setOutFile(self.config.get("Settings", "outFile"))
File "/usr/share/tragtor/tragtor.py", line 1858, in setOutFile
if setChooser: self.setOutFileChooser()
File "/usr/share/tragtor/tragtor.py", line 1840, in setOutFileChooser
and os.path.dirname(self.outFileChooser.get_filename()) != self._outFile):
File "/usr/lib/python2.7/posixpath.py", line 129, in dirname
i = p.rfind('/') + 1

adi64 commented on 2013-02-18 18:24

Azrael85: Sorry, I don't know, I'm not the developer. I just maintain the PKGBUILD. But it seems like something filesystem-related is going wrong. Maybe ask the developer via the comment section of the page ( http://mein-neues-blog.de/tragtor-gui-for-FFmpeg/ )?

Azrael85 commented on 2013-02-18 17:30

I'm having a new problem:

Traceback (most recent call last):
File "/usr/share/tragtor/tragtor.py", line 4332, in <module>
tragtorWindow = tragtorGUI()
File "/usr/share/tragtor/tragtor.py", line 585, in __init__
self.reset()
File "/usr/share/tragtor/tragtor.py", line 2468, in reset
self.setOutFile(self.config.get("Settings", "outFile"))
File "/usr/share/tragtor/tragtor.py", line 1858, in setOutFile
if setChooser: self.setOutFileChooser()
File "/usr/share/tragtor/tragtor.py", line 1840, in setOutFileChooser
and os.path.dirname(self.outFileChooser.get_filename()) != self._outFile):
File "/usr/lib/python2.7/posixpath.py", line 120, in dirname
i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'

Maybe some problem with the latest update of ffmpeg??

adi64 commented on 2013-01-24 13:07

Nordlicht, you're right. Overall, his site tends to have some downtime :-/
I mirrored Version 0.8.65 here:
http://88.198.227.29/~adi64/zeugs/tragtor-0.8.65_all.tar.gz

Nordlicht commented on 2013-01-24 10:57

It seems as if the source file isn't online any longer.

adi64 commented on 2012-11-15 11:04

Thanks for your comment, I will update as soon as the developer page is back online. It seems to be unavailable since last weekend...

DrZaius commented on 2012-11-11 04:15

This required python2-dbus for me.

Traceback (most recent call last):
File "/usr/share/tragtor/tragtor.py", line 32, in <module>
import dbus
ImportError: No module named dbus

mrbit commented on 2012-05-12 18:57

ok...thanks

mrbit commented on 2012-05-12 18:57

ok

adi64 commented on 2012-05-12 12:59

English is now default language (thanks mrbit).

mrbit commented on 2012-05-11 19:02

please update pkgbuild with:

# Set English as the default language
sed -i '127s/de/en/' /usr/share/tragtor/tragtor.py

mrbit commented on 2012-05-11 18:24

nice...

mrbit commented on 2012-05-11 18:24

adi64 commented on 2012-03-15 17:04

Thanks for the notification, the package changed indeed. I updated the md5sums :)

na12 commented on 2012-03-15 15:34

==> Validating source files with md5sums...
tragtor-0.8.48_all.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build tragtor.
==> Restart building tragtor ? [y/N]

adi64 commented on 2012-03-06 10:53

Updated to 0.8.48.

adi64 commented on 2011-02-18 10:15

Updated to 0.8.27. Additionally, the line 'OnlyShowIn=GNOME;' gets removed during build process.

mokkurkalve commented on 2011-02-16 15:53

What's the point of the OnlyShowIn=GNOME; in the .desktop file?
I use LXDE and comment that out.

adi64 commented on 2011-02-13 10:52

you can switch the language in "Einstellungen", the option is called "Sprache wählen" and defaults to "de" (German). Just switch it to "en" and you're fine =)

dserban commented on 2011-02-13 10:49

Wonderful, awesome-looking utility program.
Any plans to provide an interface in English?

adi64 commented on 2011-02-13 09:39

updated to 0.8.25. Still no python3 PyGObject :(

adi64 commented on 2011-01-24 15:25

updated.

OldShatterhand commented on 2011-01-24 15:12

tragtor 0.8.23 is out now

adi64 commented on 2010-11-21 09:18

updated to 0.8.22.
It's still patched to python2 since there is no python3 compatible PyGObject package in the repos.

OldShatterhand commented on 2010-11-20 09:52

tragtor 0.8.22 is out

adi64 commented on 2010-10-28 05:32

It's updated and patched now. My python package was outdated so I didn't already patch it yesterday.
I simply do the following in the PKGBUILD now (no need for patchfile then):

sed s/python\ /python2\ / usr/bin/tragtor > usr/bin/tragtor.fix || return 1
cp usr/bin/tragtor.fix usr/bin/tragtor
rm usr/bin/tragtor.fix

mokkurkalve commented on 2010-10-27 19:31

It still needs python2 and the following simple patch to work:


--- /usr/bin/tragtor 2010-10-27 20:38:00.000000000 +0200
+++ /usr/bin/tragtor 2010-10-27 20:39:59.933335039 +0200
@@ -1,3 +1,3 @@
#!/bin/sh
-exec python /usr/share/tragtor/tragtor.py "$@"
+exec python2 /usr/share/tragtor/tragtor.py "$@"

OldShatterhand commented on 2010-10-26 15:17

tragtor 0.8.20 is out now...
also you should link tragtor to python2, it does not run with the "normal" python from Arch:
[xxxxxx@Arch-Linux ~]$ tragtor
File "/usr/share/tragtor/tragtor.py", line 1382
print line.strip()
^
SyntaxError: invalid syntax

adi64 commented on 2010-08-22 07:45

updated to 0.8.19 :)
Too bad that there is no notification for traGtor updates :(

OldShatterhand commented on 2010-08-21 21:40

seit gestern gibts schon Version 0.8.19 ;)

adi64 commented on 2010-08-21 18:05

Package updated to 0.8.18. Thanks to OldShatterhand for flagging the old package out of date!

OldShatterhand commented on 2010-08-20 12:37

a new PKBUILD of the current tragtor version (0.8.18): http://aur.pastebin.com/3KRQQtHi

OldShatterhand commented on 2010-08-20 12:36

an new PKGBUILD of tragtor 0.8.18: http://aur.pastebin.com/3KRQQtHi