Package Details: transmission-remote-cli-git 1.7.1.3.g1e412a2-1

Git Clone URL: https://aur.archlinux.org/transmission-remote-cli-git.git (read-only)
Package Base: transmission-remote-cli-git
Description: Curses interface for the daemon of the BitTorrent client Transmission
Upstream URL: https://github.com/fagga/transmission-remote-cli
Licenses: GPL3
Conflicts: transmission-remote-cli
Replaces: transmission-remote-cli
Submitter: fauno
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 60
Popularity: 5.294460
First Submitted: 2009-09-16 14:18
Last Updated: 2017-06-24 21:52

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

WorMzy commented on 2017-06-24 21:53

Good calls. Updated.

user1 commented on 2017-06-24 17:07

I believe that bash completion script shouldn't be executable:

-install -Dm755 completion/bash/transmission-remote-cli-bash-completion.sh \
+install -Dm644 completion/bash/transmission-remote-cli-bash-completion.sh \

zsh completion script can be installed as well:

+install -Dm644 completion/zsh/_transmission-remote-cli \
+ "$pkgdir/usr/share/zsh/site-functions/_transmission-remote-cli"

WorMzy commented on 2016-03-31 15:25

Thanks for pointing that out, echpiel. I've removed the prepare function altogether as it serves no purpose any more.

echpiel commented on 2016-03-31 15:18

Now the first line on github is:
#!/usr/bin/env python2

So the sed changes it to:
#!/usr/bin/env python22

Try instead:
sed -i "1s/python$/python2/" transmission-remote-cli

WorMzy commented on 2014-01-20 13:59

Any reason why this was flagged out of date? I can bump the pkgver if it'll make people happy, but that wan't change what version you get when you build the package (you always get the current master HEAD). I could use this as a chance to add a .AURINFO file, but if there's anything else that needs changing, please let me know.

WorMzy commented on 2013-09-01 15:52

Good call, I hadn't noticed that.

dapus2 commented on 2013-09-01 15:44

Perhaps you should do
sed -i "1s/python/python2/" transmission-remote-cli
instead of
sed -i "s/python/python2/" transmission-remote-cli
or you will mess up some URLs.

WorMzy commented on 2013-07-29 22:43

Thanks for the heads up, updated.

gabrielrcp commented on 2013-07-29 20:12

Upstream changed the location of the bash completion script in the source tree. Please update the PKGBUILD. I am marking as out of date for this reason.

WorMzy commented on 2013-04-27 21:27

Please update the PKGBUILD to make use of pacman 4.1 CVS PKGBUILD features. Here's one I made earlier, feel free to use it: https://raw.github.com/WorMzy/PKGBUILDs/master/transmission-remote-cli-git-PKGBUILD

All comments