Package Details: travis-lint 2.0.0-1

Git Clone URL: https://aur.archlinux.org/travis-lint.git (read-only)
Package Base: travis-lint
Description: travis-lint is a tool that check your .travis.yml for possible issues, deprecations and so on.
Upstream URL: https://github.com/travis-ci/travis-lint
Licenses: MIT
Submitter: joschi
Maintainer: None
Last Packager: McNoggins
Votes: 10
Popularity: 0.000838
First Submitted: 2012-02-22 09:11
Last Updated: 2015-06-12 01:59

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

joschi commented on 2014-06-17 12:27

oconnor663: You're totally right. I forgot to add this dependency when it was introduced. I've updated the PKGBUILD. Please try again.

oconnor663 commented on 2014-06-17 00:07

I'm seeing a Ruby failure, probably because something isn't installed:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'safe_yaml' (~> 0.9.0) among 10 total gem(s) (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/travis-lint:22:in `<main>'

joschi commented on 2013-03-02 10:19

Fresco: Good catch, I fixed that. Thanks!

Freso commented on 2013-03-02 10:01

Is there a reason you don't install /usr/lib/ruby/gems/1.9.1/bin/travis-lint in /usr/bin/travis-lint so it actually gets picked up in the $PATH?