Package Details: treeline-unstable 2.9.0-1

Git Clone URL: https://aur.archlinux.org/treeline-unstable.git (read-only)
Package Base: treeline-unstable
Description: Tree outliner and PIM which stores any kind of information within a tree structure; unstable development snapshot
Upstream URL: http://treeline.bellz.org
Keywords: database outliner pim tree
Licenses: GPL2
Conflicts: treeline
Replaces: treeline
Submitter: ninian
Maintainer: ninian
Last Packager: ninian
Votes: 7
Popularity: 0.025968
First Submitted: 2013-02-17 23:27
Last Updated: 2018-01-28 14:15

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

ninian commented on 2015-01-16 10:49

Weird! Don't see why making the package in a home subdirectory should be different from /tmp. Here's what I've now done and it works just as expected:
1) downloaded the tarball to /tmp
2) $ cd /tmp; tar -xf treeline-unstable.tar.gz
3) $ cd treeline-unstable
4) $ makepkg
5) $ sudo pacman -U treeline-unstable-1.9.5-1-any.pkg.tar.xz
6) $ treeline

noplomplom commented on 2015-01-16 10:39

Problem solved! I manually created the '.treeline-1.9' folder in $HOME. It solves the issue.

noplomplom commented on 2015-01-16 10:36

Here's the error I get when launching from command line:

$ treeline
libpng warning: iCCP: known incorrect sRGB profile
Traceback (most recent call last):
File "/usr/share/treeline/treemaincontrol.py", line 451, in removeLocalControlRef
self.recentFiles.writeItems()
File "/usr/share/treeline/recentfiles.py", line 248, in writeItems
globalref.histOptions.writeFile()
File "/usr/share/treeline/options.py", line 705, in writeFile
with open(self.path, 'w', encoding='utf-8') as f:
PermissionError: [Errno 13] Permission denied: '/usr/share/config/historyrc'

noplomplom commented on 2015-01-16 10:33

I'm as baffled as you are... I just tried again from scratch, and the same error appears. What I did is:
- download the tarball
- unpack the tarball somewhere in home directory
- open terminal into that directory
- build with 'makepkg'
- then install with 'pacman -U'

NB: by the way, if I try to build the package in /tmp/makepkg, it fails. I have to copy the desktop and xml files into the build folder in /tmp to have it work.

ninian commented on 2015-01-16 10:15

Am baffled as to why you are getting this error. Have checked again and package doesn't access this directory at all. When Treeline first runs for me, it creates the configuration directory: $HOME/.treeline-1.9
How did you create your package? How are you running Treeline (it should be from
the desktop file /usr/share/applications/treeline.desktop or the command [/usr/bin/]treeline)? Maybe a conflict with another version of Treeline which you had installed?

noplomplom commented on 2015-01-15 21:41

Just installed it for the first time; when launched, it complained it didn't have permissions to create the configuration file into the '/usr/share/config/' folder, which is quite reassuring. The problem of course is that it should not create the configuration file in /usr/share/config, but rather somewhere in $HOME.
As a result, it is impossible to edit the general options.

noplomplom commented on 2015-01-15 21:39

Just installed it for the first time; when launched, it complained it didn't have permissions to create the configuration file into the '/usr/share/config/' folder, which is quite reassuring. The problem however is that the configuration file should not be created in /usr/share/config.
As a result, it is impossible to edit the general options.

ninian commented on 2014-06-01 11:36

@shblythe: Thanks for reporting this. My apologies, new release should fix. Problem had been caused by updating packages to ensure an .AURINFO file was included.

shblythe commented on 2014-06-01 07:39

Hi ninian, thanks for your work on this.

Unfortunately this latest release fails "makepkg -s".

It lacks treeline.desktop and treeline.xml. If I copy these from the previous tarball I downloaded (1.9.4-1) all works fine.

ninian commented on 2014-02-16 16:59

@ slot: Thanks for info about alternative dependency python-lxml.
Have now changed package to depend on: python-lxml python-pyqt4 ispell