Package Details: trelby 2.4.9-4

Git Clone URL: https://aur.archlinux.org/trelby.git (read-only, click to copy)
Package Base: trelby
Description: The free, multiplatform, feature-rich screenwriting program!
Upstream URL: https://github.com/limburgher/trelby
Keywords: editor screenplay screenwriting scriptwriting
Licenses: GPL2
Conflicts: trelby-git
Submitter: tdy
Maintainer: txtsd
Last Packager: txtsd
Votes: 8
Popularity: 0.196506
First Submitted: 2017-01-20 15:19 (UTC)
Last Updated: 2024-05-21 16:10 (UTC)

Latest Comments

1 2 Next › Last »

txtsd commented on 2023-10-18 06:47 (UTC)

Thanks for your suggestions @xiota and @MarsSeed. It was just a stopgap to get a functional PKGBUILD. I'll do it the correct way today.

xiota commented on 2023-10-18 04:07 (UTC)

Why not using PEP517 install?

+  python setup.py sdist
+  python setup.py install --root="${pkgdir}"

MarsSeed commented on 2023-10-17 18:00 (UTC)

setuptools should be in makedepends, not in depends.

txtsd commented on 2023-10-16 18:19 (UTC) (edited on 2023-10-16 20:13 (UTC) by txtsd)

Can I get co-maintainer on this? I'd like to update it to the actively maintained fork https://github.com/limburgher/trelby

EDIT: I maintain trelby-git

SamWhited commented on 2022-08-15 18:51 (UTC) (edited on 2022-08-15 18:51 (UTC) by SamWhited)

I'm getting the following when attempting to build this package:

In file included from src/helpers.cpp:16:
include/wx/wxPython/wxPython_int.h:19:10: fatal error: wx/wx.h: No such file or directory
   19 | #include <wx/wx.h>
      |          ^~~~~~~~~
compilation terminated.

Kruemmelspalter commented on 2021-05-26 11:01 (UTC)

The dependency python2-lxml doesn't exist anymore. There's python-lxml which is for python3

tyrannis.hawk commented on 2020-07-07 13:32 (UTC)

I adopted the package and fixed the download link. It should work now.

AllanDaemon commented on 2018-01-26 20:22 (UTC)

Also, the generated package is wrong. It got the files from the AUR git repository (like PKGBUILD, trelby.{sh,xml}). No luck for me, but the trelby-git did work.

AllanDaemon commented on 2018-01-26 20:08 (UTC)

The source link is broken now they changed the hosting to Github. Simply changing the PGKBUILD link is enough, as the file is the same, with the same hash.

the new link is (from https://github.com/trelby/trelby/releases) https://github.com/trelby/trelby/releases/download/import/$pkgname-$pkgver.tar.gz

Use git apply with this patch to fix it.

diff --git a/PKGBUILD b/PKGBUILD index 728bb72..092851c 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -9,7 +9,7 @@ url=http://www.trelby.org license=(GPL) depends=(wxpython2.8 python2-lxml) conflicts=(trelby-git) -source=(http://www.trelby.org/files/release/$pkgver/$pkgname-$pkgver.tar.gz +source=(https://github.com/trelby/trelby/releases/download/import/$pkgname-$pkgver.tar.gz $pkgname.sh $pkgname.xml) sha256sums=(a46661507444a7ba80a3202fd637220198853db7b6b6cb3a0ce441c7eb6f72e6

settyness commented on 2017-06-19 21:12 (UTC)

@Aribam it works fine if you just let wxgtk2.8 build.