Package Details: trellis-git r979.60c05b3-1

Git Clone URL: https://aur.archlinux.org/trellis-git.git (read-only, click to copy)
Package Base: trellis-git
Description: Tools and scripts which allow you to document the bit-stream format of Lattice ECP5 series FPGAs
Upstream URL: https://github.com/YosysHQ/prjtrellis
Licenses: custom:ISC
Conflicts: prjtrellis, prjtrellis-db
Provides: prjtrellis, prjtrellis-db
Submitter: grahamedgecombe
Maintainer: grahamedgecombe
Last Packager: grahamedgecombe
Votes: 6
Popularity: 0.007270
First Submitted: 2018-10-22 18:22
Last Updated: 2021-01-03 22:37

Dependencies (5)

Required by (3)

Sources (2)

Latest Comments

rvalles commented on 2020-12-17 17:58

Upstream url should be: https://github.com/YosysHQ/prjtrellis

Symbiflow isn't the upstream, and it isn't being updated.

novenary commented on 2019-09-05 20:15

It seems the /usr/lib64 workaround is no longer needed, and breaks the build. mv: cannot stat '/home/streetwalrus/.cache/yay/trellis-git/pkg/trellis-git/usr/lib64': No such file or directory

grahamedgecombe commented on 2019-06-29 13:01

@palmr: thanks, this is fixed now.

palmr commented on 2019-06-29 11:57

This does not respect the database submodule version.

It's currently pulling in the latest revision which includes MULT18X18D:REGS=ALL which while trellis will install some downstream dependents, like nextpnr-git, will fail to build.

Fixed locally by patching the PKGBUILD to not rsync in the prepare but following the pattern suggested here: https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git_Submodules

grahamedgecombe commented on 2019-02-16 10:34

@eimis: thanks, it works again now

eimis commented on 2019-02-15 21:19

it fails to install

error: failed to commit transaction (conflicting files)

trellis-git: /usr/lib64 exists in filesystem (owned by filesystem)

Errors occurred, no packages were upgraded.

n56vz ~ $ ls /usr/lib64

lrwxrwxrwx 1 root root 3 Dec 6 16:19 /usr/lib64 -> lib