Package Details: trizen 135.3deb262-1

Git Clone URL: https://aur.archlinux.org/trizen.git (read-only)
Package Base: trizen
Description: Trizen's AUR Package Manager: A lightweight wrapper for AUR.
Upstream URL: https://github.com/trizen/trizen
Keywords: aur manager package
Licenses: GPLv3
Submitter: trizen
Maintainer: trizen
Last Packager: trizen
Votes: 11
Popularity: 0.104200
First Submitted: 2010-07-07 10:21
Last Updated: 2016-05-24 12:37

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

trizen commented on 2013-11-03 07:46

Types::Serialiser should be listed as a dependency for 'perl-json-xs'. trizen does not use directly this module.

modulation commented on 2013-11-03 07:36

Using latest trizen there seems to be a new dependency:

Can't locate Types/Serialiser.pm in @INC (you may need to install the Types::Serialiser module)

trizen commented on 2013-04-02 08:48

Fixed. For some reason, I have /bin/arch that looks like this:

#!/bin/bash
uname -m

So, I've changed the script to execute 'uname -m', instead of arch. Thanks.

modulation commented on 2013-04-02 08:26

There seems to be a new dependency?

Can't exec "arch": No such file or directory at /usr/bin/trizen line 59.
Use of uninitialized value in substr at /usr/bin/trizen line 59.

trizen commented on 2012-11-14 16:22

Updated. Thanks!

daimonion commented on 2012-11-14 14:41

Please add 'perl-lwp-protocol-https' into dependencies, it solves the problem described below.

daimonion commented on 2012-11-14 14:36

I can't update AUR packages anymore, here's the error:


501 Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)
** Unable to get info for local packages

daimonion commented on 2012-11-14 14:28

I cannot search update packets from AUR, this is the output:
"** Unable to get info for local packages"

daimonion commented on 2011-11-06 23:42

I've found the source aforementioned problem. In line 696 change
system qq[$sudo_or_su "$pacman -S $pkgname"];
into
system "$sudo_or_su $pacman -S $pkgname";
and trizne will normally install a package from official repos. I don't know if this will break any other feature, though. So far everything is working normally.

daimonion commented on 2011-11-06 16:02

No problem, I liked your program, it' really amazing: simple and lightweight, with minimum dependencies. I still have this error when trying to install programs from official repositories:

$ trizen -S conky

=>> Installing 'conky' with pacman

Sudo Password:
sudo: pacman -S conky: command not found

I don't know if this is supported at all. Also, there are features I miss from yaourt, I would like to see them in trizen if possible:
1. I can view all local packages in yaourt by issuing yaourt -Qma command which looks like this: http://img850.imageshack.us/img850/9836/yaourt.png
2. Don't know how to explain, so here's a picture: http://img254.imageshack.us/img254/9848/yaourtsysupg.png

Feature 2. is questionable, I figure you didn't imagined trizen as a wrapper for every pacman function. But feature 1. would be nice to have: it's just a 'pacman -Qm' command but colored, and displays which packages are available on AUR. :)

trizen commented on 2011-11-06 14:06

Fixed. You're a good tester :)

daimonion commented on 2011-11-06 13:38

Sorry to bother you again, another error came up:

[14:36:09] mladen@demon ~/Programi/pkgbuilds/quadkonsole
$ trizen -U quadkonsole4-0.4.3-1-x86_64.pkg.tar.xz

* Installing: /home/mladen/Programi/pkgbuilds/quadkonsole/quadkonsole4-0.4.3-1-x86_64.pkg.tar.xz

Sudo error: '': wrong or NULL argument passed

trizen commented on 2011-11-06 12:11

Added.

daimonion commented on 2011-11-06 11:51

Here's the patch for the feature I need: http://pastebin.com/zQhWd7Ky

It's ugly, I know, but: good bye yaourt! :D

daimonion commented on 2011-11-06 11:29

Sorry to bother again, I have another error:

[12:27:00] mladen@demon ~
$ trizen -Ss bleachbit
community/bleachbit 0.9.0-1 [0,26 MB]
Deletes unneeded files to free disk space and maintain privacy
1. bleachbit-svn 2526-1 [out-of-date] (34+) (multimedia) Deletes unneeded files to free disk space and maintain privacy
[12:27:04] mladen@demon ~
$ trizen -S bleachbit

=>> Installing 'bleachbit' with pacman

Sudo Лозинка:
sudo: pacman -S bleachbit: command not found

daimonion commented on 2011-11-06 11:20

If you add an option to move the built package to the pacman cache directory (using 'su' to execute the mv command), I'll ditch the yaourt! :D

trizen commented on 2011-11-06 10:46

Fixed. Thanks!

daimonion commented on 2011-11-05 23:05

I get this error:

==> Finished making: alsi 0.3.2-1 (Sun Nov 6 00:05:08 CET 2011)

* Installing: /tmp/trizen-mladen/alsi/alsi-0.3.2-1-any.pkg.tar.gz

Sudo Password:
sudo: pacman -Uf --asexplicit /tmp/trizen-mladen/alsi/alsi-0.3.2-1-any.pkg.tar.gz: command not found

By the way, I love all your apps, they're simply fantastic!

trizen commented on 2011-07-29 03:48

But you're wrong :)

lolilolicon commented on 2011-05-22 04:27

@trizen
May I request HTTPS support? Maybe as an option --https to force https whenever possible?

ajs124 commented on 2011-04-26 21:12

eh, i think dependencies aren't searched in the aur, so e.g. lib32-ogre can't be build automaticly, because it depends on packages from the aur.

trizen commented on 2011-02-27 11:08

Fixed.

ajs124 commented on 2011-02-26 22:13

FAIL:
xgalaga != xgalaga++
but with trizen, it is^^

trizen commented on 2011-02-20 19:55

No, it is. Problem has been fixed in git. Please reinstall the application. Thanks for your report.

Anonymous comment on 2011-02-20 18:03

It is not OK:

* xampp 1.7.4-1 (New Update: 1.7.3a-1) (out-of-date) ??

trizen commented on 2011-02-19 13:37

Screenshot: http://i53.tinypic.com/2e0tqc4.png

trizen commented on 2011-02-17 22:20

Rewritten from scratch and moved to github. The performance and stability has been improved. Everything should work fine now...

trizen commented on 2010-11-20 14:55

I think is better in my way. Now script will look for 3 popular editors: joe, vi and nano or user can specify a editor when installs a package, ex: trizen -S [pkgname] --editor leafpad

trizen commented on 2010-11-20 14:54

I think is better in my way. No script will look for 3 popular editors: joe, vi and nano or user can specify a editor when installs a package, ex: trizen -S [pkgname] --editor leafpad

haawda commented on 2010-11-20 14:44

please do not depend on a specific editor. see http://pastebin.com/7tPwHDie

haawda commented on 2010-11-20 13:54

please do not depend on a specific editor. see http://pastebin.com/7tPwHDie

trizen commented on 2010-07-09 05:49

Done..

haawda commented on 2010-07-09 05:47

Please use arch=('any') instead of arch=('i686' 'x86_64').