Package Details: tsc 2.0.0-3

Git Clone URL: https://aur.archlinux.org/tsc.git (read-only)
Package Base: tsc
Description: Jump'n'run game with editor and scripting facilities, fork of SMC
Upstream URL: https://secretchronicles.org/en/
Licenses: GPL3
Submitter: rafaelff
Maintainer: rafaelff (Quintus)
Last Packager: rafaelff
Votes: 2
Popularity: 0.000000
First Submitted: 2015-01-23 12:35
Last Updated: 2017-12-10 15:34

Latest Comments

rafaelff commented on 2017-11-25 17:57

@PrzemekS: cegui-0.7 compilation was fixed. I also fixed the TSC's upstream URL. Let me know if any other problem occur.

PrzemekS commented on 2017-10-01 15:52

That help but cegiu 0.7 error is still stoping from building the game

rafaelff commented on 2017-09-22 13:38

Please try building with the URL ftp://ftp.secretchronicles.org/releases/TSC-2.0.0.tar.xz and let me know

PrzemekS commented on 2017-09-22 07:01

Hello, I want to install on Manjaro and have that error:
BŁĄD: Błąd podczas pobierania ftp://ftp.secretchronicles.de/releases/TSC-2.0.0.tar.xz
(it means error during download).
I have also errors when try to build in pamac tsc-git, smc-git and smc packages.

rafaelff commented on 2017-03-20 00:23

Nice catch, @jnvandermeer. Package updated.

jnvandermeer commented on 2017-03-19 20:40

hi guys,

You need another dependency: extras/libxml++2.6

It might be that the libxml++ already in the dependency list is not the right one.

rafaelff commented on 2016-08-19 04:21

@pollito: Do you mean like a tsc-bin, where the "source" for the package is actually the software pre-built tarball? If that's the case, I'm sorry to say that TSC doesn't provide binary tarball, so I'm unable to link to it.

pollito commented on 2016-08-19 04:03

Thanks it's compile perfect, I want to ask if is posible to upload another version of TSC already compiled?

MrEvilBreakfast commented on 2016-01-31 01:32

@ozky:

That's unfortunate. I get cmake errors with the recipe for target: "CMakefiles/tsc.dir/src/audio/audio.cpp.o".

I have no idea how to fix that. I'm tempted to flag the package out of date.

ozky commented on 2015-12-04 19:41

Here is log from build.

CMakeFiles/tsc.dir/build.make:90: recipe for target 'CMakeFiles/tsc.dir/src/overworld/overworld_description_loader.cpp.o' failed
make[2]: *** [CMakeFiles/tsc.dir/src/overworld/overworld_description_loader.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
CMakeFiles/tsc.dir/build.make:66: recipe for target 'CMakeFiles/tsc.dir/src/overworld/world_sprite_manager.cpp.o' failed
make[2]: *** [CMakeFiles/tsc.dir/src/overworld/world_sprite_manager.cpp.o] Error 1
CMakeFiles/Makefile2:173: recipe for target 'CMakeFiles/tsc.dir/all' failed
make[1]: *** [CMakeFiles/tsc.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

All comments