Package Details: tttool-git 1.6-1

Git Clone URL: https://aur.archlinux.org/tttool-git.git (read-only)
Package Base: tttool-git
Description: tool for compiling and decompiling gme files for tiptoi pen
Upstream URL: http://tttool.entropia.de
Licenses: custom
Conflicts: tttool
Provides: tttool
Submitter: mockfrog
Maintainer: mockfrog
Last Packager: mockfrog
Votes: 1
Popularity: 0.000195
First Submitted: 2016-02-08 20:04
Last Updated: 2016-02-08 20:06

Latest Comments

mmccoo commented on 2019-01-24 09:46

I had some trouble installing tttool from their git because I keep my home dir on a smaller disk. Haskell's stack infrastructure wants, in my case, 5.4GB.

To accommodate this, I did: export STACK_ROOT=<path to some disk with space>

I also did 'stack init' before the stack install line, but I can't say for sure it's required.

erictronic commented on 2018-03-28 00:03

During installation with yaourt or pamec i got this build error: ... ==> Beginne build()... Writing a default package environment file to /tmp/pamac-build-eric/tttool-git/src/tip-toi-reveng/cabal.sandbox.config Creating a new sandbox at /tmp/pamac-build-eric/tttool-git/src/tip-toi-reveng/.cabal-sandbox Resolving dependencies... cabal: Could not resolve dependencies: next goal: tttool (user goal) rejecting: tttool-1.8, tttool-1.7.0.3, tttool-1.7.0.2, tttool-1.7.0.1, tttool-1.6.1.4, tttool-1.6.1.3, tttool-1.6.1.2, tttool-1.6.1.1, tttool-1.6.1, tttool-1.6.0.1 (constraint from user target requires ==1.6) trying: tttool-1.6 next goal: base (dependency of tttool-1.6) rejecting: base-4.10.1.0/installed-4.1... (conflict: tttool => base>=4.5 && <4.10) rejecting: base-4.11.0.0, base-4.10.1.0, base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires installed instance) After searching the rest of the dependency tree exhaustively, these were the goals I've had most trouble fulfilling: base, tttool Note: when using a sandbox, all packages are required to have consistent dependencies. Try reinstalling/unregistering the offending packages or recreating the sandbox. ==> FEHLER: Ein Fehler geschah in build(). Breche ab... ...

What is going wrong?

thx, Eric

mavrix commented on 2016-11-09 12:55

Had to set version to 1.6.1.3 for this to build.