Package Details: ttyd 1.6.1-3

Git Clone URL: https://aur.archlinux.org/ttyd.git (read-only, click to copy)
Package Base: ttyd
Description: Share your terminal over the web
Upstream URL: https://tsl0922.github.io/ttyd/
Keywords: browser terminal
Licenses: MIT
Submitter: polyzen
Maintainer: eklausmeier (edh)
Last Packager: eklausmeier
Votes: 9
Popularity: 0.175469
First Submitted: 2017-08-06 08:04
Last Updated: 2020-10-03 19:32

Latest Comments

1 2 Next › Last »

eklausmeier commented on 2020-07-22 20:03

vim is indeed not needed, so dropped this dependency.

Thanks m050601 for pointing this out.

m040601 commented on 2020-07-22 16:25

Just an upvote and big thank you for providing this package. Good thing to also provide a systemd service. It's so usefull or ARM (Raspberry PI).

Sorry I dont understand much about compiling and cant help much with troubleshooting its dependecies, but:

makedepends=('cmake' 'vim') # vim needed for its xxd binary

Hope we can get rid of this annoying 'vim' make dependency here. :-)

Just curious how, https://aur.archlinux.org/packages/ttyd-git, seems to get away with not needing it. On Raspberry Pi 2b v1.1 , was forced to download the whole vim shabang. :: Checking for conflicts... :: Checking for inner conflicts... [Repo: 2] libev-4.33-1 libwebsockets-4.0.20-3 [Repo Make: 5] jsoncpp-1.9.3-1 rhash-1.3.9-2 cmake-3.18.0-2 vim-runtime-8.2.0814-3 vim-8.2.0814-3 [Aur: 1] ttyd-1.6.1-1

eklausmeier commented on 2020-06-11 12:22

Following the proposal from TheGentlChainsaw I pick a specific commit from GitHub which should fix this annoying dependency on libwebsockets-libuv. Though I do not take the below commit, but I take a later one.

Now ttyd is no longer dependent on libwebsockets-lib but can use the Community/libwebsockets package.

Thanks TheGentlChainsaw for pointing this out.

TheGentlChainsaw commented on 2020-06-10 02:37

tsl0922 has added a fix for our current problem in the git master, but the fix just hasn't made it to a release tarball yet. If you bump the package version to 1.6.0+10+g79acf9e89 like so, then that should get it to build successfully against community libwebsockets again:

pkgname=ttyd
pkgver=1.6.0+10+g79acf9e89
pkgrel=1
pkgdesc='Share your terminal over the web'
arch=('i686' 'x86_64' 'armv7h')
url=https://tsl0922.github.io/ttyd/
license=('MIT')
depends=('json-c' 'libpcap' 'libwebsockets' 'zlib')
makedepends=('cmake' 'xxd' 'git')
source=("ttyd.service"
        "ttyd-$pkgver::git+https://github.com/tsl0922/ttyd.git#tag=79acf9e896c8da91997dade70d0d2a0440d138fd")
sha512sums=('b6c731444ad78d68464082557a4b7dae857f2b86511810f055d2a4c8e1c7051328cdbcd1f8a43c322a2dd20c20474b483f9fa104785268bafdefb04cce54287d'
            'SKIP')

eklausmeier commented on 2020-04-11 21:57

Made ttyd dependent on libwebsockets-libuv again as libwebsockets from community breaks linkage as mentioned by riaqn.

riaqn commented on 2020-04-11 19:02

The libwebsocket in official repository has updated, now the dynamic library linking doesn't work anymore.

eklausmeier commented on 2020-02-26 14:36

Many thanks for comments and assistance to TheGentlChainsaw and mdevaev.

Changed dependency to original libwebsockets again.

TheGentlChainsaw commented on 2020-02-25 23:51

Community repo's libwebsockets package is now being built with libuv as a default dependency as of 3.2.2-3. I guess we don't need the separate package anymore!

eklausmeier commented on 2020-02-17 20:21

I took over ownership for libwebsockets-libuv and added libuv support as suggested. With that package then ttyd can be bumped to 1.6.0.

mdevaev commented on 2020-02-17 17:21

@TheGentlChainsaw @eklausmeier

I sent a request to the libwebsockets maintainer to enable libuv support. If someone adds their vote for this, it will be great :)

https://bugs.archlinux.org/task/65532