Package Details: turses 0.3.1-9

Git Clone URL: https://aur.archlinux.org/turses.git (read-only)
Package Base: turses
Description: A Twitter client for the console
Upstream URL: https://github.com/dialelo/turses
Licenses: GPLv3
Conflicts: turses-git
Submitter: archtux
Maintainer: shaggytwodope
Last Packager: shaggytwodope
Votes: 44
Popularity: 0.596969
First Submitted: 2012-03-03 17:47
Last Updated: 2016-04-07 10:30

Latest Comments

shaggytwodope commented on 2016-04-07 10:39

@milouse updated and removed. thanks for letting me know.

milouse commented on 2016-04-07 09:39

The python2-oauth2 dependance is no more required. See http://turses.readthedocs.org/en/latest/dev/changelog.html and setup.py

Xemerau commented on 2016-03-30 15:53

Works like a charm now, thanks for your work @shaggytwodope

shaggytwodope commented on 2016-03-30 14:26

@Xemerau, updated sorry for the delay. And thanks for the comment.

Xemerau commented on 2016-03-30 13:55

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
.....
pkg_resources.DistributionNotFound: The 'tweepy==3.5.0' distribution was not found and is required by turses
----------
According to the output of 'pacman -Qi', python2-tweepy-git is reporting a version 0.1018.cd46550-1

Noorac commented on 2015-10-01 19:25

@shaggytwodope thanks for the update. It's working indeed!

shaggytwodope commented on 2015-10-01 19:19

@Noorac Just saw your msg after updating the package. It should be fully working at the time of posting.

Noorac commented on 2015-10-01 18:43

It seems turses wants future 0.15.1, newest version of future is 0.15.2-2

petr.fischer commented on 2015-08-13 17:57

@shaggytwodope Working! Thanks for the fast fix!

shaggytwodope commented on 2015-08-13 17:36

@petr.fischer Should be working now, update and lemme know if any issues.

petr.fischer commented on 2015-08-13 14:48

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
.........
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'future==0.14.3' distribution was not found and is required by turses

Packages installed:
aur/turses 0.3.1-0
aur/python2-future 0.15.0-1
aur/python2-oauth2 1.5.211-2
aur/python2-tweepy 3.3.0-2
extra/python2-urwid 1.3.0-2
extra/python2-setuptools 1:18.1-2
extra/python2 2.7.10-1

shaggytwodope commented on 2015-04-12 21:51

@Gadileth @nielsk @corky sorry for the delay, package updated and should be working currently as I post this. Any issues email me directly with address in pkgbuild. Will be sure to fix this asap from now on.

corky commented on 2015-04-03 08:53

Turses still wants python2-tweepy 3.1
Newest python2-tweepy version is 3.3.

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3038, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 617, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 630, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 808, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: tweepy==3.1.0

Gadileth commented on 2015-01-29 21:07

Turses wants python2-tweepy 3.1.
Newest python2-tweepy version is 3.2.

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3018, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 614, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 627, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 805, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: tweepy==3.1.0

Gadileth commented on 2015-01-29 14:21

Same now after another pyhton2-tweepy update:

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3018, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 614, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 627, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 805, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: tweepy<3,>2.2

nielsk commented on 2014-12-11 11:27

Since today I get the following error after I updated some packages incl. python2-tweepy
Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2880, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 434, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 447, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: tweepy>2.2,<3

alejandrogomez commented on 2014-03-24 18:48

@ethail I just submitted a version that should fix that. Thanks for reporting!

ethail commented on 2014-03-24 08:01

Since the update on python2-tweepy from 2.1 to 2.2 I can't get turses to start, even after rebuilding turses:

Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2749, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 446, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 459, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 628, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: tweepy==2.1

alejandrogomez commented on 2013-11-03 10:17

@OwenTuz updated, thanks for the heads up! I'm glad I can contribute packages for everybody to use!

OwenTuz commented on 2013-11-01 16:30

Dependency 'python2-distribute' fails, is now provided by 'python2-setuptools'.
I notice packager is also the dev - thanks for a great job :)

alejandrogomez commented on 2013-08-18 16:17

0.2.18 is a bugfix release, please upgrade.

alejandrogomez commented on 2012-11-16 11:20

When upgrading to 0.2.9, make sure to read this: http://turses.readthedocs.org/en/latest/user/configuration.html#module-turses.session

alejandrogomez commented on 2012-07-04 14:37

0.2.4 fixes a bug that would not let you focus the topmost status when having multiple columns. Please upgrade.

Thank you for your patience :)

alejandrogomez commented on 2012-05-30 10:53

The 0.1.17 version would crash when rendering a direct message, please upgrade to 0.1.18.

alejandrogomez commented on 2012-05-22 16:44

In the last version (0.1.16), you can see the status authors info pressing `i`.

Try it out!

muunleit commented on 2012-05-19 03:57

Forget what I have written in the deleted post. You was right and I was wrong. Thank you for fixing.

muunleit commented on 2012-05-19 03:50

@alejandrogomez
Thank you, but you didn't exactly fixed it. 'python2-distribute' is only needed for building the package, not for running it.

alejandrogomez commented on 2012-05-18 18:42

Thanks for reporting @muunleit, fixed!

muunleit commented on 2012-05-18 14:51

It seems the PKGBUILD is missing makedepends=('python2-distribute') .

alejandrogomez commented on 2012-05-10 19:00

0.1.11 fixes bug when trying to add a tweet to favorites.

alejandrogomez commented on 2012-05-09 22:23

If you installed 0.1.9 please upgrade to 0.1.10, is a bugfix release.

Sorry for the incovenient. Enjoy!

alejandrogomez commented on 2012-04-30 12:26

I forgot to add color for URLs in 0.1.5; 0.1.6 has that.
Also more detailed replies, retweets and favorites.

alejandrogomez commented on 2012-04-25 22:28

0.1.5 is out. Color for hashtags and usernames and configurable tab text.

milouse commented on 2012-04-17 16:27

It works with this new version. Thanks!

alejandrogomez commented on 2012-04-17 15:08

It was a bug on the package, I've just pushed a new release to fix it.

alejandrogomez commented on 2012-04-17 10:08

It seems like `turses` has not been correctly installed. Did you installed it from the PKGBUILD?

BTW, there is a new bugfix release: 0.1.1

milouse commented on 2012-04-17 09:31

I get the following error after having installed turses... any idea on which package is missing ? I had tyrs and must rm -rf /pythonpath/oauth2 and /urwid to let them install correctly. Could it stay other broken files around ?

$ turses
Traceback (most recent call last):
File "/usr/bin/turses", line 3, in <module>
from turses.cli import main
File "/usr/lib/python2.7/site-packages/turses/cli.py", line 15, in <module>
from .ui import CursesInterface
ImportError: No module named ui

alejandrogomez commented on 2012-04-16 11:33

turses 0.1.0 is out!

alejandrogomez commented on 2012-04-16 10:03

Updated, sorry for the delay. I'm releasing 0.1.0 later today.

Anonymous comment on 2012-04-16 04:57

0.0.15 is out

Anonymous comment on 2012-04-16 04:57

0.0.15 is out

alejandrogomez commented on 2012-04-11 19:37

0.0.14

Anonymous comment on 2012-04-11 18:32

No, thank you! if it help to others...

Just put the next code into a PKGBUILD file and type: makepkg -i PKGBUILD
-------------
# Maintainer: alejandrogomez <alejandroogomez@gmail.com>
pkgname=turses
pkgver=0.0.14
pkgrel=1
pkgdesc="A Twitter client featuring a sexy curses interface"
arch=('any')
url="http://pypi.python.org/pypi/turses/"
license=('GPLv3')
depends=('ncurses' 'python2' 'python2-oauth2' 'tweepy' 'python2-urwid')
source=(http://pypi.python.org/packages/source/t/$pkgname/$pkgname-$pkgver.tar.gz)
md5sums=('abeeddc3d66c802d638a972741fbbe4b')
build() {
cd "$srcdir/$pkgname-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1 }

alejandrogomez commented on 2012-04-11 17:29

I'm afraid I cannot update the PKGBUILD with the 0.0.14 bugfix release because of my slow internet connection.

You can get the last version in pypi: http://pypi.python.org/pypi/turses
or download the source: http://github.com/alejandrogomez/turses

Thank you for your help!

Anonymous comment on 2012-04-11 17:02

## Installed new version .13-1 with yaourt, fine then run it and:

Generating and signing request for an access token

your account has been saved
Traceback (most recent call last):
File "/usr/bin/turses", line 5, in <module>
main()
File "/usr/lib/python2.7/site-packages/turses/cli.py", line 21, in main
configuration = Configuration(args)
File "/usr/lib/python2.7/site-packages/turses/config.py", line 50, in __init__
self.parse_config()
File "/usr/lib/python2.7/site-packages/turses/config.py", line 143, in parse_config
self.init_logger()
File "/usr/lib/python2.7/site-packages/turses/config.py", line 256, in init_logger
lvl = self.init_logger_level()
File "/usr/lib/python2.7/site-packages/turses/config.py", line 267, in init_logger_level
lvl = int(self.params['logging_level'])
KeyError: 'logging_level'

Anonymous comment on 2012-04-02 18:35

I had it:
$ atención: python2-urwid-1.0.1-1 está actualizado -- re-instalando
but just for testing I reinstalled it. lol, it works now. Thanks for all!

alejandrogomez commented on 2012-04-02 09:35

It looks like you don't have `python2-urwid` installed, it's in the depdencies array so I don't know why you
don't have it installed. Try installing that package and should work.

alejandrogomez commented on 2012-04-02 09:34

It looks like you don't have `python2-urwid` installed, it's in the depdencies array so I don't know why you
don't have it installed. Try installing that pakage and should work.

Anonymous comment on 2012-04-01 22:40

Yep I have the latest. Thanks for your attention

alejandrogomez commented on 2012-04-01 12:59

¿Did you install the last version of the package?

I'm looking at it right now.

Anonymous comment on 2012-03-31 18:55

Traceback (most recent call last):
File "/usr/bin/turses", line 3, in <module>
from turses.cli import main
File "/usr/lib/python2.7/site-packages/turses/cli.py", line 12, in <module>
from .controller import CursesController
File "/usr/lib/python2.7/site-packages/turses/controller.py", line 15, in <module>
import urwid
ImportError: No module named urwid