Package Details: tuxedo-keyboard-dkms 3.2.14-1

Git Clone URL: (read-only, click to copy)
Package Base: tuxedo-keyboard-dkms
Description: Keyboard Backlight Driver from TUXEDO Computers
Upstream URL:
Licenses: GPL3
Conflicts: tuxedo-cc-wmi, tuxedo-keyboard
Provides: tuxedo-io, tuxedo-keyboard
Submitter: StevenSeifried
Maintainer: StevenSeifried
Last Packager: StevenSeifried
Votes: 22
Popularity: 0.78
First Submitted: 2022-10-07 12:39 (UTC)
Last Updated: 2023-11-17 15:54 (UTC)

Dependencies (6)

Required by (8)

Sources (2)

Pinned Comments

StevenSeifried commented on 2023-03-27 05:21 (UTC)

Since version 3.2.0, tuxedo-keyboard uses the SysFS Interface.

Latest Comments

1 2 3 Next › Last »

Camponotus commented on 2023-11-27 14:18 (UTC)

Hi StevenSeifried!

Thank you for integrating a run of mkinitcpio to post install hooks with the last update! Until now I had to perform this manually. Did you change something in addition in version 3.2.14-1 ? At the moment everything works as it should – no problem with the keyboard while entering the password on boot! (see my last comment for details).

Camponotus commented on 2023-10-24 19:45 (UTC) (edited on 2023-10-24 19:46 (UTC) by Camponotus)


I use tuxedo-keyboard/tuxedo-keybord-dkms since about two years. Without any trouble at the first year. But one year ago a strange behavior occurred… and I am still not sure where the problem is located because it occur most of the time but not every time. So I sometimes already thought it is fixed, but it was not…

I have an encrypted system and I directly start my system with a Unified kernel image signed for Secure Boot directly with a UEFI boot entry. The Hooks in my mkinitcpio therefor are:

base systemd plymouth keyboard autodetect modconf kms block sd-vconsole sd-encrypt lvm2 filesystems fsck

Since one year, on most reboots the keyboard hangs after some pressed buttons when it comes to enter the password in the early boot process. The keyboard is dead after this. Even if I plug a external keyboard to complete the password and boot successfully, the built in keyboard keeps unusable. The only thing I can do – do not touch the keyboard of my laptop while booting up the system and only use the external keyboard for booting. After the system is up I can unplug the external keyboard and use the built in keyboard without any troubles.

What could be the reason for this behavior? Anyone an idea how tuxedo-keyboard could mess up the usability of the keyboard in early boot process? Or is there a possibility to only integrate the stock driver for the keyboard into the initramfs without the backlight? – I do not really need this feature at the password prompt…

evorster commented on 2023-08-24 08:54 (UTC) (edited on 2023-08-24 11:44 (UTC) by evorster)

Hi there!

If you have a Sager laptop which is basically a rebranded Tuxedo laptop, you can still get this driver to work. You just have to get around that DMI string check mentioned below.

Using modified instructions from a comment in the clevo-xms-wmi:

  1. Download the package manually
  2. Run makepkg -o
  3. Edit the file in the source code src/tuxedo-something/src/tuxedo_keyboard.c
  4. Search for "DMI_MATCH" and set the DMI strings to what matches your system.

How to find what matches your system?

sudo dmidecode | grep Manufacturer

Use the first three hits, on my system it was "Notebook", "Notebook" and "No Enclosure"

  1. Install the package by running makepkg -se in the root dir where you cloned it

teetest commented on 2023-05-05 07:37 (UTC) (edited on 2023-06-27 09:59 (UTC) by teetest)

Since commit #254e167 (, Tuxedo has added a TUXEDO DMI string check.

zazke commented on 2023-04-27 01:11 (UTC)

Noobie here. Just a reminder to fellow noobs, if you are using linux-lts, then make sure you have linux-lts-headers installed. Otherwise dkms will complain with something like this:

(2/2) Install DKMS modules ==> ERROR: Missing opt kernel headers for module tuxedo-keyboard/3.2.3. ==> ERROR: Missing etc kernel headers for module tuxedo-keyboard/3.2.3.

StevenSeifried commented on 2023-03-27 05:21 (UTC)

Since version 3.2.0, tuxedo-keyboard uses the SysFS Interface.

sekret commented on 2023-03-26 22:58 (UTC)

Ok, holy shit. I've given it a try, installing tcc and the current version of this package here. It fucks up the picture on my external monitor!!! Wtf?!

Looks like I have to stay with version 3.1.4 of this package or they fix this. Maybe I'll file a bug report.

sekret commented on 2023-03-26 22:37 (UTC)

I have the same problem waltervh has. For me it's really an issue because I don't use tcc but tcd-community ( and there was a PKGBUILD here once…) instead to handle my fan control and other tools for the other things tcc provides.

So can we only control the backlight with the keyboard shortcuts, when tcc is installed?