Package Details: tuxemon-git 0.4.33.r47.gee807080-1

Git Clone URL: https://aur.archlinux.org/tuxemon-git.git (read-only, click to copy)
Package Base: tuxemon-git
Description: A free, open source monster-fighting RPG.
Upstream URL: http://www.tuxemon.org
Licenses: GPL3
Conflicts: tuxemon
Provides: tuxemon
Submitter: zufallsheld
Maintainer: morguldir
Last Packager: morguldir
Votes: 6
Popularity: 0.093251
First Submitted: 2015-08-11 18:38 (UTC)
Last Updated: 2022-01-19 21:16 (UTC)

Latest Comments

1 2 Next › Last »

Airon90 commented on 2022-08-17 09:38 (UTC)

Add python-pygame-menu to the dependencies

poudink commented on 2022-04-22 18:14 (UTC) (edited on 2022-04-22 18:14 (UTC) by poudink)

had to do pip install pygame_menu for the game to launch. the installation of pygame_menu also had to following error, but the game worked anyway: ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. tuxemon 0.4.34 requires PyYAML>=5.4.1, which is not installed. tuxemon 0.4.34 requires pyscroll==2.30, but you have pyscroll 2.19.3 which is incompatible.

morguldir commented on 2022-01-19 21:17 (UTC)

There is no need to manually update VCS packages like this, makepkg will handle that for you, using the pkgver() function. I have added python-prompt_toolkit as a dependency

HunabKu commented on 2022-01-18 14:47 (UTC) (edited on 2022-01-18 14:52 (UTC) by HunabKu)

0.4.33 is released as stable.

Just changed version to 0.4.33 in PKGBUILD works for compilation, but not for launch. Same error as kleintux

Airon90 commented on 2019-09-04 09:30 (UTC) (edited on 2019-09-04 09:30 (UTC) by Airon90)

This script seems to be broken. First of all AFAIK line 29 is wrong: you should not create a symlink to the Python file but a script so that "tuxemon" command equals "python /usr/share/tuxemon/tuxemon.py". Then, /usr/share/tuxemon/tuxemon.py doesn't exist

zufallsheld commented on 2016-08-28 16:40 (UTC)

When I last created the PKGBUILD python-pygame did not successfully build. Now it does so I changed the dependency. As to python-yapsy: I guess this was a depedendy sometime, not anymore. Same with netifaces. I updated the dependencies and also now am using the development branch of tuxemon, because its more up to date.

nontlikeuname commented on 2016-08-27 15:07 (UTC)

Is there any reason this depends on python-pygame-hg rather than python-pygame? Is any reason that tuxemon depends on python-yapsy or netifaces? Tuxemon seems to work with just python-pygame. (To the extent that tuxemon does work in its current state)

duckbrain commented on 2016-06-07 14:30 (UTC)

I was able to get the game to run by editing PKGBUILD to depend on `python2-pygame` instead of `python-pygame-hg` and installing `python2-pip` and running `sudo pip2 install pytmx`.

zufallsheld commented on 2016-06-06 18:51 (UTC) (edited on 2016-06-06 19:06 (UTC) by zufallsheld)

MCMic, I'll create a binary soon, thanks for bringing this up. As to the error you posted, that's a problem of the sourcecode of the game. This is already fixed in the development branch and the next release will probably have this fix.