Package Details: tuxonice-userui 1.1.65200132-1

Git Clone URL: (read-only)
Package Base: tuxonice-userui
Description: TuxOnIce userspace user interface
Upstream URL:
Licenses: GPL
Submitter: Snowman
Maintainer: gdamjan
Last Packager: gdamjan
Votes: 103
Popularity: 0.149422
First Submitted: 2009-03-12 03:19
Last Updated: 2016-02-07 21:52

Required by (2)

Sources (5)

Latest Comments

M0Rf30 commented on 2016-02-05 02:03

gdamjan commented on 2015-11-28 16:30

This should be reported upstream (possibly with reference to the ft docs)

jaro3 commented on 2015-11-28 15:13

OK, this worked:

#include FT_FREETYPE_H
/*#include <ftoutln.h>*/
#include <freetype/ftoutln.h>

gdamjan commented on 2015-10-15 18:37

do you have a reference why that change is needed?

M0Rf30 commented on 2015-10-15 15:18

please replace row 26 in ttf.c
#include <freetype/ftoutln.h>

gdamjan commented on 2015-09-09 14:11

well, freetype2-infinality is version 2.6 and vanilla freetype is 2.11 - you'd have to patch that line out at your side.

ps. somehow I've looked at the version of fontconfig and not freetype. I still don't know why -infinality fails like that.

jaro3 commented on 2015-09-09 08:19

ttf.c:31:21: fatal error: ftoutln.h: No such file or directory
compilation terminated.
Makefile:15: recipe for target 'ttf.o' failed
make[1]: *** [ttf.o] Error 1


doesn't build perhaps because I'm using the infinality fonts :-(

nous commented on 2015-08-20 21:32

1.1.2-1 compiled just fine. Thanks.

gdamjan commented on 2015-08-20 16:53

hm, aur doesn't show the new package. wth

gdamjan commented on 2015-08-18 20:08

I bumped the version to one with some of the patches applied.
It should compile now. Can anyone test it, I'm not currently using tuxonice.

mikroskeem commented on 2015-06-21 23:59

/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:67: undefined reference to `put_pixel'

Won't compile anymore

mikroskeem commented on 2015-06-21 23:58

cc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -O3 -DUSE_FBSPLASH -Wall -O3 -g -I/usr/include/freetype2/ -I. -c ttf.c -o ttf.o
ttf.c: In function ‘Load_Glyph’:
ttf.c:371:4: warning: implicit declaration of function ‘FT_Outline_Transform’ [-Wimplicit-function-declaration]
FT_Outline_Transform(outline, &shear);
In file included from ttf.c:32:0:
ttf.c: At top level:
splash.h:232:13: warning: inline function ‘put_pixel’ declared but never defined
inline void put_pixel (u8 a, u8 r, u8 g, u8 b, u8 *src, u8 *dst, u8 add);
cc -Wl,-O1,--sort-common,--as-needed,-z,relro -r -nostdlib -nostartfiles userui_fbsplash_core.o cmd.o common.o effects.o image.o list.o parse.o mng_callbacks.o mng_render.o render.o ttf.o -o userui_fbsplash.o
make[1]: Leaving directory '/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash'
cc -Wl,-O1,--sort-common,--as-needed,-z,relro userui_core.o userui_text.o fbsplash/userui_fbsplash.o -lmng -lpng -ljpeg -lfreetype -lm -o tuxoniceui
fbsplash/userui_fbsplash.o: In function `truecolor2fb':
/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:67: undefined reference to `put_pixel'
/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:67: undefined reference to `put_pixel'
/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:64: undefined reference to `put_pixel'
/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:67: undefined reference to `put_pixel'
/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/image.c:67: undefined reference to `put_pixel'
fbsplash/userui_fbsplash.o:/tmp/yaourt-tmp-mark/aur-tuxonice-userui/src/Tuxonice-Userui-1.1.1/fbsplash/ttf.c:667: more undefined references to `put_pixel' follow
collect2: error: ld returned 1 exit status
Makefile:45: recipe for target 'tuxoniceui' failed
make: *** [tuxoniceui] Error 1
==> ERROR: A failure occurred in build().

gdamjan commented on 2014-08-11 17:12

I have a github fork with those patches.

I'll just update the PKGBUILD to use that fork

acaccia commented on 2014-08-11 17:09

I've created patches to fix includes for myself ; I thought I'd share it with you :-)

Add file "patch_ttfc.txt" containing : ;
file "patch_ttfh.txt" containing : ;
and updated PKGBUILD :

depaiao commented on 2014-08-10 04:12

please upgrade

AdmiralAkber commented on 2014-01-10 17:15

The easiest solution I've found was simply to sym link /usr/include/freetype2 to /usr/include/freetype temporarily for the build.

GottZ commented on 2014-01-07 20:54

in ttf.c and ttf.h just remove freetype/ from the includes and voila. compiles fine.

gdamjan commented on 2014-01-06 02:02

A quick fix is to replace the include with:

#include <ft2build.h>
#include FT_FREETYPE_H

I'll see if upstream will apply the patch or I'll need to fork the repo.

AdmiralAkber commented on 2014-01-05 03:27

Build fails with error:

make -C fbsplash
make[1]: Entering directory '/tmp/packerbuild-1000/tuxonice-userui/tuxonice-userui/src/NigelCunningham-Tuxonice-Userui-c3bdd83/fbsplash'
cc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -Wall -O3 -DUSE_FBSPLASH -Wall -O3 -g -I/usr/include/freetype2/ -I. -c userui_fbsplash_core.c -o userui_fbsplash_core.o
In file included from splash.h:147:0,
from userui_fbsplash_core.c:28:
ttf.h:4:30: fatal error: freetype/ftoutln.h: No such file or directory
#include <freetype/ftoutln.h>

nous commented on 2013-09-12 19:42

gdamjan commented on 2013-09-12 08:24


that link doesn't do anything for me. I just get an empty page.

nous commented on 2013-09-10 21:44

I think I use fbsplash-theme-arch-black on the desktop. It's an Athlon X2 with GeForce 9800GT, binary nvidia-pf on a 1920x1080 TV set. Sometimes the framebuffer kinda works (i.e. with the stripes) - sometimes it doesn't (i.e. falls back to text, probably after some image lib update).

The Dell Vostro 1500 has a GeForce 8600M-GT (nvidia-pf too) and I use a custom theme at its native resolution of 1680x1050. I've tarxz'ed the entire directory for your convenience and uploaded it to

gdamjan commented on 2013-09-10 16:39

thanks, it feels nice to know I'm not the only one :)

What's the difference between your laptop and desktop?
Do you use the same theme? What theme do you use on the Dell?
What kind of GPU do you have? What resolution?

My tests are on Thinkpad X60s with intel 950 gpu/chipset and 1024x768 native resolution on the LCD. The i915 KMS driver is built-in in the kernel.

nous commented on 2013-09-10 16:34

gdamjan: I do user fbsplash, it works flawlessly on my Dell laptop, but I have black stripes through the background image on my no-name desktop.

nous commented on 2013-09-10 16:24

pablox: you need to rebuild tuxonice-userui to get linked against libmng v2.

gdamjan commented on 2013-09-10 14:15

bumped pkgrel

is anyone using the fbsplash support? I do, but the background of the splash doesn't look right, it's all stripped where it needs to be solid black.

pablox commented on 2013-09-10 14:09

I had an issue after updating to the last linux-pf kernel (3.11.1-pf)... when running mkinitcpio, it was complaining about `tuxonice-userui` not finding the ``. Weird because it wer in the lib directory (`ldd` command said the same on `/usr/sbin/tuxonice`.

Rebuilding this package solved the problem (and now `ldd` points to ``...). Anyway, you should bump the `pkgrel` to force an update ;).

gdamjan commented on 2013-06-04 15:27


what version of makepkg do you have? The package itself doesn't invoke wget, makepkg does that (and works fine here).

xxxxme commented on 2013-06-04 15:24

When I makepkg:
-> Downloading tuxonice-userui-1.1-c3bdd83.tgz...
Usage: wget [OPTION]... [URL]...

Try `wget --help' for more options.
/usr/bin/makepkg: line 374: tuxonice-userui-1.1-c3bdd83.tgz.part: command not found

gdamjan commented on 2013-06-01 16:20

Moved to /usr/bin

SirWuffleton commented on 2013-05-16 15:29

You should probably bump the PKGREL out of courtesy. Since this package depends on libpng, it requires a recompile in order to work properly after the recent update. If anyone else is puzzled why their UI suddenly disappeared, this is probably the issue.

jakob commented on 2012-10-17 09:56

Yeah ok. I was really astonished when I pressed suspen/hibernate keys and my box hybernated. Still, as I want my box to be locked after restart, I set it to use the /etc/hibernate/ scripts & configs as shown here:

gdamjan commented on 2012-10-17 02:25

now I just do "systemctl hibernate" seems to work just fine with the hook I recently added.

Also you can set HandlePowerKey=hibernate in /etc/systemd/logind.conf so that it hibernates when the power button is pressed.

jakob commented on 2012-10-16 14:41

Hey, thx for the update! How do you guys use hibernation on systemd? Did you set systemd to use /usr/bin/hibernate?

gdamjan commented on 2012-10-08 21:37

This update uses a newer git revision and adds a systemd sleep hook

gdamjan commented on 2012-04-06 03:26


This package, as of 1.1-3, now installs in /usr/lib and /usr/sbin only.

gdamjan commented on 2012-04-06 03:25

Done. this package now installs in /usr/lib and /usr/sbin only

gdamjan commented on 2012-04-04 14:06

Very soon tuxonice-userui will move the initcpio files to /usr as the new mkinitcpio moves from [testing] to [extra]

gdamjan commented on 2012-02-11 15:04

There's no need for a patch. The latest git version compiles fine with libpng15.
I'll update the PKGBUILD now.

ValdikSS commented on 2012-02-09 17:56

Fixed! PKGBUILD libpng15.patch

Anonymous comment on 2012-02-09 16:23

@gdamjan i can confirm that, does not build here.

gdamjan commented on 2012-02-07 20:58

Seems to not build with the new libpng 1.5.8
Investigating. If anyone has hints please share them here.

gdamjan commented on 2011-07-25 07:57

Updated the initcpio hook. There was one more use of $tuxoniceui_sys instead of $tuxonice_sys

kalpik commented on 2011-07-24 14:28

Thanks for fixing this :)

gdamjan commented on 2011-07-24 14:14

bah, found it.
it was the "-d $tuxoniceui_sys" which should've been "-d $tuxonice_sys"

I also changed the version number to the one in the ChangeLog file - I would've done it earlier, but couldn't find the convention about release candidates. Of course it only matters for this site, the package itself will take the build date since it's a git package.

gdamjan commented on 2011-07-24 13:21

I have no idea on the "-x" issue. I got the same when booting, but I don't understand how that can happen when it works outside of the initramfs (with busybox and busybox ash).

gdamjan commented on 2011-07-22 08:58

userui-hook updated

kalpik commented on 2011-07-21 02:25

@gdamjan: Thanks for the reply! The problem with resume was a problem with the latest pf-kernel. But yes, you should fix your userui hook!

gdamjan commented on 2011-07-20 22:52

hmm, seems to work here. what's your mkinitcpio.conf ?

The error you get is a bit strange:
[ 3.947999] Failed to launch userspace program '/usr/sbin/tuxoniceui': Error -2

also I don't know what this means:
[ 4.035116] Breaking out of I/O loop because of result code -22.
but tuxonice gives up trying to resume, and then the normal hibernate tries to continue.
Do you have CONFIG_TOI_REPLACE_SWSUSP=y set in your kernel?

Also, can you run:
/lib/initcpio/busybox [ -d "/sys/power/tuxonice" -a -x "/usr/sbin/tuxoniceui" ] && echo ok || echo not ok

kalpik commented on 2011-07-20 13:00

Also, I cannot resume now.. Here's what it says:

Sorry for the comment spam!

kalpik commented on 2011-07-20 12:41

Even after adding the "then" there, I'm getting this:

[running hook userui]
ash: -x: unknown operand

kalpik commented on 2011-07-20 12:24

There seem to be a syntax error in the userui hook:

vim:set ft=sh:
run_hook ()

if [ -d $tuxoniceui_sys -a -x $tuxoniceui_cmd ]; then
if [ -c /dev/fb0 -a -d /etc/splash/tuxonice ]; *MISSING THEN HERE*

echo $tuxoniceui_cmd $tuxoniceui_opt > $tuxoniceui_sys/user_interface/p$

gdamjan commented on 2011-07-19 16:31

Updated the package to get the latest version from git.
I've set the PKGBUILD to get the commit that is now the latest (6befcbbfc5052f95e5e258a34107fb987f06b6dc) which should be considered 1.1rc2.

This update brings the "single binary support" - i.e. text mode, fbsplash and optionally usplash are combined into one binary /usr/sbin/tuxoniceui. The initcpio scripts are also updated, and suspend2 support is dropped.

(usplash support is not enabled, of course)

gdamjan commented on 2011-07-16 10:52

Updated to use build() instead of install() function in the mkinitcpio script (/lib/initcpio/install/userui)

gdamjan commented on 2011-07-15 18:14

what are the improvements?

Det commented on 2011-01-11 16:09

Improved PKGBUILD:

gdamjan commented on 2010-11-03 13:16

I guess since the PKGBUILD is different

Det commented on 2010-10-30 07:22

If the tarball is the same why did you bump the pkgrel?

gdamjan commented on 2010-10-29 10:12

Updated the source url in rev -6, thanks guys

Anonymous comment on 2010-10-28 23:40

@cantabile You can replace it with this link from the ubuntu repos:

I think this is because the tuxonice team are working on the wikis

jackoneill commented on 2010-10-05 09:39

Indeed it is. With the current address I get an html document >_<

Correct address is:

Anonymous comment on 2010-09-18 10:19

Please, correct the download link. The current one ( is unvalid now.