Package Details: tvnamer-git 20130403-3

Git Clone URL: https://aur.archlinux.org/tvnamer-git.git (read-only)
Package Base: tvnamer-git
Description: Automatic TV episode file renamer using Python, It uses data from thetvdb.com via tvdb_api.
Upstream URL: http://github.com/dbr/tvnamer/
Licenses: GPL
Provides: tvnamer
Submitter: None
Maintainer: cdemoulins
Last Packager: cdemoulins
Votes: 15
Popularity: 0.056945
First Submitted: 2010-04-17 17:29
Last Updated: 2015-07-02 09:37

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Berseker commented on 2012-11-02 08:34

please replace python-simplejson with python2-simplejson

munkoil commented on 2011-11-23 15:24

I mean that it is expected that it do not install the build dependencies. But it has to be installed :). Sorry for being sloppy when typing.

munkoil commented on 2011-11-23 15:19

Hi,
Thanks! But it looks like you have to add it as a dependency. When I build it now with makepkg -sr and then install it, python2-distribute is not installed, which is what you expect from a build dependency. But then I get the following error,


Traceback (most recent call last):
File "/usr/bin/tvnamer", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

This disappear when I install python2-distribute.

cdemoulins commented on 2011-11-23 14:46

I added python2-distribute that provide setuptools as build dependency.

munkoil commented on 2011-11-22 18:34

Getting the following error when building:

Traceback (most recent call last):
File "setup.py", line 14, in <module>
from setuptools import setup
ImportError: No module named setuptools
==> ERROR: A failure occurred in build().
Aborting...

Looks like you forgot to add the setuptools dependency. I don't know which one.

cdemoulins commented on 2010-11-10 23:53

Please update this package for python2 compatibility or orphan it and i will maintain it.

Berseker commented on 2010-10-20 05:59

please update PKGBUILDfor python2 compatibility. Simply add "python2" instead of "python" in the PKGBUILD. Same mod is needed for tvdb_api PKGBUILD.

Berseker commented on 2010-10-20 05:53

please update PKGBUILD for using python2, thanks

Anonymous comment on 2010-04-19 23:13

ok thank you cdemoulins i will add depencies.

cdemoulins commented on 2010-04-19 11:20

Git version of tvdb_api seem to be broken. You can instead use the package i made (another) tvdb_api.

All comments