Package Details: twinkle 1.4.2-19

Git Clone URL: https://aur.archlinux.org/twinkle.git (read-only)
Package Base: twinkle
Description: Softphone for voice over IP and IM communication using SIP
Upstream URL: http://www.twinklephone.com/
Licenses: GPL
Submitter: sergej
Maintainer: None
Last Packager: tredaelli
Votes: 14
Popularity: 0.000000
First Submitted: 2012-05-15 11:57
Last Updated: 2015-07-14 13:22

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

mazieres commented on 2013-08-29 07:46

Doesn't build for me. Perhaps a missing dependency? The configure phase fails with:

checking for lrelease... no
configure: error: lrelease is missing (qt3-devel-tools package)

mathias.steiger commented on 2013-04-27 16:57

Doesn't compile anymore. Very ugly fix: Put this under patch -p0 .. up to .configure .. as a replacement. You need to install automake-1.12 from AUR.
--------------------------------
cd "$pkgname-$pkgver"
export automake=1.12
export QTDIR=/usr/lib/qt3/
/usr/bin/aclocal-1.12
/usr/bin/autoconf
/usr/bin/automake-1.12 -a
mkdir -p src/gui/.ui
mkdir -p src/gui/.obj
mkdir -p src/gui/.moc
if [[ "$(uname -a | grep -os x86_64)" == "x86_64" ]]; then
find ./ -exec sed "s/\(i686-pc\|i586-pc\)/x86-64/g" -i '{}' \;
find ./ -exec sed "s/\(i686\|i586\)/x86-64/g" -i '{}' \;
fi
--------------------------------
You also need to:
ln -s /usr/share/qt3/mkspecs /usr/lib/qt3/mkspecs
ln -s /usr/lib /usr/lib/qt3/lib
ln -s /usr/include/qt3 /usr/lib/qt3/include

It compiles, HOWEVER: I have a near-perfect asterisk setup locally and wouldn't get SIP audio. The UI of twinkle is not nice imo and it crashes for all sorts of reasons, e.g. if the connection to the SIP provider is suddenly lost .. Not very worthwhile.

nemamradfazole commented on 2013-04-18 19:31

/etc/profile.d/qt3.sh (formerly from qt3) doesn't exist anymore, but it is called by PKGBUILD.

cidermole commented on 2013-04-06 20:44

Here is an additional section for the patch of configure.in to make it work:

@@ -1,6 +1,6 @@
AC_INIT(src/phone.h)
AC_CANONICAL_SYSTEM
-AM_CONFIG_HEADER(src/twinkle_config.h)
+AC_CONFIG_HEADERS(src/twinkle_config.h)

AC_ARG_ENABLE(qt-check,
AC_HELP_STRING([--disable-qt-check], [do not check Qt installation]),

bidulock commented on 2013-04-03 18:21

1.4.2-18 won't compile on x86_64.

aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
acinclude.m4:3437: warning: the serial number must appear before any macro definition
acinclude.m4:3482: warning: the serial number must appear before any macro definition
acinclude.m4:3527: warning: the serial number must appear before any macro definition
acinclude.m4:5689: warning: the serial number must appear before any macro definition
configure.in:3: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:3: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build twinkle.

nemamradfazole commented on 2013-02-25 21:59

I tried version 1.4.1 from the official site and it works the same way. It seems (http://ubuntuforums.org/showpost.php?p=7896858&postcount=2) this might be a quite old problem. So I tried compiling version 1.2 (https://gitorious.org/twinkle/twinkle/trees/upstream/1.2), but it depends on old alocal etc. so I wasn't successful.

olive commented on 2013-02-25 21:32

@nemamradfazole Yes this is what I said. There is a patch to build with the recent version of ccrtp and libzrtpcpp but this seems broken. It build but does not give a working binary. Downgrading these two libaries fixed the problem, but I just use linphone now. Anyway, I would be happy if someone have a solution.

nemamradfazole commented on 2013-02-25 21:19

With the latest version a call-receiver hears me, but I cannot hear anything.

JohnnyDeacon commented on 2013-02-14 23:19

Please update this package! or create a GIT version.

Michitux commented on 2013-02-12 16:45

The macro AM_CONFIG_HEADER is obsolete, according to http://www.delorie.com/gnu/docs/automake/automake_24.html AC_CONFIG_HEADERS in current automake versions is a synonym for this obsolete macro.

Adding
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in
after
cd "$pkgname-$pkgver"
solved the problem for me.