Package Details: twonky 8.4.1-10

Git Clone URL: https://aur.archlinux.org/twonky.git (read-only)
Package Base: twonky
Description: A DLNA-compliant UPnP AV server software from PacketVideo.
Upstream URL: http://twonky.com/
Licenses: custom
Submitter: visit
Maintainer: muhviehstarr
Last Packager: muhviehstarr
Votes: 5
Popularity: 0.000000
First Submitted: 2014-03-15 13:21
Last Updated: 2017-07-03 21:54

Latest Comments

muhviehstarr commented on 2017-07-03 07:41

also someone could check arm versions.. like raspberry users.. thanks

muhviehstarr commented on 2017-07-03 06:12

adopted the packages.

someone please check if the i686 version is working?

shwouchk commented on 2016-08-22 09:32

Hi,

the unzip package is a build requirement for installing, but is not listed.

F1nny commented on 2015-03-24 23:43

That did it! Good call, thanks visit and thanks again for maintaining on the AUR makes upgrading much easier:)

visit commented on 2015-03-24 22:50

Solved for me. Please test.

The secret sauce: options=('!strip')

Also updated the directory structure slightly, as we had both: /var/twonky/share{,d}

F1nny commented on 2015-03-24 20:56

mkdir /usr/lib/twonky && cd /usr/lib/twonky
wget http://www.twonkyforum.com/downloads/8.0.2/twonky-x86-64-glibc-2.9-8.0.2.zip
unzip twonky-x86-64-glibc-2.9-8.0.2.zip
mkdir /var/twonky
/usr/lib/twonky/twonkystarter -appdata "/var/twonky"

So question is how is that different from the pkgbuild? I edited the pkgbuild to do the same (removing ini entries) and still receive the error, however doing it manually as root as above it runs fine, any ideas? Also I do not believe it has anything to do with running twonkystarter vs twonkyserver as doesn't seem to make a difference.

F1nny commented on 2015-03-24 20:34

Still not too sure what's wrong, I contacted Twonky and they suggested that's usually because of a permissions issue however I can't seem to find any permission problems not to mention running as root should bypass most of those. Just to test something I removed all the files, mkdir /usr/local/twonky then wget'ed the same source file as the PKGBUILD does, unzipped into that folder, and ran /usr/local/twonky/twonkystarter -appdata "/var/twonky" and that seemed to work, what's really odd is that the differences in the pkgbuild are minor at best and shouldn't make any difference from what I did so not sure what the problem is. I tried without the .ini file in the pkgbuild but the same occurred, something is off somewhere just having trouble tracking it down.

F1nny commented on 2015-03-18 03:20

Very weird so am I, trying to figure where it's looking

visit commented on 2015-03-18 00:33

Anyone else getting
upnp_mediaserver_start : no valid license found
?

visit commented on 2015-03-17 23:42

@hazey: Thanks, updated.

All comments