Package Details: udis86 1.7.2-1

Git Clone URL: https://aur.archlinux.org/udis86.git (read-only)
Package Base: udis86
Description: A minimalistic disassembler library
Upstream URL: http://udis86.sourceforge.net/
Licenses: BSD
Submitter: iceman81
Maintainer: stevenhoneyman
Last Packager: stevenhoneyman
Votes: 35
Popularity: 0.220196
First Submitted: 2008-04-28 10:20
Last Updated: 2015-06-09 18:10

Latest Comments

Alister.Hood commented on 2014-09-17 00:59

# ./configure --help
...
--enable-shared[=PKGS] build shared libraries [default=no]
--enable-static[=PKGS] build static libraries [default=yes]

Alister.Hood commented on 2014-09-17 00:42

I ask because other PKGBUILDS like the one posted below by hardfalcon also used --enable-shared.

Alister.Hood commented on 2014-09-17 00:14

So do you get shared libraries if you build this?

stevenhoneyman commented on 2014-09-16 23:24

Also, udis86-git is a much better choice. This hasn't been updated since 2008 upstream "official", but the radare2 people are working on it now.

stevenhoneyman commented on 2014-09-16 23:22

That might explain why you're having problems with wxhexeditor-svn also... I think your system is broken :P

Alister.Hood commented on 2014-09-16 22:25

I was only getting static libraries until I added this:
--enable-shared --disable-static

hardfalcon commented on 2013-11-09 10:18

Completely revised PKGBUILD for version 1.7.2:
http://pastebin.com/TnPxGnT8

Anonymous comment on 2013-07-17 15:52

Yet another PKGBUILD update (git friendly) http://bpaste.net/show/115014/

queueRAM commented on 2013-04-15 21:13

Updated version of PKGBUILD including using separate package() function and referencing srcdir and pkgdir instead of startdir:
http://hastebin.com/bacefiqate

Nothing4You commented on 2013-04-15 15:14

==> WARNING: Using a PKGBUILD without a package() function is deprecated.

Freso commented on 2012-05-29 15:43

Using yaourt, I'm getting:
"""
==> Starting build()...
/tmp/yaourt-tmp-freso/aur-udis86/./PKGBUILD: line 14: cd: /tmp/yaourt-tmp-freso/aur-udis86/src/udis86-1.7: No such file or directory
"""

Anonymous comment on 2012-05-06 17:57

This package works unmodified on mips64el architecture. Please, replace "arch=('i686' 'x86_64')" with "arch=('i686' 'x86_64' 'mips64el')".