Package Details: udisks2-nosystemd 2.7.4-1

Git Clone URL: https://aur.archlinux.org/udisks2-nosystemd.git (read-only)
Package Base: udisks2-nosystemd
Description: Disk Management Service, version 2
Upstream URL: http://www.freedesktop.org/wiki/Software/udisks
Licenses: GPL2
Groups: eudev-base
Conflicts: udisks2, udisks2-eudev
Provides: udisks2=2.7.4
Replaces: udisks2, udisks2-eudev
Submitter: TZ86
Maintainer: TZ86
Last Packager: TZ86
Votes: 14
Popularity: 0.006684
First Submitted: 2013-01-24 15:47
Last Updated: 2017-11-21 11:52

Dependencies (15)

Required by (47)

Sources (2)

Latest Comments

TZ86 commented on 2017-09-10 10:26

Oops, seems to I've totally missed updates of that packages. Thanks for notifying.

@Alad
Well, repo version is actually depends on systemd (or rather on libsystemd-login) and its udisksd binary is linked with libsystemd.so.0. So these, who had completely removed systemd and his libs, may need to rebuild it.

But if you have systemd libs in your system then yes, you can just use udisks2 from official repo.

Alad commented on 2017-09-06 19:23

This is pretty outdated, both in upstream release and regarding changes in the arch repos. The repo version does not depend on systemd, only having a superficial configure flag on where to place systemd services (--with-systemdsystemunitdir). Unless the package fails to build due to this configure flag when systemd is not installed, there's no point to have it around. Better to file a request for libgudev to not depend on systemd as it's not strictly required: https://git.gnome.org/browse/libgudev/tree/configure.ac#n41