Package Details: unity-editor-beta 2018.2.0b7+20180608-1

Git Clone URL: https://aur.archlinux.org/unity-editor-beta.git (read-only)
Package Base: unity-editor-beta
Description: The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
Upstream URL: https://unity3d.com/
Keywords: beta develop engine gamedev unity3d
Licenses: custom
Submitter: spacepluk
Maintainer: spacepluk
Last Packager: spacepluk
Votes: 22
Popularity: 2.048980
First Submitted: 2016-03-16 16:54
Last Updated: 2018-06-11 10:10

Dependencies (26)

Sources (4)

Pinned Comments

spacepluk commented on 2017-10-05 15:38

Following 2013.3.0b1 all the components in UnitySetup correspond to separate AUR packages.

So, for example to get the editor with Android build support you need to install both: unity-editor-beta and unity-editor-beta-android. Check the optional dependencies for the other platforms/components.

MonoDevelop wasn't included in this build: https://forum.unity.com/threads/2017-3-0b1-editor-issues.498477/#post-3242701

Latest Comments

archaeopteryx commented on 2018-04-05 19:50

New version is out

https://forum.unity.com/threads/unity-on-linux-release-notes-and-known-issues.350256/page-2#post-3450822

2018.1.0b13: https://beta.unity3d.com/download/77a142ac9989/public_download.html sha1: db01d63684c7bf114d9b5df6d0c23f81894dd2d5

This says it has a fix for the layout change crash if that affects anyone else here

3KyNoX commented on 2018-03-21 09:39

Hello, any way to install the latest preview (from 19th march, MLTP1) with Magic Leap target build added.

I can't get the exact link from unity beta download to update it on pkgBuild.

Thanks anyway

mahakala commented on 2018-01-15 15:30

I get an empty error message when pressing play.

When I create a new project without any code, but a cube, this does not happen. However, as soon as I add a new script (unmodified, with just the Start(){} and Update(){} empty as per default) I get the error.

I also tried the non beta unity-editor but got the same error...

scab commented on 2018-01-15 05:51

When i be able to get 2018.1b, guys?

spacepluk commented on 2017-10-05 15:38

Following 2013.3.0b1 all the components in UnitySetup correspond to separate AUR packages.

So, for example to get the editor with Android build support you need to install both: unity-editor-beta and unity-editor-beta-android. Check the optional dependencies for the other platforms/components.

MonoDevelop wasn't included in this build: https://forum.unity.com/threads/2017-3-0b1-editor-issues.498477/#post-3242701

spacepluk commented on 2017-09-18 08:30

@Krutonium I see that here:

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=unity-editor-beta#n28

Krutonium commented on 2017-09-18 08:16

Missing Dep: libpqxx

midgard commented on 2017-08-13 12:55

There're unquoted ${srcdir}s and ${pkgdir}s on lines 68 (twice), 71, 74 and 96 (twice).

Lattyware commented on 2017-07-10 13:16

Having fun again with 2017.2.0b2 - when I launch and try to open a project, I get:

Failed to resolve packages. Please see Editor.log file for more information

Editor.log contains:

Desktop is 7680 x 3600 @ 60 Hz

LICENSE SYSTEM [2017710 14:9:11] No start/stop license dates set

LICENSE SYSTEM [2017710 14:9:11] Next license update check is after 2017-07-07T14:22:03


COMMAND LINE ARGUMENTS:
/opt/UnityBeta/Editor/Unity
[0710/140911:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[0710/140911:ERROR:renderer_main.cc(227)] Running without renderer sandbox
[0710/140911:ERROR:gpu_process_transport_factory.cc(402)] Failed to establish GPU channel.
IsTimeToCheckForNewEditor: Update time 0 current 1499692152
/home/gareth/Work/test
UpdateMenuTitleForLanguage: 10
Loading GUID <-> Path mappings...0.000038 seconds
Loading Asset Database...0.005138 seconds
Audio: FMOD Profiler initialized on port 54901
AudioManager: Using PulseAudio: Default Output Device
AssetDatabase consistency checks...0.256904 seconds
Refreshing native plugins compatible for Editor in 12.88 ms, found 0 plugins.
Preloading 0 native plugins for Editor in 0.00 ms.
PackageManager Server::Start -- Port 58220 was selected
events.js:160
throw er; // Unhandled 'error' event
^

Error: write EPIPE
at exports._errnoException (util.js:1022:11)
at WriteWrap.afterWrite (net.js:801:14)

As always, hard to say if this is a packaging issue or actual Unity-side issue.

ArXen42 commented on 2017-06-22 00:11

Download link is broken (it seems like there was no new beta version but the link had slightly changed). Corrent link is now http://beta.unity3d.com/download/45784aaa9968/unity-editor-installer-2017.1.0xb8Linux.sh.

All comments