Package Details: unity-editor 1:2018.2.15f1-1

Git Clone URL: https://aur.archlinux.org/unity-editor.git (read-only)
Package Base: unity-editor
Description: The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
Upstream URL: https://unity3d.com/
Keywords: develop engine gamedev unity3d
Licenses: custom
Submitter: LeonardK
Maintainer: spacepluk (jurf, fwalch)
Last Packager: spacepluk
Votes: 141
Popularity: 4.364637
First Submitted: 2015-08-26 18:08
Last Updated: 2018-11-12 12:19

Sources (5)

Pinned Comments

spacepluk commented on 2018-01-19 12:03

MonoDevelop is officially deprecated: https://blogs.unity3d.com/2018/01/05/discontinuing-support-for-monodevelop-unity-starting-in-unity-2018-1/

spacepluk commented on 2018-01-03 10:01

Following 2013.3.0f1 all the components in UnitySetup correspond to separate AUR packages.

So, for example to get the editor with Android build support you need to install both: unity-editor-beta and unity-editor-beta-android. Check the optional dependencies for the other platforms/components.

MonoDevelop is not included since 2013.3.0b1: https://forum.unity.com/threads/2017-3-0b1-editor-issues.498477/#post-3242701

jurf commented on 2016-11-07 21:01

This is not the beta package! Please do not flag it out of date if the new version has the letter "b" in it. Instead please look at https://aur.archlinux.org/packages/unity-editor-beta/

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

spacepluk commented on 2018-05-10 08:13

@ask6155 that's what I meant sorry. I don't see anything wrong. It takes a while to build the package did you let it running enough time?

ask6155 commented on 2018-05-10 05:46

There is no editor.log but in /tmp there is a file called unity.log here it is https://pastebin.com/Syt5wr8B

spacepluk commented on 2018-05-09 11:35

hi @ask6155, can you post a pastbin with the content of /tmp/Editor.log after it fails?

ask6155 commented on 2018-05-09 07:20

A failure occurred in the package() it started package() extracting EULA......... then it fails

also might help

(UnitySetup-2018.1.0f2:14654): Gtk-WARNING **: 12:45:01.304: Unable to locate theme engine in module_path: "adwaita",

spacepluk commented on 2018-04-26 07:06

@josexyz actually, somebody already asked and linux is not supported:

https://forum.unity.com/threads/lastest-version-of-vuforia-with-linux-editor.510369/#post-3398768

spacepluk commented on 2018-04-26 07:05

@josexyz I think you're more likely to get answers about this if ask in Unity's forum:

https://forum.unity.com/forums/linux-editor.93/

josexyz commented on 2018-04-23 04:04

I want to use the Vuforia Unity Component, it appears there is no AUR package for this component. How do I install this component?

spacepluk commented on 2018-03-23 12:48

@vita_cell it looks like there's something in your system that prevents the update of the desktop database. I would try uninstalling lib32-libcaberra and lib32-libcanberra-gtk3 and see if that helps. You can ping me on freenode if you'd like and I'll try to help :)

vita_cell commented on 2018-03-23 12:29

@spacepluk you are right, but now I have the same error as months before, it hangs at licence agreement:

  1. “Your Project Content” means games, applications, software or other content that you develop with the Unity Software.

Do you accept the ter

UPDATE: I left it doing something (no output in console), but now I have new errors:

cargando los paquetes... resolviendo dependencias... buscando conflictos entre paquetes...

Paquetes (1) unity-editor-1:2017.3.1f1+20180216-1

Tamaño total de la instalación: 2649,07 MiB

:: ¿Continuar con la instalación? [S/n] (1/1) comprobando las claves del depósito [#################] 100% (1/1) verificando la integridad de los paquetes [#################] 100% (1/1) cargando los archivos de los paquetes [#################] 100% (1/1) comprobando conflictos entre archivos [#################] 100% (1/1) comprobando el espacio disponible en el ... [#################] 100% :: Procesando los cambios de los paquetes... (1/1) instalando unity-editor [#################] 100% Dependencias opcionales para unity-editor unity-editor-doc unity-editor-standardassets unity-editor-example unity-editor-android unity-editor-ios unity-editor-mac unity-editor-webgl unity-editor-windows unity-editor-facebook :: Ejecutando los «hooks» de posinstalación... (1/3) Updating icon theme caches... (2/3) Arming ConditionNeedsUpdate... (3/3) Updating the desktop file MIME type cache... error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/gtk-3.0/modules/libcanberra-gtk-module.so' error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/gtk-3.0/modules/libcanberra-gtk3-module.so' error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/libcanberra-gtk3.so' error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/libcanberra-gtk3.so.0' error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/libcanberra-gtk3.so.0.1.9' error: file owned by 'lib32-libcanberra' and 'lib32-libcanberra-gtk3': 'usr/lib32/pkgconfig/libcanberra-gtk3.pc'

spacepluk commented on 2018-03-22 12:19

@datgame my guess is that you don't have enough space to create the package. Can you post the content of /tmp/Unity.log when that happens?

@vita_cell's problem doesn't seem related to unity-editor but the log would help figure out what's going on.