Package Details: uplink 1.55-5

Git Clone URL: (read-only)
Package Base: uplink
Description: Trust is a weakness - a futuristic computer crime game
Upstream URL:
Licenses: custom
Submitter: heftig
Maintainer: heftig
Last Packager: heftig
Votes: 9
Popularity: 0.000002
First Submitted: 2009-08-02 11:05
Last Updated: 2016-03-31 16:32

Latest Comments

chrys87 commented on 2016-03-31 16:28

Error: Destination not found lib32-libjpeg6

it seems that the depency is broken "lib32-libjpeg6"
in the AUR is just a Package for lib32-libjpeg6-turbo. Dont know if that work.

kaptoxic commented on 2014-12-31 13:52

Old PKGBUILD? I get an error:
==> ERROR: Missing package() function in /tmp/yaourt-tmp-x/aur-uplink/./PKGBUILD
==> ERROR: Makepkg was unable to build uplink.

Maxr commented on 2013-01-29 10:26

Thanks, works as expected!

Maybe you want to change the patch url? Found it here:

KinG-InFeT commented on 2012-11-17 15:55

┌─[root] @ [KinG-InFeT]
└─[(~)] > packer -S uplink

Aur Targets (1): uplink

Proceed with installation? [Y/n] y
nEdit uplink PKGBUILD with $EDITOR? [Y/n]
==> Creazione del pacchetto: uplink 1.55-3 (sab 17 nov 2012, 17.01.42, CET)
==> Controllo delle dipendenze durante l'avvio in corso...
==> Controllo delle dipendenze durante la compilazione in corso...
==> Download dei sorgenti in corso...
==> ERRORE: impossibile trovare nella directory di compilazione e non è un URL.
The build failed.

tea commented on 2012-08-02 13:25

For people with the GOG version of Uplink, have a look here:

Anonymous comment on 2012-04-03 00:26

For me, the md5sum of was incorrect.

My md5sum output was c9d019129bba0900fb185a3a8ae6f26b - replace the first line of md5sums=(...) with that made things work.

JazzplayerL9 commented on 2011-11-28 06:25

I uploaded a humble bundle version of uplink called uplink-hib if anyone wants to try it. Once the introversion website releases 1.6 maybe it'll go away and all the issues will be resolved with versioning.

vEX commented on 2011-11-25 20:26

Quick and dirty PKGBUILD for 64-bit humble bundle uplink package:

Anonymous comment on 2011-11-24 20:10

Doesn't launch for me otherwise.

heftig commented on 2011-11-24 08:28

What's the point of this? Why would you use the retail 1.55 patch on the HumbleBundle version?

Anonymous comment on 2011-11-24 07:24

There is no patch for 1.6, however, I was able to get uplink (bundled with Humble Introversion Bundle) working using the 1.55 patch:

You might need to install gtk 1.2 (pacman -S gtk), and SDL_mixer (pacman -S sdl_mixer) before anything will work.

Then download the uplink tar.gz file in your HIB key page, extract to a directory somewhere.

Make the uplink patch script executable:
chmod +x

Then run it:

A window will pop up (user agreement); the next screen will ask where you have installed (or in this case, extracted) uplink. Enter the path of that directory, then click [Begin Install].

The patch will now apply. You'll need to do one more step. Navigate to the directory where uplink is installed, copy uplink.bin.x86 in the root directory of uplink to the lib folder within it. Let's say you installed uplink to /home/pp/uplink. There will be a subfolder /home/pp/uplink/lib that contains an older uplink.bin.x86 file.

Basically you need to overwrite the uplink.x86.bin file in the lib folder of your uplink directory with whatever came with the HIB version (Same file name), or else you will be prompted for a CD code.

Hope that helps anyone who downloaded the Humble Indie Bundle version and is having trouble getting the program to start correctly.

Anonymous comment on 2011-11-22 22:35

It doesn't seem to have been released on their website, but I assure you the version I just downloaded from HIB was 1.6-1. I assume that they're going to release it to everyone else after the hib finishes.

heftig commented on 2011-11-22 22:17

There is no patch available for 1.6.

Anonymous comment on 2011-11-22 21:59

The version released with the new Humble Bundle is 1.6, could you update the package to support it please?

Anonymous comment on 2010-12-06 17:23

I am a robot. This is not an official message. AUR guidelines suggest to not include binaries. Examples:
Feel free to disregard this as you would any other comment. This robot will not post here again.

Anonymous comment on 2010-10-02 17:22

somehow there is actually no file on my uplink cd
the uplink cd came bundled with defcon.
the setup.exe file on the cd installs version 1.54
the cd contains no linux folder or something...
any ideas?

heftig commented on 2010-08-25 18:12


Anonymous comment on 2010-08-25 17:14

the codecard link is not working too, you can use:

heftig commented on 2010-08-25 17:03

Added another URL.

Anonymous comment on 2010-08-25 16:30

Patch is no more on server.

heftig commented on 2010-08-25 15:15

Why was this flagged out-of-date?

heftig commented on 2010-04-21 13:22 is not included.

Anonymous comment on 2010-04-21 10:05

Hello, file is missing. Can you please reupload it? Thank you.

heftig commented on 2010-04-03 21:20

Thanks. Dependencies updated.

Gilrain commented on 2010-04-02 14:27

Thank you for this package.

On my x86-64 system (clean of any lib32* pkgs), I had to install lib32-libxdamage to get rid of this error:
error while loading shared libraries: wrong ELF class: ELFCLASS64