Package Details: upterm 0.4.3-1

Git Clone URL: https://aur.archlinux.org/upterm.git (read-only)
Package Base: upterm
Description: A terminal emulator for the 21st century
Upstream URL: https://github.com/railsware/upterm
Licenses: MIT
Submitter: tensor5
Maintainer: tensor5
Last Packager: tensor5
Votes: 11
Popularity: 0.145035
First Submitted: 2017-05-27 14:11
Last Updated: 2017-09-29 09:29

Latest Comments

sylvr commented on 2018-01-10 16:50

Hi @tensor5, it seems this package does not build because of some npm issues :

npm WARN enzyme@2.9.1 requires a peer of react@0.13.x || 0.14.x || ^15.0.0-0 || 15.x but none is installed. You must install peer dependencies yourself. npm WARN react-addons-test-utils@15.6.0 requires a peer of react-dom@^15.4.2 but none is installed. You must install peer dependencies yourself.

npm ERR! path /home/sylvr/.cache/pacaur/upterm/src/upterm-0.4.3/node_modules/npm/node_modules/dezalgo npm ERR! code ENOENT npm ERR! errno -2 npm ERR! syscall rename npm ERR! enoent ENOENT: no such file or directory, rename '/home/sylvr/.cache/pacaur/upterm/src/upterm-0.4.3/node_modules/npm/node_modules/dezalgo' -> '/home/sylvr/.cache/pacaur/upterm/src/upterm-0.4.3/node_modules/npm/node_modules/.dezalgo.DELETE' npm ERR! enoent This is related to npm not being able to find a file. npm ERR! enoent

tensor5 commented on 2017-10-18 14:50

Hi @cnacode, I see that you are using a binary version of Atom, can try uninstall it and install apm from [community]?

cnacode commented on 2017-10-01 01:28

Hi, thank you tensor5 for maintaining upterm. I can't install it using octopi and yaourt -S. I get an error about "gyp ERR! configure error" in which it warns that python executable "is v3.6.2, which is not supported by gyp." and more... here's the complete log https://pastebin.com/29pd0GtC
thanks

sistematico commented on 2017-09-23 03:41

http://ix.io/A76 updated PKGBUILD

tensor5 commented on 2017-08-31 10:34

@macjabeth, let me know if the PTY error persists after upgrade.

tensor5 commented on 2017-08-13 16:41

I will update upterm and take care of the PTY.ts issue as soon as I finish updating electron in [community].

macjabeth commented on 2017-07-25 01:54

I got the following error during installation:

$ tsc
src/PTY.ts(81,25): error TS2345: Argument of type 'Buffer' is not assignable to parameter of type 'string | PromiseLike<string> | undefined'.
Type 'Buffer' is not assignable to type 'PromiseLike<string>'.
Property 'then' is missing in type 'Buffer'.
src/views/PromptComponent.tsx(83,17): error TS2339: Property 'type' does not exist on type 'DetailedHTMLProps<HTMLAttributes<HTMLDivElement>, HTMLDivElement>'.
error Command failed with exit code 1.

tensor5 commented on 2017-07-07 13:03

@agostonbarna, try now.

agostonbarna commented on 2017-07-05 22:10

I get the following error during installation:
src/plugins/autocompletion_providers/Git.ts(526,57): error TS7024: Function implicitly has return type 'any' because it does not have a return type annotation and is referenced directly or indirectly in one of its return expressions.
src/views/css/main.ts(522,9): error TS2322: Type '{ fontFamily: string; contain?: "strict" | "paint" | undefined; pointerEvents?: string | undefine...' is not assignable to type 'CSSObject'.
Object literal may only specify known properties, and 'fontFamily' does not exist in type 'CSSObject'.
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build upterm package(s)

tensor5 commented on 2017-05-27 14:15

Uninstall black-screen and install upterm.

All comments