Package Details: upwork 5.4.2.2-1

Git Clone URL: https://aur.archlinux.org/upwork.git (read-only, click to copy)
Package Base: upwork
Description: Desktop Application
Upstream URL: https://www.upwork.com/downloads/
Keywords: freelance job prod stable standard upwork
Licenses: custom
Conflicts: upwork-alpha
Submitter: lybin
Maintainer: lybin (msheremet)
Last Packager: msheremet
Votes: 59
Popularity: 1.49
First Submitted: 2015-05-05 17:51
Last Updated: 2020-06-17 23:17

Pinned Comments

msheremet commented on 2018-02-09 15:34

Please run following command before reporting out-of-date issues. And ALWAYS include this command output in such reports.

Command to check new version. Run this command in terminal as regular user: grep "_getVersionToDownload" ~/.Upwork/Upwork/Logs/upwork.2*.log | tail -n 1

This AUR package follows upstream Prod version.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

groonya commented on 2017-04-03 05:53

curl: (60) SSL certificate problem: certificate has expired

...

ERROR: Failure while downloading https://dl.devtrue.net/archlinux/upwork/LICENSE
Aborting...

cortopy commented on 2017-03-29 09:29

Wayland doesn't allow most of applications to take screenshots. It's a security feature and 99.9% of applications that take screenshots are not compatible. You have to use x

ondrejku commented on 2017-03-28 00:04

I'm on Wayland & Gnome and it doesn't take screenshots

9grPPT3yBewMM635 commented on 2017-03-16 04:28

This package is working massively slow for me. The windows freeze all the time, When I run it it takes like 5 minutes for all the windows to show up. And sometimes the application doesn't start at all. I've been looking for threads about this but found nothing.

Any suggestions?

I'm using i3wm in case that's relevant.

lybin commented on 2016-11-16 20:35

fixed

TrueBers commented on 2016-11-15 21:55

LICENSE is not found

PiroXiline commented on 2016-09-14 11:47

@lybin

I have the same issue as marsoft, and groonya.

And marsoft commented on 2016-07-14 21:28 still helps.

marsoft commented on 2016-08-10 01:49

For me, with current version (4.1.347.0-1) I still get that error when trying to start without these libraries symlinked:

$ upwork
[0810/044749:ERROR:browser_main_loop.cc(173)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[0810/044749:ERROR:renderer_main.cc(200)] Running without renderer sandbox
[0810/044749:ERROR:renderer_main.cc(200)] Running without renderer sandbox
[0810/044749:WARNING:channel.cc(549)] Failed to send message to ack remove remote endpoint (local ID 1, remote ID 1)
[0810/044749:WARNING:channel.cc(549)] Failed to send message to ack remove remote endpoint (local ID 2147483648, remote ID 2)
[0810/044749:ERROR:channel.cc(300)] RawChannel read error (connection broken)
[0810/044749:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044750:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044751:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044751:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044751:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044752:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR
[0810/044752:WARNING:nss_ssl_util.cc(370)] Unknown SSL error -12218 (SSL_ERROR_ENCRYPTION_FAILURE) mapped to net::ERR_SSL_PROTOCOL_ERROR

Everything starts to work fine when I add symlinks to -upwork versions of libnss3.so and libsoftokn3.so
I think it is worth re-adding this solution into pkgbuild.

lybin commented on 2016-07-15 12:50

@marsoft, I made same solution in prev version: https://aur.archlinux.org/cgit/aur.git/commit/?h=upwork&id=6356fe58a96835a74cf461ad01e69f2257d5f18a

But I've deleted this with 4.1.321 version, because problem is solved for me.

groonya commented on 2016-07-15 05:39

@marsoft Great solution, thanks!