Package Details: util-linux-libs-selinux 2.40-1

Git Clone URL: https://aur.archlinux.org/util-linux-selinux.git (read-only, click to copy)
Package Base: util-linux-selinux
Description: util-linux-selinux runtime libraries
Upstream URL: https://github.com/util-linux/util-linux
Keywords: selinux
Licenses: ISC, BSD-3-Clause, BSD-2-Clause, GPL-3.0-or-later, GPL-2.0-only, GPL-2.0-or-later, LGPL-2.1-or-later, BSD-4-Clause-UC, LicenseRef-PublicDomain
Groups: selinux
Conflicts: libutil-linux-selinux, util-linux-libs
Provides: libblkid.so, libfdisk.so, libmount.so, libsmartcols.so, libutil-linux, libutil-linux-selinux, libuuid.so, util-linux-libs
Replaces: libutil-linux-selinux
Submitter: Siosm
Maintainer: IooNag
Last Packager: IooNag
Votes: 17
Popularity: 0.118023
First Submitted: 2014-01-02 21:33 (UTC)
Last Updated: 2024-04-01 17:38 (UTC)

Dependencies (14)

Required by (321)

Sources (11)

Latest Comments

1 2 3 Next › Last »

B3l3tte commented on 2024-03-29 20:56 (UTC) (edited on 2024-03-29 20:58 (UTC) by B3l3tte)

Hello, for now I downgraded this packages :

at-spi2-core 2.50.2-1
glib2 2.78.4-1
glib-networking 1:2.78.1-1
gobject-introspection-runtime 1.78.1-1
gsettings-desktop-schemas 45.0-1
libgirepository 1.78.1-1
tracker3 3.6.0-3

cf. https://www.reddit.com/r/archlinux/comments/1bm63jj/comment/kw9ly4x/

Plus some personal debugging and tests. If it can help someone out there ... Peace !

MacroNerd commented on 2024-03-28 22:01 (UTC)

IooNag: Ah i had misunderstood some of the versioning as I was under the impression it was on 2.40-2. I can't guarantee I'll be super helpful but if there's any documentation on how to apply the patches and all that, I'd be happy to take a shot at it this weekend. It'd at least give me a chance to bring my system back up.

IooNag commented on 2024-03-28 21:29 (UTC)

MacroNerd: the official package has only been updated to 2.40-1 yesterday (https://gitlab.archlinux.org/archlinux/packaging/packages/util-linux/-/commits/38076a16943cca34e028ebcb58a8dd3936e9b87c ) and as I do not have access to my test systems for now (due to Easter week-end), I will update the package next week. I understand this lag is currently breaking system updates (and this has also been reported in https://github.com/archlinuxhardened/selinux/issues/121). If someone gives it a try by updating the package and submitting a GitHub Pull Request there, I will probably be able to merge it (and release the update) on Monday, being more confident that it works properly :)

MacroNerd commented on 2024-03-26 15:44 (UTC)

This has already been flagged out of date, but is there a time frame we can expect to see the new version? The recent upgrades in the main repos broke my system and repairing it will take a while, but an update to this package would probably fix it. Not to add any pressure, just curious.

yar commented on 2023-05-18 21:56 (UTC)

The package functions still hard-code paths to python 3.10. Please update to 3.11 or, ideally, test for the python version first.

Siosm commented on 2014-01-02 21:44 (UTC)

Renamed to util-linux-selinux

Nicky726 commented on 2013-02-11 21:05 (UTC)

OK, you can uninstall that and install procps-ng from [core]. procps has been obsoleted, I should have it removed. I do not have selinux-procps-ng yet.

xangelux commented on 2013-02-11 20:40 (UTC)

Now I know, it's provided by selinux-procps

Nicky726 commented on 2013-02-11 20:38 (UTC)

What does pacman -Qo /bin/kill give you?

xangelux commented on 2013-02-11 20:29 (UTC)

Still fails, complains files already exist /bin/kill and /usr/share/man/man1/kill.1.gz should those be on the backup array?