Package Details: utopia-documents3 3.1.0-1

Git Clone URL: https://aur.archlinux.org/utopia-documents3.git (read-only)
Package Base: utopia-documents3
Description: PDF reader that displays interactive annotations on scientific articles
Upstream URL: http://utopiadocs.com
Licenses: GPL
Conflicts: utopia-documents
Provides: utopia-documents3
Submitter: rvasilev
Maintainer: rvasilev (Snow)
Last Packager: rvasilev
Votes: 1
Popularity: 0.000165
First Submitted: 2017-02-10 11:38
Last Updated: 2017-09-30 06:35

Latest Comments

1 2 Next › Last »

ndandanov commented on 2018-10-02 13:20

@xulongwu4, @rvasilev, I also encountered a build problem. I assume that it is related to python 3 being the default so I forced the usage of python 2 for the compilation process by linking /usr/bin/python to /usr/bin/python2.7. However, I still cannot build the project. Here is the installation output: https://pastebin.com/ApeQ4zPq Thanks!

xulongwu4 commented on 2018-04-15 18:16

@GhostRun

As you can see from the error message, the utopia-documents's source code is written based on python 2. In arch linux the default python is python 3, and that causes the error in compilation. I think you need to force the usage of python 2 in your compilation process.

xulongwu4 commented on 2018-04-15 18:11

@rvasilev

At line 59 of your PKGBUILD file, the CMakeConfig folder is not in ${srcdir} but in ${srcdir}/utopia-documents-3.1.0. Or you can just use ../CMakeConfig/configurations/common.txt and ../CMakeConfig/configurations/Linux.txt. That causes the error you see during the build process.

Let us know if you have any errors in the compilation process once you fix it.

GhostRun commented on 2018-04-05 14:07

https://pastebin.com/AQQ3j1pJ this is the complete output of installation, error in build..

rvasilev commented on 2018-04-02 20:38

CMakeError https://pastebin.com/qh3XKdwR

CMakeOutput https://pastebin.com/gZrr6Gum

Strange. Now it fails with other build error..

Yes, it's the latest source.

Ok. Dependencies stage (cmake -CCMakeConfig/configurations/common.txt -CCMakeConfig/configurations/Linux.txt .) ends without errors.

Build stage (cmake -C${srcdir}/CMakeConfig/configurations/common.txt -C${srcdir}/CMakeConfig/configurations/Linux.txt ..) drops a error https://pastebin.com/qh3XKdwR

Current PKGBUILD - https://gist.github.com/rvasilev/9e53b1fea7674ecfb44cb692b3b82634

xulongwu4 commented on 2018-03-25 19:24

Your error message looks a bit weird since the GlobalParams.h file comes with utopia-documents and it has the specified method in the error message. Did you use the latest source file from here: http://utopiadocs.com/files/utopia-documents-3.1.0.tgz? Did you try applying the patches (what's important is 0001-qt-version.patch and 0002-use-system-poppler-api.patch) on the solus website and following the building procedure there (see the package.yml file)? Can you give some more info on how you build it? It would be better if you can attach the output for each step of your building process (cmake in the dependencies folder, cmake in the main folder, make in the main folder, ...).

rvasilev commented on 2018-03-23 19:08

xulongwu4 patch applied, but

Does not build because of http://dpaste.com/3H9K263

poppler 0.61.1

xulongwu4 commented on 2018-03-23 16:41

The poppler api used by utopia-documents is not compatible with the new version of poppler. A patch is needed for compiling libcrackle. You can find the patch here: https://dev.solus-project.com/file/data/hwptvvkyi4epknik75ec/PHID-FILE-dgjtvbevvdfi5qyxnizm/files_0002-use-system-poppler-api.patch

This is the solus patch for building utopia-documents: https://dev.solus-project.com/D2587

krishnakumar commented on 2018-03-19 12:36

This package does not build. The problem occurs when building libcrackle

rvasilev commented on 2017-10-01 17:00

For me the source of 3.1 is not building for some reason and I'm trying to figure it out. I'm stuck @ libcrackle (make crackle). May be that's the problem with upstream.

The same looking list of errors with build of 3.0.2.