Package Details: v2ray-desktop 2.3.1-1

Git Clone URL: https://aur.archlinux.org/v2ray-desktop.git (read-only, click to copy)
Package Base: v2ray-desktop
Description: A cross-platform GUI proxy client that supports Shadowsocks(R), V2Ray, and Trojan protocols (Stable Release)
Upstream URL: https://github.com/Dr-Incognito/V2Ray-Desktop
Keywords: clash shadowsocks shadowsocks-gui trojan trojan-gui v2ray v2ray-desktop v2ray-gui
Licenses: GPL3
Provides: v2ray-desktop
Submitter: Dr-Incognito
Maintainer: Dr-Incognito
Last Packager: Dr-Incognito
Votes: 7
Popularity: 0.002412
First Submitted: 2020-02-17 11:52 (UTC)
Last Updated: 2022-02-05 02:23 (UTC)

Latest Comments

1 2 Next › Last »

navidmafi commented on 2022-12-08 20:45 (UTC)

@mablue I will report this on upstream, this is a problem with ipinfo.io

mablue commented on 2022-11-11 17:45 (UTC) (edited on 2022-11-11 17:48 (UTC) by mablue)

I'm from iran and have conection problems with world internet

[mab@mab ~]$ yay -S v2ray-desktop
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo:1]  clash-1.11.8-1
[Repo Make:3]  oniguruma-6.9.8-1  jq-1.6-4  qt5-tools-5.15.7+kde+r1-1
[Aur:1]  v2ray-desktop-2.3.1-1

==> Remove make dependencies after install? [y/N] 
:: (1/1) Downloaded PKGBUILD: v2ray-desktop
  1 v2ray-desktop                            (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/1) Parsing SRCINFO: v2ray-desktop
[sudo] password for mab: 
resolving dependencies...
looking for conflicting packages...

Packages (4) clash-1.11.8-1  jq-1.6-4  oniguruma-6.9.8-1
             qt5-tools-5.15.7+kde+r1-1

Total Download Size:    8.86 MiB
Total Installed Size:  26.85 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 qt5-tools-5.15.7...     5.3 MiB   531 KiB/s 00:10 [######################] 100%
 clash-1.11.8-1-x...     3.1 MiB   277 KiB/s 00:11 [######################] 100%
 jq-1.6-4-x86_64       226.4 KiB  96.1 KiB/s 00:02 [######################] 100%
 oniguruma-6.9.8-...   216.9 KiB  81.0 KiB/s 00:03 [######################] 100%
 Total (4/4)             8.9 MiB   313 KiB/s 00:29 [######################] 100%
error: failed retrieving file 'qt5-tools-5.15.7+kde+r1-1-x86_64.pkg.tar.zst' from mirror.rasanegar.com : SSL certificate problem: self signed certificate
error: failed retrieving file 'clash-1.11.8-1-x86_64.pkg.tar.zst' from mirror.rasanegar.com : SSL certificate problem: self signed certificate
error: failed retrieving file 'jq-1.6-4-x86_64.pkg.tar.zst' from mirror.rasanegar.com : SSL certificate problem: self signed certificate
warning: too many errors from mirror.rasanegar.com, skipping for the remainder of this transaction
(4/4) checking keys in keyring                     [######################] 100%
(4/4) checking package integrity                   [######################] 100%
(4/4) loading package files                        [######################] 100%
(4/4) checking for file conflicts                  [######################] 100%
(4/4) checking available disk space                [######################] 100%
:: Processing package changes...
(1/4) installing clash                             [######################] 100%
(2/4) installing oniguruma                         [######################] 100%
(3/4) installing jq                                [######################] 100%
(4/4) installing qt5-tools                         [######################] 100%
Optional dependencies for qt5-tools
    clang: for qdoc [installed]
    qt5-webkit: for Qt Assistant
:: Running post-transaction hooks...
(1/4) Reloading system manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating icon theme caches...
(4/4) Updating the desktop file MIME type cache...
==> Making package: v2ray-desktop 2.3.1-1 (Fri Nov 11 21:09:54 2022)
==> Retrieving sources...
  -> Cloning V2Ray-Desktop git repo...
Cloning into bare repository '/home/mab/.cache/yay/v2ray-desktop/V2Ray-Desktop'...
remote: Enumerating objects: 1760, done.
remote: Counting objects: 100% (206/206), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 1760 (delta 202), reused 201 (delta 201), pack-reused 1554
Receiving objects: 100% (1760/1760), 543.30 KiB | 270.00 KiB/s, done.
Resolving deltas: 100% (1216/1216), done.
==> Validating source files with sha512sums...
    V2Ray-Desktop ... Skipped
 -> clash>=1.5.0 not satisfied, flushing install queue
==> Making package: v2ray-desktop 2.3.1-1 (Fri Nov 11 21:09:59 2022)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating V2Ray-Desktop git repo...
==> Validating source files with sha512sums...
    V2Ray-Desktop ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of V2Ray-Desktop git repo...
Cloning into 'V2Ray-Desktop'...
done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
Detecting your country ... Please wait ...
parse error: Invalid numeric literal at line 3, column 0
==> ERROR: A failure occurred in prepare().
    Aborting...
 -> error making: v2ray-desktop

lonble commented on 2022-03-01 11:04 (UTC)

既然以Clash为后端,为什么不叫clash-desktop

oldoldstone commented on 2020-04-17 16:19 (UTC) (edited on 2020-04-20 13:05 (UTC) by oldoldstone)

请添加依赖:qqc2-desktop-style,否则界面无反应,需root用户才能运行. 4-20更新:貌似不是这个问题,更新后界面又没有反应了,我还是等等用命令行吧。

Dr-Incognito commented on 2020-04-03 06:10 (UTC)

@yangtsesu

It is used for parsing JSON strings. This dependency has been added to PKGBUILD. Sorry for the inconvenience.

yangtsesu commented on 2020-04-03 03:00 (UTC) (edited on 2020-04-03 03:01 (UTC) by yangtsesu)

jq???

ZhangHua commented on 2020-03-05 05:12 (UTC)

@Dr-Incognito 好的,已经添加新的issue到github。

Dr-Incognito commented on 2020-03-04 02:25 (UTC)

@ZhangHua

我无法复现您的问题。请提供您的桌面环境,以及pacman -Qs qt5的输出。 麻烦您在GitHub的Repo开一个新的Issue来协助Debug一下这个问题。

GitHub Repo: https://github.com/Dr-Incognito/V2Ray-Desktop

ZhangHua commented on 2020-03-03 09:19 (UTC)

请问一下为什么这个程序不能以普通用户的身份执行?它只有root权限执行的时候才正常,如果以普通用户身份执行,就不能打开设置和服务器列表,并且也不能正常代理,只有执行 sudo /opt/v2ray-desktop/v2ray-desktop 时才能正常使用。

Dr-Incognito commented on 2020-02-26 13:50 (UTC)

@FranklinYu

这仅仅是一种不同习惯而已。 没有说源码编译的程序一定要放在哪儿,不然为什么还要有prefix这个option。 放/opt的原因是程序需要加载外部的语言文件,目前语言文件没有被集成到可执行文件中去。