Package Details: v2ray-git 5.1.0.r17.ga4a3f4dee-1

Git Clone URL: https://aur.archlinux.org/v2ray-git.git (read-only, click to copy)
Package Base: v2ray-git
Description: A set of network tools that helps you to build your own computer network (git version).
Upstream URL: https://github.com/v2fly/v2ray-core
Licenses: MIT
Conflicts: v2ray
Provides: v2ray
Submitter: dctxmei
Maintainer: m8D2
Last Packager: m8D2
Votes: 2
Popularity: 0.000122
First Submitted: 2018-05-26 01:06 (UTC)
Last Updated: 2022-10-07 23:36 (UTC)

Required by (15)

Sources (1)

Latest Comments

m8D2 commented on 2022-10-07 23:37 (UTC)

Updated, thanks for the suggestion!

cubercsl commented on 2022-09-21 06:30 (UTC)

Please use provides=("v2ray=${pkgver%%.r*}") because some packages related to v2ray may depend on a specific version of v2ray (>=5 or < 5).

m8D2 commented on 2020-09-25 01:47 (UTC) (edited on 2020-09-25 01:47 (UTC) by m8D2)

Updated as the source URL has been moved to: https://github.com/v2ray/v2ray-core

See announcement: https://github.com/v2ray/v2ray-core.

Also bumped to v4.28.x, please note that in v4.27 there was a breaking change:

Breaking Change

VMessAEAD has been updated and needs both client and server to be the same version for it to work.

See details: https://github.com/v2ray/v2ray-core/releases

Because of this breaking change, if your Arch is the "server" and if your "client" hasn't been updated to v4.27 or above, you can temporarily uninstall this git version and install v4.26 on your server from the Arch repo: sudo pacman -U https://archive.archlinux.org/packages/v/v2ray/v2ray-4.26.0-1-x86_64.pkg.tar.zst