Package Details: v2raya 2.2.5.6-1

Git Clone URL: https://aur.archlinux.org/v2raya.git (read-only, click to copy)
Package Base: v2raya
Description: A web GUI client of Project V which supports VMess, VLESS, SS, SSR, Trojan, Tuic and Juicity protocols
Upstream URL: https://github.com/v2rayA/v2rayA
Keywords: pingtunnel shadowsocks ss ssr trojan v2ray
Licenses: AGPL3
Submitter: mzz2017
Maintainer: mzz2017
Last Packager: mzz2017
Votes: 22
Popularity: 0.48
First Submitted: 2019-11-21 15:57 (UTC)
Last Updated: 2024-06-21 12:17 (UTC)

Latest Comments

1 2 3 Next › Last »

yutsing commented on 2024-06-19 07:53 (UTC) (edited on 2024-06-19 07:54 (UTC) by yutsing)

(node:114767) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
[1/4] Resolving packages...
[2/4] Fetching packages...
error @achrinza/node-ipc@10.1.10: The engine "node" is incompatible with this module. Expected version "14 || 16 || 17 || 18 || 19 || 20 || 21". Got "22.3.0"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
==> ERROR: A failure occurred in build().

m-freeman commented on 2024-06-06 23:26 (UTC) (edited on 2024-06-06 23:32 (UTC) by m-freeman)

==> Starting build()...
yarn install v1.22.22
(node:39073) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
[1/4] Resolving packages...
[2/4] Fetching packages...
error @achrinza/node-ipc@10.1.10: The engine "node" is incompatible with this module. Expected version "14 || 16 || 17 || 18 || 19 || 20 || 21". Got "22.2.0"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: v2raya-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
v2raya - exit status 4

wustdsh commented on 2024-05-18 09:06 (UTC)

[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
warning " > terser-webpack-plugin@5.3.6" has unmet peer dependency "webpack@^5.1.0".
warning " > @vue/eslint-config-prettier@5.1.0" has incorrect peer dependency "eslint-plugin-prettier@^3.1.0".
warning " > compression-webpack-plugin@10.0.0" has unmet peer dependency "webpack@^5.1.0".
warning " > css-loader@5.2.7" has unmet peer dependency "webpack@^4.27.0 || ^5.0.0".
warning " > sass-loader@8.0.2" has unmet peer dependency "webpack@^4.36.0 || ^5.0.0".
[4/4] Building fresh packages...
[1/2] ⠂ core-js
error /tmp/makepkg/v2raya/src/v2rayA-2.2.5.1/gui/node_modules/core-js: Command failed.
Exit code: 126
Command: node -e "try{require('./postinstall')}catch(e){}"
Arguments: 
Directory: /tmp/makepkg/v2raya/src/v2rayA-2.2.5.1/gui/node_modules/core-js
Output:
/bin/sh: /tmp/yarn--1716022990915-0.20350748018490727/node: /bin/sh: 错误的解释器: 文本文件忙

为啥会有这个错误

yutsing commented on 2023-11-22 12:51 (UTC)

error @achrinza/event-pubsub@5.0.9: The engine "node" is incompatible with this module. Expected version "13 || 14 || 16 || 17 || 18 || 19 || 20". Got "21.2.0" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

curled commented on 2023-11-13 02:04 (UTC)

core/specialMode/infra/handle.go:11:2: zip: not a valid zip file pkg/util/proxyWithHttp/proxyWithHttp.go:8:2: zip: not a valid zip file ==> ERROR: A failure occurred in build(). Aborting... -> error making: v2raya-exit status 4 -> Failed to install the following packages. Manual intervention is required: v2raya - exit status 4

airgap97 commented on 2023-11-09 05:37 (UTC)

error @achrinza/node-ipc@10.1.9: The engine "node" is incompatible with this module. Expected version "14 || 16 || 17 || 18 || 19 || 20". Got "21.1.0"
error Found incompatible module.

FishBoneEK commented on 2023-09-09 14:22 (UTC)

Met some issues trying installation: * Some comments report v2raya doesn't support nodejs 20 * The required v2ray-domain-list-community version as install dependency is older than the pkg version in extra repo, mirrors returned 404 because of it My work arounds: * Install nvm and nodejs 19 via nvm, then use --assume-installed to install yarn (build dependency) * Use --assume-installed to install v2raya, v2raya will fetch domain list itself later

<deleted-account> commented on 2023-07-25 23:22 (UTC)

Incompatible with nodejs 20.

error @achrinza/node-ipc@9.2.6: The engine "node" is incompatible with this module. Expected version "8 || 9 || 10 || 11 || 12 || 13 || 14 || 15 || 16 || 17 || 18 || 19". Got "20.4.0"
error Found incompatible module.

xihale commented on 2023-07-14 08:53 (UTC)

Please add the 'nodejs<=19' to prevent the nodejs version bugs