Package Details: v8-3.15 3.15.11-1

Git Clone URL: https://aur.archlinux.org/v8-3.15.git (read-only)
Package Base: v8-3.15
Description: A fast and modern javascript engine (old 3.15 version required for ethereum)
Upstream URL: http://code.google.com/p/v8
Licenses: BSD
Conflicts: v8
Provides: v8
Submitter: spiff
Maintainer: spiff
Last Packager: spiff
Votes: 6
Popularity: 0.802705
First Submitted: 2015-09-14 01:13
Last Updated: 2015-09-14 01:14

Latest Comments

EvilAlan42 commented on 2016-05-23 04:28

Thank you Abogical!

Abogical commented on 2016-05-19 20:25

I got it working now via a workaround, After removing the line 'make dependencies', add 'snapshot=off' argument to the makefile. v8 startup may be a bit slower, but unfortunately I have no other option. @arturodz, if you have fixed it in another way than please let me know.

Abogical commented on 2016-05-19 17:06

Weirdly, it compiles fine and everything works when it is compiled for debugging (by running [make x64.debug]), mksnapshot works fine. but not when it is run for release (by running [make x64.release]) where mknapshot segfaults.

Abogical commented on 2016-05-18 20:28

It works if you removed that line, as gyp is already bundled in that tarball, and it compiles ok, but then it runs 'mksnapshot' only to segfault. I'm not sure what mksnaphot even does. Problem persists even if you download the latest gyp version from git, and even if you download v8 git version 3.15.11.18.

arturodz commented on 2016-05-18 15:04

@Abogical I tried that from the package manager, but it didn't work. I'll try again this evening compiling manually.

Abogical commented on 2016-05-18 14:59

The line 'make dependencies' is the culprit. It tries to checkout the gyp subversion repository. That repository has been dropped. gyp needs to be downloaded manually via git for this package to work.

arturodz commented on 2016-05-17 15:08

The SVN repos for this google project have moved to a git repo

Abogical commented on 2016-05-17 13:45

I'm also getting the same error as @arturodz, apparently this problem exists on all v8 aur packages.

arturodz commented on 2016-05-16 02:10

I had a problem installing this package. The problem seems to be gyp as it is unable to download the repo:

==> Starting build()...
svn checkout --force http://gyp.googlecode.com/svn/trunk build/gyp \
--revision 1501
svn: E170013: Unable to connect to a repository at URL 'http://gyp.googlecode.com/svn/trunk'
svn: E160013: '/svn/trunk' path not found
Makefile:289: recipe for target 'dependencies' failed
make: *** [dependencies] Error 1