Package Details: vagrant-git

Git Clone URL: (read-only, click to copy)
Package Base: vagrant-git
Description: Build and distribute virtualized development environments
Upstream URL:
Licenses: MIT
Conflicts: vagrant, vagrant-substrate, vagrant-substrate-git
Provides: vagrant
Replaces: vagrant-substrate, vagrant-substrate-git
Submitter: gtmanfred
Maintainer: architect0
Last Packager: architect0
Votes: 6
Popularity: 0.000000
First Submitted: 2013-09-03 20:50
Last Updated: 2020-01-23 01:03

Required by (9)

Sources (2)

Latest Comments

1 2 3 Next › Last »

rageltman commented on 2021-01-15 01:25

Needs ruby-net-ssh along with SCP gem:

[2021-01-14T21:18:59.193Z] ==> Starting package()...
[2021-01-14T21:18:59.193Z] ERROR:  While executing gem ... (Gem::DependencyError)
[2021-01-14T21:18:59.193Z]     Unresolved dependency found during sorting - net-ssh (>= 2.6.5) (requested by net-scp-1.2.1)
[2021-01-14T21:18:59.193Z] ==> ERROR: A failure occurred in package().
[2021-01-14T21:18:59.193Z]     Aborting...
script returned exit code 255

yenlegion commented on 2020-11-12 11:02

Same, the main package at is out of date as well. Several versions behind. The Vagrant website specifically mentions not to use a repo, is this package okay to use, once fixed?

magickreeator commented on 2020-11-10 07:36

I'm having a problem

    ERROR:  While executing gem ... (Gem::DependencyError)
    Unresolved dependency found during sorting - net-ssh (>= 2.6.5) (requested by net-scp-1.2.1)
==> ОШИБКА: Произошел сбой в package().
ошибка сборки: vagrant-git

How can I fix this?

wizonesolutions commented on 2020-01-23 20:35

After building with RVM and version 2.6.3:

$ vagrant                                                                                                                                         
Failed to read Vagrant manifest file at /opt/vagrant/embedded/manifest.json: open /opt/vagrant/embedded/manifest.json: no such file or directory

Did I miss something?

Twiki commented on 2019-04-23 16:11

The repo has moved to here : EDIT: Forgot the second : Mitchell's company. EDIT 2: And there is a message here : "Don't use this anymore! Use the official library at:"

jsteel commented on 2017-11-02 11:44

Upstream have made some changes that means we can ditch the substrate layer and use system binaries/libraries. Please test and let me know of any issues.

zerathidune commented on 2017-10-28 19:31

There seems to be a missing dependency on libyaml. Without libyaml installed I get the following error:

==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning vagrant git repo...
Cloning into bare repository '/home/isd/scratch/vagrant-git/vagrant'...
remote: Counting objects: 103007, done.
remote: Compressing objects: 100% (152/152), done.
remote: Total 103007 (delta 88), reused 17 (delta 5), pack-reused 102850
Receiving objects: 100% (103007/103007), 23.68 MiB | 1.39 MiB/s, done.
Resolving deltas: 100% (64572/64572), done.
==> Validating source files with md5sums...
vagrant ... Skipped
==> Extracting sources...
-> Creating working copy of vagrant git repo...
Cloning into 'vagrant'...
==> Starting pkgver()...
==> Updated version: vagrant-git
==> Starting build()...
/opt/vagrant/embedded/lib/ruby/2.3.0/yaml.rb:5:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
/opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot open shared object file: No such file or directory - /opt/vagrant/embedded/lib/ruby/2.3.0/x86_64-linux/ (LoadError)
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /opt/vagrant/embedded/lib/ruby/2.3.0/psych.rb:7:in `<top (required)>'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /opt/vagrant/embedded/lib/ruby/2.3.0/yaml.rb:6:in `<top (required)>'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems.rb:628:in `load_yaml'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/config_file.rb:327:in `load_file'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/config_file.rb:198:in `initialize'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/gem_runner.rb:75:in `new'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/gem_runner.rb:75:in `do_configuration'
from /opt/vagrant/embedded/lib/ruby/2.3.0/rubygems/gem_runner.rb:40:in `run'
from /opt/vagrant/embedded/bin/gem:25:in `<main>'
==> ERROR: A failure occurred in build().

jsteel commented on 2017-06-13 11:47

That should have been installed as a dep though, so I was a bit confused. Did you make changes to the PKGBUILD?

dmp1ce commented on 2017-06-13 11:38

jsteel: Yes, thank you. It was vagrant-substrate.

jsteel commented on 2017-06-13 11:32

Have you got vagrant-substrate installed?