Package Details: vala-git 0.50.1+96+gffd19b25b-1

Git Clone URL: https://aur.archlinux.org/vala-git.git (read-only, click to copy)
Package Base: vala-git
Description: Compiler for the GObject type system
Upstream URL: https://wiki.gnome.org/Projects/Vala
Keywords: compiler gobject programming
Licenses: LGPL
Conflicts: vala, valadoc
Provides: vala, valadoc
Replaces: vala, valadoc
Submitter: None
Maintainer: swiftscythe
Last Packager: swiftscythe
Votes: 84
Popularity: 0.000002
First Submitted: 2009-10-23 08:57
Last Updated: 2020-12-23 08:33

Required by (688)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

chenxiaolong commented on 2012-05-01 18:46

@buergi: Thanks! I changed it so that vala-git provides vala 0.18.0.

buergi commented on 2012-05-01 16:44

Could we revert the provides line to vala or vala=0.18.0 which would be correct?
If there is an issue with cairo-compmgr which than it should be fixed there not here.
I got both compiled just fine by changing to vala=0.18.0 in vala-git and cairo-compmgr-git and replacing the version in sed commands in cairo-compmgr-git's PKGCONFIG from 16 to 18.
With the current vala-git cairo-compmgr just doesn't compile since it doesn't provide libvala-0.14.so (resp 16 in current versions) even if it pretends to do so.

donniezazen commented on 2012-04-20 00:47

I built it this morning, it worked just fine except you have to install vala for first time as comment below says.

chenxiaolong commented on 2012-04-19 23:47

I received an email that Diego posted a comment that said "broken". Could you explain how it's broken (and provide build logs, etc)?

By the way, the out-of-date button is only for notifying maintainers that there's a new upstream button. Please do not click it when the build fails. I respond to all comments.

Diego commented on 2012-04-19 21:46

broken

chenxiaolong commented on 2012-04-04 03:50

@donniezazen: Just install the regular vala. It's only needed the first time you install vala-git :)

donniezazen commented on 2012-04-03 16:58

./autogen.sh: line 10: valac: command not found
**Error**: You must have valac >= 0.12.0 installed
to build vala. Download the appropriate package
from your distribution or get the source tarball at
http://download.gnome.org/sources/vala/
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build vala-git.

chenxiaolong commented on 2012-02-17 03:13

I'm taking over this package since no one wants to maintain it anymore. I've fixed the provides line so that it provides the latest version of vala in the extra repository :)

Anonymous comment on 2012-02-05 12:02

please fix vala provides\makedepen issue

kite commented on 2012-02-04 18:27

flex is missed in dependencies