Package Details: valama-git r940.a7539fa-1

Git Clone URL: https://aur.archlinux.org/valama-git.git (read-only)
Package Base: valama-git
Description: Next generation Vala IDE
Upstream URL: https://github.com/Valama/valama
Licenses: GPL3
Submitter: gothmog.todi
Maintainer: fusion809
Last Packager: fusion809
Votes: 7
Popularity: 0.719109
First Submitted: 2013-06-08 10:33
Last Updated: 2016-11-02 08:57

Latest Comments

volmok commented on 2017-02-07 20:47

After spending some time trying to build with the current version of vala it seems that this IDE will be stuck at 0.26 (the errors are not simple surface errors as reported by some Ubuntu folks).

Thanks for the quick reply!

fusion809 commented on 2017-02-07 19:48

Nope. I have asked the upstream developers and 0.26.x is the latest version of Vala that Valama can be built against and use.

volmok commented on 2017-02-07 19:43

The official vala is 0.34 and is in conflict with vala0.26 (AUR)

Any way to use the Extra\vala package for valama?

Serra commented on 2016-11-02 08:51

@fusion809 sorry for orphaning this package so late. Thank you for adopting it.

fusion809 commented on 2016-10-17 16:42

@Serra to fix @Fafa123's build error please change the vala dependency to vala0.26. Vala 0.26 is the latest Vala version that Valama can be successfully built against. If you're too busy to maintain this package anymore I'd be happy to assume responsibility for it.

Fafa123 commented on 2016-06-10 20:51

Can someone help me?

I get a /aur-valama-git/src/valama-git/guanako/scanner/valaparser.vala:597.5-597.36: error: Assignment: Cannot convert from `int' to `Vala.Expression?'


Is this related to valama simply being outdated or does this has another reason? If it is because of being outdated is there another proper IDE?

bb010g commented on 2015-10-09 15:03

Due to CMakeLists.txt.patch being removed, the md5sums array needs to be updated.

jcjordyn120 commented on 2015-10-02 00:32

Serra, glade is not a optional dependense
valama will not compile with out it

gothmog.todi commented on 2014-11-29 09:34

I don't use this package anymore, therefore I disowned it. You can adopt it if you want

TheAifam5 commented on 2014-11-19 07:56

I cannot compilling this:

-- checking for module 'webkit2gtk-3.0'
-- package 'webkit2gtk-3.0' not found
CMake Error at /usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:341 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.0/Modules/FindPkgConfig.cmake:395 (_pkg_check_modules_internal)
cmake/vala/ValaPkgs.cmake:101 (pkg_check_modules)
CMakeLists.txt:184 (vala_pkgs)



I have installed webkitgtk and webkit2gtk -.-

All comments