Package Details: validatornu 22.9.29-1

Git Clone URL: https://aur.archlinux.org/validatornu.git (read-only, click to copy)
Package Base: validatornu
Description: The Nu Html Checker, a command line tool for HTML5 markup validation
Upstream URL: https://validator.github.io/validator/
Licenses: BSD, MPL, MIT, Apache, CDDL, EPL
Submitter: olegus8
Maintainer: neoninteger
Last Packager: neoninteger
Votes: 8
Popularity: 0.83
First Submitted: 2014-05-09 22:02 (UTC)
Last Updated: 2022-11-24 12:15 (UTC)

Dependencies (1)

Required by (0)

Sources (3)

Latest Comments

neoninteger commented on 2022-11-24 12:26 (UTC) (edited on 2022-11-24 12:27 (UTC) by neoninteger)

That'll do for now. It works, its up-to-date, and the licensing has been fixed (the licenses for the bundled dependencies are now also included in the package).

Still TODO:

Is java-environment the right dependency? According to the Java Packaging Guidelines and pacman output, java-environment is the full Java Development Kit. We may only need java-runtime instead of java-environment. This will likely require chroot testing for confirmation.

We should build this from source if possible, rather than pull a pre-built version from NPM. The packaging guidelines are unclear about whether this is acceptable. For pre-built native code packages, the package name needs to be suffixed with -bin. No such rule seems to exist for Java packages. But bundled dependencies are likely to be a bad idea that we should move away from if vNu's build system can handle that.

olegus8 commented on 2018-01-03 01:13 (UTC)

Hey Simon04, thanks for adopting this!