Package Details: valide 0.7.2-2

Git Clone URL: https://aur.archlinux.org/valide.git (read-only, click to copy)
Package Base: valide
Description: Val(a)IDE is an Integrated Development Environment for the Vala programming language (Tarnyko branch).
Upstream URL: http://www.tarnyko.net/en/?q=node/24
Licenses: GPL3
Submitter: None
Maintainer: Muflone
Last Packager: Muflone
Votes: 22
Popularity: 0.000000
First Submitted: 2008-06-02 03:34 (UTC)
Last Updated: 2018-03-25 19:58 (UTC)

Latest Comments

Muflone commented on 2018-03-25 20:00 (UTC)

all the dependencies were restored

FabioLolix commented on 2018-02-18 19:40 (UTC)

gdl2 is no more

Muflone commented on 2014-04-12 09:23 (UTC)

@Alister.Hood Actually the Tarnyko website is up and working The bzr version is provided by the valide-bzr package https://aur.archlinux.org/packages/valide-bzr/

Muflone commented on 2013-11-15 14:00 (UTC)

Version 0.7.2 with autocompletion from Tarnyko branch as the original project seems dead

Muflone commented on 2013-11-13 23:55 (UTC)

Package adopted and fixed. It now builds fine using the package vala0.12 (note, not the vala-012 package).

xyproto commented on 2013-09-13 14:50 (UTC)

@evilgnome Ok, someone should adopt and update this package, then.

andykluger commented on 2013-03-27 22:32 (UTC)

Actually development is still happening, see http://www.tarnyko.net/en/?q=node/24 and https://code.launchpad.net/~tarnyko/valide/trunk

xyproto commented on 2013-03-21 11:05 (UTC)

This package seems to have been discontinued. valaide.org is about college choices. Please request for this package to be removed at aur-general@archlinux.org and include a link to this page.

Alister.Hood commented on 2012-04-02 06:19 (UTC)

It builds OK if you install "vala-012" and run this: export PKG_CONFIG_PATH=/opt/vala-0.12/lib/pkgconfig/ export PATH=/opt/vala-0.12/bin/:$PATH

commented on 2012-01-05 09:58 (UTC)

Checking for libvala-0.12 >= 0.12.0 : Package libvala-0.12 was not found in the pkg-config search path. Has someone fixed this error?

z0id commented on 2011-10-29 18:30 (UTC)

I get Checking for libvala-0.12 >= 0.12.0 : Package libvala-0.12 was not found in the pkg-config search path. [...] What package provides libvala?

commented on 2011-08-27 19:06 (UTC)

the gdl-1.0.pc dependency problem is still not fixed, anyone know how to fix it? I install gdl 2.91.92 and gdl 3.1.5 still not solve the dependecy problem,

commented on 2011-07-31 08:09 (UTC)

gdl2 from AUR provides gdl-1.0.pc - maybe the dependency should be on gdl2?

kiefer commented on 2011-07-24 03:37 (UTC)

To install this application also need gdl2

yannicklm commented on 2011-06-02 14:59 (UTC)

The above error is normal, valide is not gtk3 compatible yet. There is a gtk3 bzr branch support for valide, you can try that: https://code.launchpad.net/~valide/valide/gtk+-3.0

medeo commented on 2011-04-30 13:54 (UTC)

i get this error: Checking for gdl-1.0 >= 2.28 : Package gdl-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gdl-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gdl-1.0' found /tmp/yaourt-tmp-medeo/aur-valide/src/valide-0.7.1/wscript:54: error: the configuration failed (see '/tmp/yaourt-tmp-medeo/aur-valide/src/valide-0.7.1/_build_/config.log')

medeo commented on 2011-04-30 11:40 (UTC)

i get this error: Checking for gdl-1.0 >= 2.28 : Package gdl-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gdl-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gdl-1.0' found /tmp/yaourt-tmp-medeo/aur-valide/src/valide-0.7.1/wscript:54: error: the configuration failed (see '/tmp/yaourt-tmp-medeo/aur-valide/src/valide-0.7.1/_build_/config.log')

Damon commented on 2011-03-13 21:54 (UTC)

> The package makes a configure error: Package vala-1.0 was not found in the pkg-config search path. I get this error, too.

timosa commented on 2011-03-06 09:29 (UTC)

The package makes a configure error: Package vala-1.0 was not found in the pkg-config search path.

commented on 2011-01-10 22:21 (UTC)

When is it released the new version?

commented on 2011-01-06 07:25 (UTC)

> how can I fix this???? Probably waiting the next release. The pkg file name is diferrent since vala 0.10.

commented on 2011-01-06 04:58 (UTC)

Checking for vala-1.0 >= 0.8.1 : Package vala-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `vala-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'vala-1.0' found error: the configuration failed (see '/tmp/yaourt-tmp-brando/aur-valide/src/valide-0.7.0/_build_/config.log') how can I fix this????

LeCrayonVert commented on 2011-01-05 21:53 (UTC)

gege2061 > thanks ! I did not notice your previous message...sorry ;)

commented on 2011-01-05 19:08 (UTC)

@LeCrayonVert: All bugs fixed

commented on 2010-12-12 15:53 (UTC)

The latest point isn't normal, can you explain it or post an issue on the new project page: https://launchpad.net/valide FYI: https://answers.launchpad.net/valide/+question/136791

LeCrayonVert commented on 2010-12-10 16:25 (UTC)

Up !

LeCrayonVert commented on 2010-12-01 12:58 (UTC)

valide won't compile because of pkg-config (and btw, there is no PKG_CONFIG_PATH variable) valide-svn is obsolete as the code has been moved to launchpad (it should be removed from AUR) valide-bzr raises IOError in wscript_build during compilation

commented on 2010-11-20 01:53 (UTC)

So how can I fix this to compile valide??

commented on 2010-11-19 11:43 (UTC)

The name of the pkg-config file has changed with vala >= 0.10

commented on 2010-11-19 04:30 (UTC)

I'm getting this error message: Checking for vala-1.0 >= 0.8.1 : Package vala-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `vala-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'vala-1.0' found But there is no vala 1.0.

napa3um commented on 2010-05-12 17:24 (UTC)

need pkgbuild for build

commented on 2010-05-11 22:05 (UTC)

> In addition to the below errors, intltool needs to be included in the depends. Why? It's just a dependency for building.

commented on 2010-04-15 07:17 (UTC)

It's an incompatibility with newest versions of vala.

commented on 2010-04-15 03:07 (UTC)

Linas, did you build it?

commented on 2010-04-15 03:03 (UTC)

Linas, did you build it?

Linas commented on 2010-04-14 11:24 (UTC)

In addition to the below errors, intltool needs to be included in the depends.

napa3um commented on 2010-04-11 08:52 (UTC)

too

commented on 2010-04-04 03:39 (UTC)

Same error here.

commented on 2010-04-03 03:03 (UTC)

libvalide/libyaml-glib/src/builder.vala:111.32-111.40: warning: deprecated syntax, use [CCode (has_target = false)] libvalide/libyaml-glib/src/builder.vala:520.32-520.39: warning: deprecated syntax, use [CCode (has_target = false)] libvalide/start-page.vala:57.3-57.11: error: class already contains a constructor libvalide/abstract-text-document.vala:176.15-176.27: error: only automatic properties can have default values Waf: Leaving directory `/tmp/yaourt-tmp-root/aur-valide/valide/src/valide-0.6.1/_build_' Build failed -> task failed (err #1): {task: valac_task utils.vala,encoding.vala,document-close-dialog.vala,searching.vala,compiler.vala,abstract-config-manager.vala,recent-manager-ui.vala,uimanager.vala,document-manager.vala,builder-manager.vala,split-source-view.vala,template.vala,statusbar.vala,project-dialog.vala,plugin.vala,loader.vala,buildable.vala,writer.vala,libyaml-glib.vala,builder.vala,error.vala,project.vala,start-page.vala,plugin-registrar.vala,document-message.vala,plugin-manager.vala,plugin-preferences.vala,template-manager.vala,preferences-dialog.vala,document.vala,goto-dialog.vala,config-manager.vala,valac.vala,project-dialog-remove.vala,source-buffer.vala,abstract-text-document.vala,aboutdialog.vala,project-manager.vala,builder.vala,project-dialog-options.vala,idocument.vala,panel.vala,window.vala,executable-manager.vala,abstract-preferences-dialog.vala,abstract-executable-preferences.vala,abstract-project-dialog-options.vala,abstract-project-dialog-remove.vala,abstract-project-dialog.vala,abstract-native-builder-preferences.vala,abstract-close-dialog.vala,native-builder.vala,source-view.vala,executable.vala -> utils.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,encoding.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,document-close-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,searching.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,compiler.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-config-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,recent-manager-ui.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,uimanager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,document-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,builder-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,split-source-view.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,template.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,statusbar.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,project-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,plugin.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,loader.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,buildable.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,writer.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,libyaml-glib.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,builder.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,error.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,project.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,start-page.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,plugin-registrar.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,document-message.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,plugin-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,plugin-preferences.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,template-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,preferences-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,document.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,goto-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,config-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,valac.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,project-dialog-remove.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,source-buffer.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-text-document.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,aboutdialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,project-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,builder.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,project-dialog-options.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,idocument.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,panel.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,window.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,executable-manager.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-preferences-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-executable-preferences.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-project-dialog-options.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-project-dialog-remove.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-project-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-native-builder-preferences.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,abstract-close-dialog.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,native-builder.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,source-view.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,executable.c,valide-0.0.h,valide-0.0.vapi,valide-0.0.deps,valide-0.0.h} ==> BŁĄD: Budowanie nie powiodło się. Przerywam... Error: Makepkg was unable to build valide package.