Package Details: vapoursynth-plugin-mlrt-trt-runtime-git 609.cfe4933-1

Git Clone URL: https://aur.archlinux.org/vapoursynth-plugin-mlrt-trt-runtime-git.git (read-only, click to copy)
Package Base: vapoursynth-plugin-mlrt-trt-runtime-git
Description: Plugin for VapourSynth: mlrt (TensorRT runtime: recommended for Nvidia GPUs >=8GB VRAM)
Upstream URL: https://github.com/AmusementClub/vs-mlrt
Licenses: LGPL
Conflicts: vapoursynth-plugin-mlrt-ncnn-runtime-git, vapoursynth-plugin-mlrt-ort-runtime-git, vapoursynth-plugin-mlrt-ov-runtime-git
Provides: vapoursynth-plugin-mlrt
Submitter: jholmer
Maintainer: jholmer
Last Packager: jholmer
Votes: 0
Popularity: 0.000000
First Submitted: 2024-06-15 01:42 (UTC)
Last Updated: 2024-07-08 20:36 (UTC)

Required by (0)

Sources (2)

Latest Comments

jholmer commented on 2024-07-08 20:36 (UTC)

Thanks, I've updated the pkgbuild with the suggestions

spacemann commented on 2024-07-03 20:18 (UTC)

I noticed that this doesn't pull the models artifact from the latest release of the github repo for the project, and there's a v15 release now. The v15 version of the models artifact is the same size as the v14 models artifact, so it likely doesn't really matter, but I figured it might be good to update this PKGBUILD so that it automatically seeks out the newest models artifact (since this is a -git AUR repo).

Anyway, here's a patch for the PKGBUILD that does this:

diff --git a/PKGBUILD b/PKGBUILD
index 3cd80b4..c589089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,30 @@

 _plug=mlrt
 pkgname=vapoursynth-plugin-${_plug}-trt-runtime-git
-pkgver=598.460f978
+pkgver=602.99825d0
 pkgrel=1
 pkgdesc="Plugin for VapourSynth: ${_plug} (TensorRT runtime: recommended for Nvidia GPUs >=8GB VRAM)"
 arch=('x86_64')
 url='https://github.com/AmusementClub/vs-mlrt'
 license=('LGPL')
 depends=('vapoursynth' 'cuda' 'tensorrt')
-makedepends=('git' 'ninja' 'cmake')
+makedepends=('git' 'ninja' 'cmake' 'jq')
 provides=("vapoursynth-plugin-${_plug}")
 conflicts=("vapoursynth-plugin-${_plug}-ov-runtime-git"
   "vapoursynth-plugin-${_plug}-ort-runtime-git"
   "vapoursynth-plugin-${_plug}-ncnn-runtime-git")
+
+# Function to fetch the latest release version
+get_latest_release_version() {
+  curl --silent "https://api.github.com/repos/AmusementClub/vs-mlrt/releases/latest" | jq -r .tag_name
+}
+
+# Fetch the latest release version
+latest_release=$(get_latest_release_version)
+
 source=("${_plug}::git+https://github.com/AmusementClub/vs-mlrt.git"
-  models-v14.7z::https://github.com/AmusementClub/vs-mlrt/releases/download/v14/models.v14.7z)
-sha256sums=('SKIP' '19dd9e312b5a6961d76527871d13ef2767bab4dce955ded41f107fb179acb1e0')
+  "models-${latest_release}.7z::https://github.com/AmusementClub/vs-mlrt/releases/download/${latest_release}/models.${latest_release}.7z")
+sha256sums=('SKIP' 'SKIP')

 pkgver() {
   cd "${_plug}"
@@ -56,3 +65,4 @@ package() {
   install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
   install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
 }
+