Package Details: vapoursynth-plugin-vsdenoise-git 2.4.0.3.ga540892-1

Git Clone URL: https://aur.archlinux.org/vapoursynth-plugin-vsdenoise-git.git (read-only, click to copy)
Package Base: vapoursynth-plugin-vsdenoise-git
Description: Plugin for Vapoursynth: vsdenoise (GIT version)
Upstream URL: https://github.com/Irrational-Encoding-Wizardry/vs-denoise
Keywords: vapoursynth
Licenses: MIT
Conflicts: vapoursynth-plugin-vsdenoise
Provides: vapoursynth-plugin-vsdenoise
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 1
Popularity: 0.000605
First Submitted: 2022-11-18 15:17 (UTC)
Last Updated: 2023-08-31 22:52 (UTC)

Latest Comments

gourdcaptain commented on 2023-09-01 21:57 (UTC)

A bunch of other vapoursynth plugin updates today seem to have fixed it all together, but when it was happening, you could just open up python3 in a terminal and do import vsdenoise and it would happen.

sl1pkn07 commented on 2023-08-31 22:33 (UTC)

can you share a little snipplet of the script? for try replicate in my environment

greetings

gourdcaptain commented on 2023-08-31 22:20 (UTC) (edited on 2023-08-31 22:21 (UTC) by gourdcaptain)

Currently giving me issues of:

ImportError: cannot import name 'MeanMode' from 'vsrgtools' (/usr/lib/python3.11/site-packages/vsrgtools/__init__.py)
>>> import vsrgtools
>>> import vsdenoise
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.11/site-packages/vsdenoise/__init__.py", line 7, in <module>
    from .freqs import *
  File "/usr/lib/python3.11/site-packages/vsdenoise/freqs.py", line 5, in <module>
    from vsrgtools import MeanMode
ImportError: cannot import name 'MeanMode' from 'vsrgtools' (/usr/lib/python3.11/site-packages/vsrgtools/__init__.py)
>>> import vapoursynth as vs
KeyboardInterrupt
>>> 

when I try to import this, even with an up-to-date vapoursynth-plugin-vsrgtools-git (1.5.1.0.g81da5f7) and an older one (1.4.4.3.gbdd6d43). Not sure what it wants.

vsdenoise 2.2.0.30.g2d7fed4 does work with either version of vsrgtools.

PublicUsername commented on 2023-08-31 12:34 (UTC)

Dependencies need updating it needs vapoursynth-plugin-bm3dcuda-git and vapoursynth-plugin-bm3dcuda-cpu-git to run the BM3DCUDA or BM3DCPU function.