Package Details: vcsh-git 1:1.20151229.1.r0.g87bccfd-1

Git Clone URL: https://aur.archlinux.org/vcsh-git.git (read-only)
Package Base: vcsh-git
Description: manage config files in HOME via fake bare git repositories
Upstream URL: https://github.com/RichiH/vcsh
Keywords: configuration dotconfig git management
Licenses: GPL
Conflicts: vcsh
Provides: vcsh
Submitter: Dieter_be
Maintainer: milk
Last Packager: xaocon
Votes: 10
Popularity: 0.002051
First Submitted: 2011-11-20 12:14
Last Updated: 2016-01-24 18:34

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

1 2 3 Next › Last »

milk commented on 2019-04-25 23:34

So, FYI:

vcsh development is on hiatus. This package points to the debian branch, which is stale. My hope was to upgrade to master, which has commits up to half way between now and the last change to the debian branch. Problem is that there are build breaking test fails on master, see issue: https://github.com/RichiH/vcsh/issues/261

There is an apparently active fork, but I'm holding off switching the package to that until the situation becomes clearer.

The other potential option is to edit out the tests from the build in the prepare().

caleb commented on 2018-08-10 06:26

@xaocon if you don't want to maintain this, please orphan it. I'd be happy to keep it up to date. At the moment it's a *-git package that's building from a release-only branch. It should be building from the branch where development is actually happening. The resulting install is several years out of date.

vlowrian commented on 2015-05-26 20:29

Some unit tests added new dependencies. If you compile this on a fresh system, you also need perl-shell-command (AUR) and perl-test-most (AUR). Please add those dependencies.

xaocon commented on 2014-06-23 07:21

I've taken over the package. I've added ronn back because the static branch doesn't seem to always match master and I preferred building for yourself for the -git package. I'll track how future commits are handled.

chetgray commented on 2014-06-12 21:31

Upstream is building manpages in the manpage-static branch. Pulling source from that branch, ruby-ronn is no longer a build requirement. I don't use vcsh any more, so I'm disowning. Feel free to take over.

pspeder commented on 2014-05-26 08:56

I resolved it by un- and then reinstalling ruby-ronn from aur.

chetgray commented on 2014-02-09 16:26

Someone is having the same issue with the non-devel vcsh package. I wasn't able to replicate, but I'll try some more.

vcsh.1 is generated in the Makefile from vcsh.1.ronn with ronn from ruby-ronn. If vcsh.1 isn't found by install, then its generation may have been prevented by a problem with ronn or the Makefile.

kodiak commented on 2014-02-09 15:14

with newest version I get: "install: cannot stat ‘vcsh.1’: No such file or directory"

xaocon commented on 2013-09-24 14:24

Yeah I saw it was building from HEAD. I just know that people use automated tools that don't rebuild until there is a version bump. Of course, how you want to handle versions is up to you. Glad I could help.

chetgray commented on 2013-09-24 08:42

Tagged release PKGBUILD now in AUR: https://aur.archlinux.org/packages/vcsh/