Package Details: vcvrack-git 1.1.6.r18.ga5fc5891-9

Git Clone URL: https://aur.archlinux.org/vcvrack-git.git (read-only, click to copy)
Package Base: vcvrack-git
Description: Open-source virtual Eurorack DAW
Upstream URL: https://github.com/VCVRack/Rack
Keywords: analog audio synthesizer VCVrack
Licenses: BSD
Conflicts: vcvrack
Provides: vcvrack
Submitter: mkoskar
Maintainer: Popolon
Last Packager: Popolon
Votes: 7
Popularity: 0.000000
First Submitted: 2017-09-19 17:33 (UTC)
Last Updated: 2022-03-18 20:55 (UTC)

Required by (27)

Sources (3)

Pinned Comments

Popolon commented on 2021-12-03 11:32 (UTC) (edited on 2022-01-01 20:41 (UTC) by Popolon)

Everything work now with 1.1.6 (force v1 branch). You can compile 2.0.1 version by just replacing _branchname from v1 to v2:

_branchname=v2

But plugins don't work with new version, need to patch them.

https://aur.archlinux.org/packages/cardinal-git/ package is an interesting alternative integrating lot of plugins a more linux way.

Here is the working AUR set with vcvrack-git 1.1.6.r18.ga5fc5891-1:

vcvrack-audible-instruments-git 1.4.0.r6.g8c7fd24-2
vcvrack-befaco-git r64.5014a93-1
vcvrack-eseries 1.0-1
vcvrack-fundamental 1.4.0-1
vcvrack-mental-git r116.1660a55-1

Latest Comments

1 2 3 Next › Last »

Popolon commented on 2022-03-18 20:56 (UTC)

OOps thank you, there was 3 typos: : => =, ,=>; and a ; missing at the end of the line

nyanpasu64 commented on 2022-03-12 05:17 (UTC)

Your .desktop file is invalid, it contains Keywords:music;multimedia;synthesizer,midi when it should be Keywords=.... This causes update-desktop-database and kbuildsycoca5 and kmenuedit to complain trying to parse that file.

I haven't checked whether the file is otherwise valid or not.

phunni commented on 2021-12-08 18:07 (UTC)

I used this to build version 2 (using _branchname=v2 as mentioned in other comments) and I can't login. It always just says "No response from server". Is anyone else experiencing anything like this? Rack 1 always logged in perfectly well...

Popolon commented on 2021-12-03 11:32 (UTC) (edited on 2022-01-01 20:41 (UTC) by Popolon)

Everything work now with 1.1.6 (force v1 branch). You can compile 2.0.1 version by just replacing _branchname from v1 to v2:

_branchname=v2

But plugins don't work with new version, need to patch them.

https://aur.archlinux.org/packages/cardinal-git/ package is an interesting alternative integrating lot of plugins a more linux way.

Here is the working AUR set with vcvrack-git 1.1.6.r18.ga5fc5891-1:

vcvrack-audible-instruments-git 1.4.0.r6.g8c7fd24-2
vcvrack-befaco-git r64.5014a93-1
vcvrack-eseries 1.0-1
vcvrack-fundamental 1.4.0-1
vcvrack-mental-git r116.1660a55-1

eggix commented on 2021-12-03 10:24 (UTC)

Minimal working example for PKGBUILD after the update to 2.0. Bump to gtk3.

Popolon commented on 2021-06-11 10:08 (UTC) (edited on 2021-06-11 10:53 (UTC) by Popolon)

Thank's for the catch. If openssl is removed, it download by itself, more recent but still outdated version of Openssl (1.1.1d, today is 1.1.1k) and curl tried 7.77 it keep 7.66 :(. I removed those dependencies that are now useless. Someone need to ask upstream to update these libs. Updated with removed PKGBUILD libs download, let the VCVRack make do it by itself (but without control sum verification).

Netboy3 commented on 2021-06-08 21:02 (UTC)

Why are you vendoring all those dependencies? Why not "depends" all those like any other package? Surely we don't need to grab libzib, openssl, curl etc... sources just to build VCV. Vendoring dependencies is a bad practice and a security risk. For example, your version of openssl is 2.5 years old and has at least 4 known vulnerabilities, yet you still vendor it here.

Popolon commented on 2021-04-18 08:19 (UTC) (edited on 2021-04-18 11:08 (UTC) by Popolon)

I had the time this morning to verify. I added installation of include files adapting current vcvrack packages rules. I was able to compile vcvrack-eseries-git with this. Just noticed that I forgot 2 files, so input/output/midi din't work. that's fine now. I also updated fundamentals so it uses /opt/vcvrack/plugins dir

Popolon commented on 2021-03-31 23:22 (UTC) (edited on 2021-03-31 23:52 (UTC) by Popolon)

This update work. git plugin I compiled last year (vcvrack-*-git) work with it. I didn't tried to compiled them again for now. At least, the last git version basic VCVRack work :).

flying-sheep commented on 2020-04-19 15:54 (UTC) (edited on 2020-04-20 17:04 (UTC) by flying-sheep)

Hi, I just changed the gtk2 dependency to gtk3 upstream. Please update.

You need to update depends and FLAGS=... in build