Package Details: vdr 2.6.6-1

Git Clone URL: https://aur.archlinux.org/vdr.git (read-only, click to copy)
Package Base: vdr
Description: 'open' digital satellite receiver and timer controlled video disk recorder
Upstream URL: http://tvdr.de/
Licenses: GPL-2.0-or-later
Conflicts: runvdr-extreme
Provides: vdr-api
Replaces: runvdr-extreme
Submitter: lotho
Maintainer: CReimer (M-Reimer)
Last Packager: M-Reimer
Votes: 63
Popularity: 0.002266
First Submitted: 2006-06-19 17:17 (UTC)
Last Updated: 2024-01-28 21:56 (UTC)

Dependencies (16)

Required by (113)

Sources (12)

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

M-Reimer commented on 2024-01-31 15:18 (UTC)

I guess none will be able to do this. Pacman is able to resolve this internally if it has a full repo with all packages.

If you build VDR, first, with existing plugins installed, then you can't install VDR as doing this will kill the dependency of all installed plugins. BUT without installing the new VDR you can't update your plugins (meaning rebuild them).

An AUR helper would basically have to resolve this manually to find out that it is OK to force install VDR in this case to have it for building all the plugins.

VDR including all plugins was never planned to be built with an AUR helper and as you will always get this deadlock when manually building packages, the only way is to force install the built VDR package and then upgrade all plugins.

stephan.loescher commented on 2024-01-30 19:52 (UTC)

I tried it with all available AUR helpers, but none of them was able to resolve the right update order. Could you please shortly advise how you did prebuild the repo and added it as a local file repo?

stephan.loescher commented on 2024-01-16 20:01 (UTC)

It does not work, because it fails at rebuilding vdr-markad:

Validating source files with sha256sums... vdr-markad-3.4.3.tar.gz ... FAILED

But after this is fixed, I'll re-try it with your suggestion!

M-Reimer commented on 2024-01-11 15:35 (UTC)

Does it work with "yay -Syu"?

All I can tell you is that it works absolutely fine if you prebuild the repo, add it as a local file repo and then run "pacman -Syu". If yay is not able to know that "vdr" is to be built first and then satisfies the "vdr-api" dependency, then yay is broken.

stephan.loescher commented on 2024-01-10 20:21 (UTC)

Thanks for providing this VDR AUR package! Is there a smooth way to update VDR including its packages? My "yay -Sua" ends with: error: failed to prepare transaction (could not satisfy dependencies) :: installing vdr (2.6.5-1) breaks dependency 'vdr-api=2.6.3' required by vdr-epgsearch :: installing vdr (2.6.5-1) breaks dependency 'vdr-api=2.6.3' required by vdr-femon :: installing vdr (2.6.5-1) breaks dependency 'vdr-api=2.6.3' required by vdr-markad s:: installing vdr (2.6.5-1) breaks dependency 'vdr-api=2.6.3' required by vdr-streamdev-server :: installing vdr (2.6.5-1) breaks dependency 'vdr-api=2.6.3' required by vdr-xineliboutput I know, I can deinstall all packages and install them again, but is this the only way?

simona commented on 2021-05-01 12:26 (UTC)

i have erased vdr-api and now is ok

M-Reimer commented on 2021-05-01 11:09 (UTC)

I don't know what the problem is. Please describe more in detail if the problem still exists.

AND please describe in English language. If needed, use "Google Translate". Really helps me if I can read comments "on the go" without fiddling around with my smartphone to get comments copied into Google Translate.

simona commented on 2021-05-01 10:14 (UTC)

erased vdr-api

simona commented on 2021-05-01 10:13 (UTC)

:: l'installazione di vdr (2.4.7-1) interrompe la dipendenza 'vdr=2.4.6' richiesta da vdr-api

schnere commented on 2019-06-29 10:07 (UTC)

Hi, could you please add aarch64 to the architecture list in PKGBUILD? Would be good for the plugins, too.