Package Details: vdr-plugin-sc-hg 574-4

Git Clone URL: (read-only)
Package Base: vdr-plugin-sc-hg
Description: A sc plugin for archvdr project (
Upstream URL:
Licenses: GPL
Conflicts: vdr-sc
Submitter: knedlyk
Maintainer: knedlyk
Last Packager: knedlyk
Votes: 5
Popularity: 0.000000
First Submitted: 2009-09-04 21:45
Last Updated: 2015-06-23 21:31

Dependencies (2)

Required by (0)

Sources (5)

  • 01_Makefile-MAXCAID.dpatch
  • commands.vdr-sc.conf
  • reload-softcam.key
  • vdr-plugin-sc.groups

Latest Comments

Anonymous comment on 2011-12-10 17:16

Builds without problem. Thanks!

Best regards,

knedlyk commented on 2011-12-09 00:47

@cdwijs: I found a mistake in PKGBUILD, can you please test it?

Anonymous comment on 2011-12-08 20:09

I had the following error:
make[1]: Entering directory `/storage/home/cedric/vdr/archvdr/trunk/vdr-plugin-sc-hg/src/sc-build/FFdecsa'
g++ -Wall -fPIC -g -O3 -mmmx -fomit-frame-pointer -fexpensive-optimizations -funroll-loops -march=pentium -DPARALLEL_MODE=PARALLEL_32_INT -c FFdecsa.c
FFdecsa.c:1:0: error: CPU you selected does not support x86-64 instruction set
FFdecsa.c:1:0: error: CPU you selected does not support x86-64 instruction set
make[1]: *** [FFdecsa.o] Error 1
make[1]: Leaving directory `/storage/home/cedric/vdr/archvdr/trunk/vdr-plugin-sc-hg/src/sc-build/FFdecsa'
make: *** [FFdecsa/FFdecsa.o] Error 2
==> ERROR: A failure occurred in build().

This is because I have a 64 bit processor, and the makefile asks for a pentium processor wich is not 64 bit. To solve it edit the following file:

Replace this line:
FLAGS ?= -Wall -fPIC -O3 -march=pentium -mmmx -fomit-frame-pointer -fexpensive-optimizations -funroll-loops
By this line:
FLAGS ?= -Wall -fPIC -O3 -march=x86-64 -mmmx -fomit-frame-pointer -fexpensive-optimizations -funroll-loops

Then go back to the top level directory, and issue makepkg again. Now the plugin is successfully created

I know this line can be edited by a sed command in the PKGBUILD, but I don't feel like doing that now.

Best regards,

Anonymous comment on 2010-07-24 07:19

to knedlyk:
you have mail

knedlyk commented on 2010-07-18 23:00

to shining235:
Thanks! I can do and check anything without x86-64. Can you post somewhere your package? I can also dissown mine. Then you can submit your packages in AUR.

Anonymous comment on 2010-07-17 18:33

changes in the Makefile are necessary for FFdeCSA options e.g.

CPUOPT ?= x86-64

to compile without errors I had to add the -fPIC option in /etc/makepkg.conf

knedlyk commented on 2010-07-09 22:16

Please check this PKGBUILD for x86-64 pls.

knedlyk commented on 2010-06-18 09:09

Cannot check, I have i686 architecture only, sorry.

nemster commented on 2010-06-17 19:25

does not work under x86_64