Package Details: vdr-vnsiserver 2:1.8.0.r13.g47a90dd-2

Git Clone URL: (read-only, click to copy)
Package Base: vdr-vnsiserver
Description: VDR plugin to handle Kodi clients
Upstream URL:
Licenses: GPL2
Submitter: CReimer
Maintainer: CReimer (M-Reimer)
Last Packager: M-Reimer
Votes: 6
Popularity: 0.001455
First Submitted: 2015-02-24 22:30
Last Updated: 2021-05-01 09:46

Latest Comments

mr_nuub commented on 2019-07-10 07:33

Thanks for clarifying this. Then there's no need to change. Guess I will have to write down all installed plugins, uninstall them, upgrade vdr and then rebuild and install the plugins. I use yay to handle AUR packages. AFAIK yay handles multiple AUR packages one by one, e.g. build/install PKG1 then PKG2 then PKG3 and so on. It complained during vdr upgrade, that vdr-vnsiserver and vdr-ddci2 would break and cancelled installation (and vice versa).

If VDR is written in such a fail-safe yet user-unfriendly way then I'll have to deal with it.

M-Reimer commented on 2019-07-08 15:09

There is a reason behind this, why it is done exactly this way.

The resulting package is meant to be built with the exact VDR-API version built in to be sure that installing a new VDR version which conflicts with existing plugins causes pacman to throw an error.

If you build a plugin against VDR 2.4.1, then it will only work with this version. It will not work with any lower version.

VDR 2.4.1 is what is provided here on AUR and also on our "binary repository": So that's what this plugin PKGBUILD is made to build for.

Nothing will change while upgrading packages and if the AUR helper, you use, is made well, it will actually build VDR first and then all plugins after that.

I any way you have to rebuild all plugins as for example VDR 2.4.1 will not even try to load plugin that was built against VDR 2.2.0. The API version number is coded into the plugin and VDR will refuse to load old plugins as the API used to interface to plugins changes between VDR versions in incomptabile ways.

mr_nuub commented on 2019-07-06 13:17

Please stop using exact versions for vdr-api. Exact version checks make package upgras a nightmare. This plugin requires vdr 2.2.0 or newer, so please do it like this:

line 07: _vdrapi=2.2.0

line 14: depends=('gcc-libs' "vdr-api>=${_vdrapi}")