Package Details: vencord-desktop-git r264.0f0bddb-2

Git Clone URL: https://aur.archlinux.org/vencord-desktop-git.git (read-only, click to copy)
Package Base: vencord-desktop-git
Description: A standalone Electron app that loads Discord & Vencord
Upstream URL: https://github.com/Vencord/Vesktop
Keywords: discord vencord
Licenses: GPL
Conflicts: vencord
Provides: vencord
Submitter: zt64
Maintainer: zt64
Last Packager: zt64
Votes: 3
Popularity: 0.191544
First Submitted: 2023-04-06 22:23 (UTC)
Last Updated: 2024-01-16 14:32 (UTC)

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

xiota commented on 2024-01-23 02:17 (UTC)

@zt64 I created vesktop-git and added you as comaintainer.

expo commented on 2023-12-26 01:36 (UTC)

Desktop file is broken in regards to window grouping; see https://github.com/Vencord/Vesktop/issues/305.

D3SOX commented on 2023-11-05 10:56 (UTC)

The latest commits broke the taskbar icon when it's not open on KDE Plasma again. I think it worked fine on 3888427da54f74915ab293900b01f4fcacd6068c

iliqiliev commented on 2023-10-28 14:02 (UTC)

There is a taskbar icon mismatch on Gnome that I fixed for myself by renaming the vencord.desktop to vencorddesktop.desktop to match the executable name. Hope this helps somebody

picokan commented on 2023-10-27 22:34 (UTC) (edited on 2023-10-27 22:38 (UTC) by picokan)

Can you make this package use the system electron instead of always downloading a new one and using the executable with an embedded electron?

The electron-builder configuration in this project is in the package.json file, and the rest should be explained in https://wiki.archlinux.org/title/Electron_package_guidelines.

Edit: I get build errors when compiling without node-gyp installed, I think that should also be a make dependency.

winstxnhdw commented on 2023-10-24 10:20 (UTC) (edited on 2023-10-24 10:20 (UTC) by winstxnhdw)

You forget that most developers have pnpm install via npm, and not from the AUR. This is the cause for the conflict.

FichteFoll commented on 2023-10-21 13:06 (UTC)

Whatever you are using to build this package isn't doing it properly because there is absolutely no conflict with an installed pnpm package, which is definitely required here as a build dependency.

winstxnhdw commented on 2023-09-12 16:01 (UTC)

@seqfault well, it's a pretty bad idea since it conflicts with an already installed pnpm.

seqfault commented on 2023-08-11 15:50 (UTC)

@winstxnhdw: we do, it's a vcs package. we build from latest commit here

winstxnhdw commented on 2023-08-07 00:37 (UTC)

Do we really need to depend on pnpm here? Why can't we just cURL the release and unzip instead?