Package Details: vera-desktop-environment 1.10.3-1

Git Clone URL: https://aur.archlinux.org/vera-desktop-environment.git (read-only)
Package Base: vera-desktop-environment
Description: simple, lightweight, GTK3 based desktop environment
Upstream URL: https://github.com/vera-desktop/vera
Licenses: GPL2.1
Conflicts: vera-desktop-environment-git
Provides: vera-desktop-environment-git
Replaces: vera-desktop-environment-git
Submitter: SolarAquarion
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 1
Popularity: 0.000002
First Submitted: 2015-07-19 14:22
Last Updated: 2017-02-26 13:07

Latest Comments

bebehei commented on 2016-07-24 19:44

Hi,

the depends-array has a small mistake:

The last two packages are not separated with quotes:

bad: depends=('vala' 'libpeas' 'gtk3' 'libgee06' 'vera-xsettings-git' 'gobject-introspection libxss-vapi-git')

good: depends=('vala' 'libpeas' 'gtk3' 'libgee06' 'vera-xsettings-git' 'gobject-introspection' 'libxss-vapi-git')

Cheers, Bene

LizziAS commented on 2016-03-20 18:37

Couls someone please edit this package build so that it runs correctly? Thank you!

# Maintainer: Gary DeLaney <gld1982ltd@gmail.com>

_gitroot="git://github.com/semplice/libxss-vapi.git"
_gitbranch=master
_gitname=libxss-vapi

pkgname="$_gitname-git"
pkgver=1.0.2.1
pkgrel=1
pkgdesc="X11 Screen Saver extension library (vala bindings)."
arch=(i686 x86_64)
url="https://github.com/semplice/libxss-vapi"
license=('LGPL')
groups=()
depends=('vala')
makedepends=()
provides=("${pkgname%}")
conflicts=("${pkgname%}" '${pkgname%-git}')
replaces=()
backup=()
options=()
install=
source=("${_gitname}::${_gitroot}#branch=${_gitbranch}")
noextract=()
md5sums=('SKIP')

pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "%s" "$(git describe --abbrev=0 | sed 's/[A-Za-z]*//g;s/[!@#\$%^&*()/]//g;s/-/./g')"
}


package() {
cd "$srcdir/${pkgname%-git}"
install -Dm644 xscrnsaver.vapi "${pkgdir}/usr/share/vala/vapi/xscrnsaver.vapi"
}

koesherbacon commented on 2016-03-07 02:44

I'm having a difficult time getting this to work. I have tried this with both 'vera-desktop-environment' as well as 'vera-git' and always end up with the following error:

libxss-vapi-git 1.0.2.1-1 (2015-08-10 21:05)
( Unsupported package: Potentially dangerous ! )
==> libxss-vapi-git dependencies:
- vala (already installed)


==> Continue building libxss-vapi-git ? [Y/n]
==> -----------------------------------------
==>
==> Building and installing package
==> Making package: libxss-vapi-git 1.0.2.1-1 (Sun Mar 6 18:41:07 PST 2
016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning libxss-vapi git repo...
Cloning into bare repository '/tmp/yaourt-tmp-ev/aur-libxss-vapi-git/lib
xss-vapi'...
remote: Counting objects: 15, done.
remote: Total 15 (delta 0), reused 0 (delta 0), pack-reused 15
Receiving objects: 100% (15/15), done.
Checking connectivity... done.
==> Validating source files with md5sums...
libxss-vapi ... Skipped
==> Extracting sources...
-> Creating working copy of libxss-vapi git repo...
Cloning into 'libxss-vapi'...
done.
Switched to a new branch 'makepkg'
==> Starting pkgver()...
fatal: No annotated tags can describe '47712067aa57389daa855cf6bc8bab40ed151432'.
However, there were unannotated tags: try --tags.
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version:
==> ERROR: Makepkg was unable to build libxss-vapi-git.

Does anybody have any advice for me? I tried Semplice Linux and really liked their Vera environment and would love to have it on my Arch machine.

Thanks a lot!

~ Ev

luomio commented on 2015-10-23 02:08

In file PKGBUILD, change line 39:
original:
mkdir -p $pkdir/usr/share/vera/autostart
change to:
mkdir -p $pkgdir/usr/share/vera/autostart

Just a typo, please fix it asap. :D

cokomoko commented on 2015-09-27 16:17

MKDIR /tmp/yaourt-tmp-cokomoko/aur-vera-desktop-environment/pkg/vera-desktop-environment//usr/share/xsessions
CP vera.desktop /tmp/yaourt-tmp-cokomoko/aur-vera-desktop-environment/pkg/vera-desktop-environment//usr/share/xsessions/vera.desktop
[Build complete]
mkdir: `/usr/share/vera' dizini oluşturulamıyor: Erişim engellendi
==> HATA: package() içinde bir hata oluştu.
Çıkılıyor...
┌─[cokomoko]──[cokomoko]:/tmp/yaourt-tmp-cokomoko/aur-vera-desktop-environment$

Anonymous comment on 2015-09-25 01:56

makepkg fails with

MKDIR /home/idwaker/.build/vera-desktop-environment/pkg/vera-desktop-environment//usr/share/pkgconfig
CP vera.pc /home/idwaker/.build/vera-desktop-environment/pkg/vera-desktop-environment//usr/share/pkgconfig/vera.pc
[Build complete]
mkdir: cannot create directory ‘/usr/share/vera’: Permission denied
==> ERROR: A failure occurred in package().
Aborting...

Anonymous comment on 2015-09-21 21:24

You shoud add
libxss-vapi-git
to dependencies, or you'll get this error during the build

"Unable to compile library vera:

Unable to find Vala package xscrnsaver