Package Details: vicare-scheme-git 20170615.b36131c7-1

Git Clone URL: https://aur.archlinux.org/vicare-scheme-git.git (read-only)
Package Base: vicare-scheme-git
Description: R6RS scheme implementation, from github's master branch
Upstream URL: http://marcomaggi.github.io/vicare.html
Licenses: GPL3
Conflicts: vicare-scheme
Provides: vicare-scheme
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 2
Popularity: 0.000001
First Submitted: 2014-12-19 23:33
Last Updated: 2017-06-15 21:18

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

haawda commented on 2016-05-08 21:48

Fixed upstream.

haawda commented on 2016-05-07 19:17

Confirmed and filed upstream.

ecraven commented on 2016-05-06 10:36

Something seems to be wrong about the default lib search path:

> vicare
Vicare Scheme version 0.4d0, 64-bit
Build 2016-04-27

Copyright (c) 2006-2010 Abdulaziz Ghuloum and contributors
Copyright (c) 2011-2015 Marco Maggi and contributors

vicare> (import (srfi :19))
Unhandled exception
Condition components:
1. &error
2. &who: expander
3. &message: "cannot locate library"
4. &library-resolution:
library: (srfi :19)
files: ()
vicare>

compare to adding -L:
> vicare -L /usr/lib/vicare-scheme/
Vicare Scheme version 0.4d0, 64-bit
Build 2016-04-27

Copyright (c) 2006-2010 Abdulaziz Ghuloum and contributors
Copyright (c) 2011-2015 Marco Maggi and contributors

vicare> (import (srfi :19))
vicare>