Package Details: vicious-git 2.3.3.r0.gea0c5a4-1

Git Clone URL: https://aur.archlinux.org/vicious-git.git (read-only, click to copy)
Package Base: vicious-git
Description: Widgets for the Awesome window manager
Upstream URL: https://github.com/vicious-widgets/vicious
Licenses: GPL2
Conflicts: vicious
Provides: vicious
Submitter: None
Maintainer: caleb
Last Packager: caleb
Votes: 134
Popularity: 0.001020
First Submitted: 2009-08-27 19:45
Last Updated: 2019-08-26 05:34

Dependencies (6)

Required by (3)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

bidulock commented on 2013-11-14 07:40

Thanks for the package.

Needs

provides=("vicious")
conflicts=("vicious")

in PKGBUILD.

Also,

git describe --always | sed 's|^[^0-9]*||;s|\.g[a-f0-9]*$||;s|-|.|g'

yeilds a better pkgrel.

anrxc commented on 2013-04-14 15:41

Thanks, I'll look into that.

KaiSforza commented on 2013-04-10 21:45

This should be updated to reflect the new pacman 4.1 source array and version scheme.

Anonymous comment on 2012-12-29 22:55

Ah, thanks.

anrxc commented on 2012-12-29 22:35

This will become a symlink /usr/share/lua/5.1/vicious after the upgrade. You can delete it before the upgrade.

Anonymous comment on 2012-12-29 19:05

What kind of manual intervention is required on upgrade?

Should I use --force?


(1/1) checking package integrity
(1/1) loading package files
(1/1) checking for file conflicts
error: failed to commit transaction (conflicting files)
vicious-git: /usr/share/lua/5.1/vicious exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Failed to install built package(s).

anrxc commented on 2012-12-15 21:36

Vicious is now usable with awesome and awesome-git. With lua51 and lua52.

20121215-3: Manual intervention required on upgrade.

anrxc commented on 2012-12-15 18:26

Vicious is now usable with awesome and awesome-git. With lua51 and lua52.

anrxc commented on 2012-12-15 17:12

I agree, there's just so many users whose desktop I could break.
I'll consider a notice in .install file or something like that.

cocreature commented on 2012-12-15 17:08

imho vicious stable (community) is for awesome stable and vicious-git should be for awesome-git.