Package Details: viewnior-git viewnior.1.4.r3.gfc0f5cb-1

Git Clone URL: (read-only)
Package Base: viewnior-git
Description: Simple, fast, elegant and minimalistic image viewer, written in C(GTK+) with a new GtkImageView library. Git Version
Upstream URL:
Licenses: GPL
Conflicts: viewnior
Provides: viewnior
Submitter: None
Maintainer: Florian
Last Packager: Florian
Votes: 6
Popularity: 0.000000
First Submitted: 2009-08-05 01:30
Last Updated: 2015-07-09 10:30

Required by (2)

  • passqr (requires viewnior) (optional)
  • passqr-git (requires viewnior) (optional)

Sources (1)

Latest Comments

TrialnError commented on 2015-07-09 11:44

Please change the pkgver sed command to something like this:

git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/viewnior.//'

That way the version number is a proper one and just contains numerical information

mrbit commented on 2015-02-05 11:47

Done , thanks Florian :)

Florian commented on 2015-02-05 09:29

Updated version:

orschiro commented on 2014-06-08 12:09

Why the dependency on the following two packages?


Florian commented on 2014-01-26 19:43

Sorry, I forgot about this comment. Updated PKGBUILD:

mrbit commented on 2013-11-20 16:30

Hi, FlorianD ,sorry I do not have much time, you suggest ..

Florian commented on 2013-11-20 15:35

Is it possible to update the PKGBUILD to the modern standards? Thanks.

mrbit commented on 2013-07-29 12:23

Florian commented on 2013-07-28 19:00

Fontconfig-ubuntu is not necessary. Namcap includes it because some Viewnior library probably depends on it because you have it installed. Also, please add 'viewnior' as conflicting dependency.

mrbit commented on 2013-05-16 06:29

namcap utility...!!

anonymous_user commented on 2013-05-16 04:13

May I ask why the dependencies were changed to cairo-ubuntu and fontconfig-ubuntu?

mrbit commented on 2013-03-03 08:27

Hi, browntown
with namcap utility no gnome-common dependencies ????

browntown commented on 2013-03-03 05:33

You should add in the dependencies field above that this package requires gnome-common

Anonymous comment on 2012-01-13 09:05

A solution to the linking error that user umby213 reports is to add -lm to the LDFLAGS flags. One method for doing this is to modify the PKGBUILD to add the following:

./configure LDFLAGS='-lm'

P.S. FYI, official upstream repo sources do not compile without above mentioned fix as well on my system. I am not all that sure as to why this error has suddenly popped up, but in short: changes to the DSO linking process within the GNU linker (ld).

Berseker commented on 2011-12-28 11:44

sorry but I don't use this package anymore, if you find the solution please feel free to adopt this package.
in the meantime I can suggest to install non-git version from standard repositories

KleinerMann commented on 2011-12-27 12:19

I receive this error when i run makepkg :( :
/usr/bin/ld: viewnior-uni-image-view.o: undefined reference to symbol 'floor@@GLIBC_2.0'
/usr/bin/ld: note: 'floor@@GLIBC_2.0' is defined in DSO /lib/ so try adding it to the linker command line
/lib/ could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[3]: *** [viewnior] Errore 1
make[2]: *** [all] Errore 2
make[1]: *** [all-recursive] Errore 1
make: *** [all] Errore 2
==> ERRORE: Si è verificato un errore in build().
L'operazione sta per essere interrotta...


Berseker commented on 2011-05-28 10:31

I do not get that error. Maybe a packer problem or something wrong with your connection

saleem commented on 2011-05-25 18:35

getting this error

sudo packer -S viewnior-git

Aur Targets (1): viewnior-git

Proceed with installation? [Y/n] y
Edit viewnior-git PKGBUILD with $EDITOR? [Y/n] n
==> Determining latest git revision...
-> Version found: 20110525
==> Making package: viewnior-git 20110525-1 (Wed May 25 23:32:07 PKT 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Starting build()...
==> Connecting to GIT server...
Cloning into Viewnior...
fatal: The remote end hung up unexpectedly
The build failed.

any fix please?

Berseker commented on 2010-12-18 16:33

Adopted and updated. Enjoy

Anonymous comment on 2010-10-15 12:27

Please add intltool to makedepends and x86_64 to archs.

anonymous_user commented on 2010-08-13 16:00

@Berseker - thanks for the working PKGBUILD. Also I experience this same bug:

anonymous_user commented on 2010-07-16 20:34

Why is gnome-common needed to build Viewnior?

Berseker commented on 2010-07-02 14:32

working PKGBUILD updated at today
- added x86_64 deps
- modified install prefix (like viewnior in community)

cotton commented on 2010-03-27 10:55

After adding x86_64, it fails to build:
==> Starting make...
/var/abs/local/viewnior-git/PKGBUILD: line 29: ./ No such file or directory
/var/abs/local/viewnior-git/PKGBUILD: line 30: ./configure: No such file or directory
make: *** No targets specified and no makefile found. Stop.
==> ERROR: Build Failed.