Package Details: vim-airline-git 1:0.8.r237.g4a47cd7-2

Git Clone URL: https://aur.archlinux.org/vim-airline-git.git (read-only, click to copy)
Package Base: vim-airline-git
Description: A lean & mean statusline for vim that's light as air.
Upstream URL: https://github.com/vim-airline/vim-airline
Licenses: MIT
Conflicts: vim-airline
Provides: vim-airline
Submitter: arielp
Maintainer: Rhinoceros
Last Packager: Rhinoceros
Votes: 25
Popularity: 0.000000
First Submitted: 2013-07-02 12:08 (UTC)
Last Updated: 2017-04-19 03:41 (UTC)

Required by (13)

Sources (1)

Latest Comments

Rhinoceros commented on 2016-02-02 10:23 (UTC) (edited on 2016-02-02 10:24 (UTC) by Rhinoceros)

Okay, vim-airline-themes-git is now live, so install that package to get back your custom theme. https://aur.archlinux.org/packages/vim-airline-themes-git/

Rhinoceros commented on 2016-02-02 06:28 (UTC)

Adopted and updated. I'll create a new vim-airline-themes-git package in a few hours when I get time. I decided to split it off so each can be updated independently.

arielp commented on 2016-02-02 03:41 (UTC)

I am just going to go ahead and orphan this stuff. You guys clearly care about this more than I do.

rtfm3514 commented on 2016-02-01 12:46 (UTC)

Also, it seems the Git URL changed recently ("bling" -> "vim-airline"). Package is currently broken. E-Mail me, if you are interested in a PKGBUILD implementing a separate vim-airline-themes-git package, I quickly put one together as my favorite solarized theme was gone :( And also e-mail, if you are not, please :) Then I will just maintain it myself. Unless you are planning on taking Rhinoceros' suggestion and adding all of the themes by default. Thanks.

Rhinoceros commented on 2016-01-31 23:26 (UTC)

Thanks for fixing the conflict. I also just noticed that the themes have been split into a separate repository [1]. I wonder if you'd consider maintaining this as an opt-depends? Alternatively, perhaps it'd be simpler to install this by default as part of vim-airline-git. All of the themes together are only 200 kB. (You just need to install the themes, e.g. badwolf.vim, into /usr/share/vim/vimfiles/autoload/airline/themes/ .) [1] https://github.com/vim-airline/vim-airline-themes

arielp commented on 2016-01-22 18:21 (UTC)

Rhinoceros: I'm currently on vacation. I'll get to this in about 2 weeks.

Rhinoceros commented on 2016-01-20 03:42 (UTC)

This package should conflict with vim-airline.

howardad commented on 2014-08-19 22:01 (UTC)

Please add AUR metadata to this package to stop pacaur's nagging. :)

arielp commented on 2014-04-11 20:49 (UTC)

That should bring it up to date. Anyone still having issues?

arielp commented on 2014-04-10 04:37 (UTC)

Yeah, I'm still here. I've got some obligations this weekend, but I'll take care of it soon.

tom.swartz07 commented on 2014-04-09 19:25 (UTC)

Is this package still being maintained? It's quite a ways behind the upstream.

HalosGhost commented on 2014-01-06 01:26 (UTC)

Mind adding 'vim-fugitive' to the optdepends list for git branch support? All the best,

arielp commented on 2013-07-05 15:10 (UTC)

brotatos: Should be fixed up now. There are a few different themes to check out.

brotatos commented on 2013-07-05 01:48 (UTC)

I'm getting build errors. ==> Starting package()... install: cannot stat ‘autoload/airline/themes/default.vim’: No such file or directory ==> ERROR: A failure occurred in package(). Aborting... error making package `vim-airline-git', try again? [Y/n]